World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Tip: Those with Geforce 4 cards that are experiencing regular crashing with legacy drivers on Ubuntu
Adil Karim
Adil Karim
Posted 2007-04-10 11:39
I havn't tested this with anything other than Ubuntu.

With the new nVidia drivers, the Geforce 4 series has been relegated to the legacy driver system. Unfortunately, it doesn't work.

So in order to get it all running again you need to downgrade to the 9631 version.

I made a little howto to do this:

Firstly you need to get the package from here:

ftp://download.nvidia.com/XFree86/Linux-x86/1.0-9631/NVIDIA-Linux-x86-1.0-9631-pkg1.run


1. REMOVE ALL PREVIOUS NVIDIA DRIVERS. This simple step that is omitted in most guides is what caused X11 crash on startup and API mismatch errors. Not pretty.

Remember, when removing these drivers, remove nvidia-glx, nvidia-glx-legacy AND nvidia-kernel-common (or whatever the last one is called). Otherwise the X11 will default to the newer kernel and will not recognise the older drivers. You can do all of this through the Synaptic Package Manager. (System->Administration->Synaptic Package Manager).

2. Install the Xorg SDK package required to compile the driver. This package is called xserver-xorg-dev in Synaptic Package Manager.

3. Install headers required for kernel compilation. Open up terminal and type:
sudo apt-get install linux-headers-$(uname -r) build-essential

4. Close down X. This means going to TTY (CTRL+ALT+1 or CTRL+ALT+(2-6)) and logging in. Then type:
sudo /etc/init.d/gdm stop

5. Run the nVidia driver installation program:

Firstly, navigate to the place where you downloaded the package. I downloaded it to the home directory so for me, I type in
cd ~

In general:
cd (...)

where (…) is the path to your download directory.

Now that we are in the directory, we need to run the package as root.

sudo sh ./NVIDIA

The tab button should bring up the filename, but you could enter it in longhand:
sudo sh ./NVIDIA-Linux-x86-1.0-9631-pkg1.run

6. Follow installation instructions, don’t worry if it can’t find the kernel interface from the web, let it compile the kernel module. If you get any errors, like it couldn’t open a folder, just try again, worked for me 😊.

7. When it asks you to configure your xorg.conf file, if you have already set up your own custom settings, for Beryl, par example. Then you’d want to keep your old settings. However, for most people, you’d want the auto-config.

8. I recommend typing in:
sudo nano /etc/X11/xorg.conf

and search for “Section “Device”"

Then look for the part which says “Drivers”

If the next part is “nv” change that to “nvidia” however, if it is already “nvidia” then you’re done!

9. Some people, esepcially people who are running composite-enabled window-managers (Beryl, Compiz) need to have “argb-glx-visuals” on. To do this, simply type at the command line:
sudo nvidia-xconfig --add-argb-glx-visuals

10. Now that you have finished installation, I recommend you reboot. However, if you’re feeling adventurous, you can restart X11 from the command line:
sudo /etc/init.d/gdm restart

If you are having troubles or would like something more in-depth, visit the Wiki where I got most of this information from:

http://wiki.beryl-project.org/wiki/Install_Beryl_on_Ubuntu_Edgy_with_nVidia

I also have my full howto here:

http://www.mlergh.com/blog/?p=26

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTY4OTgzMzg1fQ==