World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Anyone using 13.04 and AMD?
Michael Washington Jr.
Posted 2013-06-13 00:14
Spent the past 2 hours locking up and rebooting... barely get in and when I do the FPS is terrible. What's weird is that I went the entire game all 1-90 and did some raids just fine and now it's sarting to give me problems, and it's getting worse.

The "expert support" won't help me at all. And public forums won't help with proprietary software.
Jeremy Wininger
Jeremy Wininger
Posted 2013-08-21 23:11
Are you talking about using AMD CPUs or GPUs or both.

I'm using an AMD FX-8320 CPU with a nVidia 660ti GPU and WoW works fine in D3D9 mode under Ubuntu 13.04. I get about 45-55 FPS on ultra settings, sometimes it drops down to 30-ish FPS but it's still playable.

There isn't really anything you need to do on the CPU end if you're using a AMD chip. Should just run with it. On the other hand a GPUs performance is bound by their driver. What ever GPU (AMD or nVidia) you are using make sure you are using the proprietary driver and not the open source one. Maybe the open source driver became reactivated and it's reverted back to using it. The Proprietary drive will definitely yield better performance, so double check you are using it.
Curt Peregoy
Curt Peregoy Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2013-08-21 23:37
my system is amd fx 8320 with 2 amd hd radeon 7870 and i get between 30-60 fps, i alsp have 16 gig ram and a 4 gig swap partition

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTI1ODk4MDg2fQ==