World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Mangler sound while in World of Warcraft
Bradley Marchand
Posted 2015-04-13 21:51
I am trying to use Mangler for vent while playing World of Warcraft. Mangler works fine when game isn't running, but when game starts sound stops. Anyone know of any settings I need to change?

Using Linux Mint. It is a usb headset. Mangler is setup with ALSA.
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2015-04-14 00:58
That there is your problem. You need to use PulseAudio.  Any device requesting access to audio HW via ALSA has exclusive access to that audio HW.
Bradley Marchand
Posted 2015-04-18 20:56
Sorry for the long delay in response. Got a baby which greatly limits my online time right now.

Thanks didn't know that about ALSA. I setup Mangler with PulseAudio. Still having trouble getting game sound and vent. When I start WoW game sound works, but still no vent. WoW sound settings are set to system default with sound channels set to high. When I change the sound channels to medium or low, it kills game sound and I can hear vent (actually seems to plays back any vent sound from when game started). Restarting game always resets the sound channels to high. So, maybe if I figure out how to keep the sound channels at medium or low, after restart both will work?

Also tried setting Sound_NumChannels "32" in Config.wtf, but starting game resets it to 64.
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2015-04-19 00:06
Do you have these packages installed? libasound2:i386 and libasound2-plugins:i386

You can check wiith
 apt-cache policy libasound2:i386


Did you change PulseAudio's config files in any way? (since you were running Mangler with ALSA)
Bradley Marchand
Posted 2015-04-21 20:44
I haven't changed any Pulse Audio settings other than volumes and I changed the output device to my headset.

libasound2:i386:
  Installed: 1.0.27.2-3ubuntu7
  Candidate: 1.0.27.2-3ubuntu7
  Version table:
 *** 1.0.27.2-3ubuntu7 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
        100 /var/lib/dpkg/status

libasound2-plugins:i386:
  Installed: 1.0.27-2ubuntu2
  Candidate: 1.0.27-2ubuntu2
  Version table:
 *** 1.0.27-2ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
        100 /var/lib/dpkg/status
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2015-04-22 02:12
Hmm I don't know. File a ticket, point to this thread, maybe Codeweavers' staff will be able to help you.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTA5MDI4MzM5fQ==