World of Warcraft Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Reply to Thread Back to Threads

March 22 Patch Broke Connection to WoW
Blizzard has it listed as infrastructure changes and memory optimizations.  It appears that the vast majority of Linux users are unable to connect in game, although the Battle.net launcher has no problem connecting.  Here is the full BattleNet.log file.  I let it sit and try to connect for a little over a minute and you can see in the log file that it generates and error almost immediately after attempting to logon.

3/23 06:53:33.209  [IBN_Login] Starting up | hasFrontInterface=false | hasBackInterface=false
3/23 06:54:00.407  [GlueLogin] Starting login | launcherPortal=nullopt | loginPortal=US.actual.battle.net:1119
3/23 06:54:00.407  [GlueLogin] Resetting
3/23 06:54:00.407  [IBN_Login] Initializing
3/23 06:54:00.408  [IBN_Login] Attempting logon | host=US.actual.battle.net | port=1119
3/23 06:54:00.409  [GlueLogin] Waiting for server response.
3/23 06:54:00.561  [IBN_Login] Front disconnected | connectionId=1 | result=( | code=ERROR_OK (0) | localizedMessage= | debugMessage=)
3/23 06:54:00.561  [GlueLogin] Disconnected from authentication server.
3/23 06:55:04.084  [GlueLogin] Explicitly disconnecting from realm server
3/23 06:55:08.099  [IBN_Login] Destroying | isInitialized=true
3/23 06:55:08.638  [IBN_Login] Shutting down
I am just here to second this. I have the same experience, with the same error message.
Currently 172 posts over on the WoW site about this.  Hoping CodeWeavers figures it out first.
http://us.battle.net/wow/en/forum/topic/20742855183?page=1
It wasnt Wine I don't think.

http://us.battle.net/wow/en/forum/topic/20742835094

Was the error message I was getting.

Which was fixed by, "it worked for me when I double clicked a realm, rather than using the button at the bottom" suggestion.

Might work for you too?

I think the bug fix has gone through though yea. Unless the wine issue is different, as it wasnt letting people log in at all I read. Maybe I slept through the wine issue, but when I got up, i could log into some realms fine, but when switching i got the above topic error.

So dunno... possibly though it was not a wine issue, but just a patch glitch :).

They had the servers down for a hot fix today i believe :).

Hope its working for u now man :).

Edit: Weird though, Wine runs it fine, Crossover runs it fine [for me] but PlayonLinux is getting the stuck at Sign-in screen... weird :-O...
It does look like wine was partly at fault:

http://us.battle.net/wow/en/forum/topic/20742995286?page=1

Looks like codeweavers is going to need to make a new build for the latest wine.
Well here is what I have come up with:

According to the blizzard forums there is a bug in wine due to the recent BEAST attack  (http://us.battle.net/wow/en/forum/topic/20742995286?page=11#201) and apparently the fix requires a patch for wine 1.9.6 (http://us.battle.net/wow/en/forum/topic/20742995286?page=11#203).
Hi all,

Just to +1 the issue. I can't connect (stuck at connection screen (popup connection)).

Crossing fingers codeweavers will deploy new bottle :)
Thomas Raulet Posted:
Hi all,

Just to +1 the issue. I can't connect (stuck at connection screen (popup connection)).

Crossing fingers codeweavers will deploy new bottle :)


Dittoes.  I haven't had time to jerk around with making any custom packages yet, likely Codeweavers will beat me to a fix at this rate.  IT work can be draining and VERY time consuming.  Would be nice to kill some NPCs to extinguish some frustration.  Guess CS:GO will have to do in the meantime.
Issue has been narrowed down to the secur32.dll.so.   Or at least that is what has been able to fix the problem for many.  The key change is a modification that tells gnutls to not use SSLv3 during the handshake.  

Details and examples are listed here.  So far I haven't been able to make a secur32.dll.so that works with Crossover.
http://us.battle.net/wow/en/forum/topic/20742995286?page=11
By doing a terribad thing and using a secur32.dll.so created here, I changed from connecting to instant disconnect.  Time for codeweavers to step in and help I think.
With the new secur32.dll.so file, I did change to what has been called Issue#1, which is described as follows:

Issue #1: Error Code BLZ51900007
Upon attempting to log-in, user immediately receives the following error: "You have been disconnected (BLZ51900007)" and is returned to the log-in screen. (Screenshot: http://imgur.com/rhFslBw ) If you are not seeing this specific error message, proceed to issue #2, this does not apply to you.

This is the issue I was personally having yesterday. The fix for this error appears to be to update to the latest version of Wine (1.9.6). Directions for how to do this can be found at https://www.winehq.org/download or from your distribution's support pages. If you are using PlayOnLinux or Crossover Office, verify which version of wine is being used underneath before submitting reports.

At this point, it does not appear that anyone using the current version of Wine is receiving this error message upon attempting to log in (the four people who have reported this error are all either able to play now or are now experiencing issue #2 instead.) If you continue experiencing this error message after updating wine to 1.9.6, please review the feedback format below and post as currently it is believed Issue #1 is resolved.


This further points to the wine version employed by Crossover as not being able to handle the new handshake requirements for WoW.
Porbably using the wrong glibc than what it was compiled with.  You likely are on a different distro and thus whomever compiled it had a different glibc version than what you have.  Hence the beauty or source packages, you just rebuild (one command) and done.
Just a heads up, things can be fixed with a newer version of gnutls.  I've tested with version 3.4.10 from Debian unstable (actual package is gnutls-bin) and it worked like a charm.  If you're savvy enough to update this package, then have at it, if not, hopefully there will be an easier way to get things fixed -- like an update from Codeweavers.
Thanks for the heads up.  Ill see if I can help my EL loving bretheren by rolling up a EL6/7 RPM of something newer.  Wish me luck.  I suppose since its a mock command away, I can try a Fedora set too.  I suppose I should put this in a separate repo than my normals, since then it will be easier to remember to remove when a proper fix comes out.
A couple of people have mentioned that Codeweavers is working on a fix for the issue and will have a update out soon.

That's why I have no problem paying for Crossover.  They're always fast to respond.
So I tried to update the gnutls-bin to the unstable from the Debian branch....

              Then the dependency chain hung in the middle of the install............

                                Now on a clean install of Mint 17.3, KDE.  Ouch!!!
Update is OUT!  CodeWeavers is truly awesome.

"CrossOver 15.1.0 also includes bug fixes for the popular games Heroes
of the Storm and World of Warcraft: any users who run those games will
want to install this update."

1 to 17 of 17

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjAzMTM4NzM0LCJjc3JmX3Rva2VuIjoiWTRBUXJRVHFkbUNyZzZSZSIsImdkcHIiOjB9