World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Legion Patch changes
James Whiteley
James Whiteley
Posted 2016-07-19 15:04
I installed the Legion patch that was released today and immediately the cutscene was all black or all green. Initial troubleshooting confirmed my suspicion, the 'install' took it upon itself to update your gxAPI setting - most everything else seemed untouch. So edit your Config.wtf and change the gxAPI setting back to what you had previously. For me it was "D3D9".
Christopher Blackmon
Christopher Blackmon
Posted 2016-07-19 17:23
Yep.. that's what happened to me as well.. it changed it to D3D11... reverting it back to D3D9 got it to work.

thanks.
Jonathan C Arbogast
Posted 2016-07-19 19:04
I have the black screen I opened the Config.wtf but I can't find the gxAPI  I have gxWindow "1" and gxMaximize "0".  I serched the file and those are the only two entries with gx.  So what can I do to fix the issue?
Jonathan C Arbogast
Posted 2016-07-19 19:24
Thank you for the tip above... Initially, gxAPI did not exist but when I closed out the launcher and reopened the file it appeared at the bottom of the file. Once I changed the value it fixed the issue.
Joseph Otterson
Posted 2016-07-19 23:48
Nice find.  Fixed things for me as well.

Thanks for the info.
John Kehr
Posted 2016-07-20 06:55
Great catch.  Little tweak worked like a charm.  
Thomas Raulet
Thomas Raulet
Posted 2016-07-21 02:49
Hi All,

I had a green screen during the cinematic and then a black screen.

I tested the manipulation you spoke about, without results.

I've contacted support and they answered back :

"You can fix this by adding a .dll override using the Wine Configuration control panel https://www.codeweavers.com/support/wiki/linux/linuxtutorial/unsupported
_deps . Go to the Libraries tab and add an entry for d3d11 and edit it so that is set to disabled and you should now be able to run WoW"

If it may be helpful for anyone ;)

Avery Bunker Advocate
Posted 2016-08-05 09:46
Thanks Thomas Raulet, that worked like a champ and was the only change I made.

FYI Thomas, not sure if you can update your post, the hyperlink needed some tweaking as it looks like it broke in the paragraph where _deps is.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTI1ODk4MDg2fQ==