World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Reply to Thread Back to Threads

Very bad performance
Posted 2017-04-02 08:06

I have a very good video card on my PC atm nVidia 4GB GT 1050Ti and the performance via Crossover on my Arch Installation of WoW is awful.

I find this really striking as on Ubuntu I would get pretty nice FPS on my old videocard that was only 1GB.

I have been trying to find ways to amend the Crossover installation but no luck.

I am pretty sure my nVidia drivers are working fine.

I have been playing with wine, using my installation and I am getting better performance via:

sudo __GL_THREADED_OPTIMIZATIONS=1 wine .cxoffice/World_of_Warcraft-2/dosdevices/c:/'Program Files'/'World of Warcraft'/'Wow-64.exe' -opengl

is there any way to add the above openGL optimization line to my crossover installation?

Andrew Schott
Andrew Schott Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2017-04-04 17:14
Not sure if there are any better ways

Point to a script method:

1) Make a shell script.  Presuming that the paths are identical :

__GL_THREADED_OPTIMIZATIONS=1 "/home/andrew/.cxoffice/battlenet/desktopdata/cxmenu/Desktop.C^5E3A_users_crossover_Desktop/" %u

2) Change/Create .desktop file to the appropriate shell file.

The other method is to edit the .desktop shortcut (or create a new one)

1) Open up in your favorite editor your .desktop file.  You can create a new one too, by opening up Crossover, selecting the appropriate bottle, selecting BNet, and right clicking on it and picking "Run With Options", then clicking "Create Launcher".  The new one will be on your desktop.
For me, my existing one is at:

2) Add in an EXTRA line, above the existing .lnk one.  So for me I have
Exec="/home/andrew/.cxoffice/battlenet/desktopdata/cxmenu/Desktop.C^5E3A_users_crossover_Desktop/" %u

I did try the obvious just now of adding the preceding bit to the start of an existing .desktop file I had by just right clicking and it did not work, so if thats what you unsuccessfully tried, I hear ya.  Too bad at least GNOME forces us into having to still go the extra mile to get some slightly advanced launch options for apps.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...