World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

wow page not showing in battle.net
Ajdin Mujezinović
Posted 2018-02-11 09:42
I've installed battle.net  (crossover -> install windows software..) and it worked. I managed to log in into app, but wow tab doesn't show me anything useful.

Other pages show install button as expected. Also on screenshot you can see error get when i start battle new, so that might be helpful. I've also tried installing wow directly, but same error occured.
EDIT: for refference i'm running kubuntu 17.10.
David Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2018-02-11 12:11
its the pre-buy screen for the next X-pac
If your looking to just run WOW you can bypass the launcher using the run command not a true fix but it will get you in-game

open the run command thats in your WOW bottle and hit browse

now in Program Files/World of Warcraft  OR Program Files(86)/World of Warcraft
pick the WOW.exe   OR   WOW-64.exe   then hit open

at this point you can just run it but I would recommend hitting the  Create Launcher that will make a shortcut in the bottle

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTU4MDM0NTA0fQ==