World of Warcraft

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

wow 8.0
Juliano Pereira
Juliano Pereira
Posted 2018-08-12 17:52
Hi guys,
I see now that wow works great with 17.5.1(1). That's true? If i download the latest version of Crossover will it work? Or 17.5.1(1) is a special version?

Regards!
Miroslav Maiksnar
Miroslav Maiksnar
Posted 2018-08-13 09:46
Hi,
I've tried update to 17.5.1, but I'm getting "Game Initialization Failed: I" error when I try to run wow (either from launcher or as wow.exe). It's old installation from 17.0.0wowbuild though, it might work after fresh install.
Mixi
Ren
Posted 2018-08-23 04:44
I've tried it with a fresh install, it still doesn't seem to work.  It does install, the battle.net app runs, but with the usual error windows that have to be closed and drop down menus that don't want to appear and text that doesn't always display.

However once you actually try to launch the game all I get is a "Game Initialization Failed" message.  So back to the drawing board it seems.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTQ3NjY2NTQ4fQ==