Dishonored

Running on Linux Mint 19 with 4.15.0-29 kernel
Running on Linux Mint 19 with 4.15.0-29 kernel

If you would like to contribute screenshots for Dishonored: click here

Note: Screenshots shown in the Compatibility Center are often representative of compatibility on both Mac and Linux platforms.

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTU4MDM0NTA0fQ==