Guild Wars

macOS 10.8 (Mountain Lion)
CrossOver 11.2.0 GuildWars running on OS X Mountain Lion. MacBook Pro 13'' late 2010.
Ubuntu 11.04 (64 bit)
CrossOver 11.0.3 Guild Wars in game.
Ubuntu 11.04 (64 bit)
CrossOver 11.0.3 Guild Wars character menu screen.
macOS 10.7 (Lion)
CrossOver 11.0.2 Runs great in CrossOver Mac 11.0.2 windowed mode with settings turned down to medium/low on a 2010 Macbook Air 1.86Ghz Core 2 Duo and 2GB RAM.
macOS 10.6 (Snow Leopard)
CrossOver Games 10.1.0 Directsong functions with Windows Media Player 9 installed. The glowing directsong symbol in the options indicates that it is playing music.
Guild Wars: Eye of The North expansion. MacBook Pro Unibody (late 2008) 2,4GHz, 4GB RAM using discrete GeForce 9600M GT - CrossOver Games 9.0b6, Mac OS X 10.6.3. All settings maxed out, perfectly playable.
Running on MacBook Pro (late 2008) 2.4Ghz, 2GB RAM using integrated NVIDIA GeForce 9400M. All settings maxed out - smooth and perfectly playable.
Doing a GW Mission CrossOver Games 7.1.1 on iMac 2GHz C2D 1GB SDRAM Radeon X1600
Guild Wars running on iMac 2GHz Intel C2D 1GB DDR2 SDRAM. Radeon X1600. Leopard.
Guild Wars on MacBook, 2.2 GHz Intel Core Duo, 4 GB Ram in CROSSOVER MAC 7.1.1. It runs awesome!
Ubuntu 8.04 -> Crossover Games 7 -> 7900GS & AMD64X2 5200, 1440x900. Runs at solid 40-60FPS
GuildWars on Linux with CrossOver Games.
Incredibly low FPS and high Ping. FPS goes down to as low as 3, then jumps to 25-27-ish. Sometimes I get a steady 50-70 fps for about 3 seconds, then it's down to 3FPS again. Graphics settings has no impact (but is set to Highest in the screenshot.) CrossOver Games 7.0 Same thing in CrossOver 6.1. Playing from Norway, in case the Guild Wars server thinks I'm in the US and thus connects to a US server because of CrossOver. Nothing is downloading in the background (except for game content.)
Guildwars on Crossover Games 7.0, running on iMac 24" 2.16GHz, 3GB RAM and NVidia GeForce 7300 GT
Master Togo surrounded by spirits on an iMac using Crossover 6.2.
Find attached png image of guildwars running on Opensuse 10.3 my 55 monk about to farm.
Running on an AMD Athlon 3400+ with 1 GB of RAM under SuSE Linux worked in one try. In windowed mode. Using SuSE Linux 10.2 with an nVIDIA GeForce 7600 GS PCIe.
Mac Mini; 1.66 GHz; 2GB RAM
Guild Wars running on MacBook C2D 2.0GHz 1GB ram
Guild Wars with everything on High, running 1024x768 Windowed mode. CrossOVer 6.1b2

If you would like to contribute screenshots for Guild Wars: click here

Note: Screenshots shown in the Compatibility Center are often representative of compatibility on both Mac and Linux platforms.

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==