CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

can't save changes in MS-Office 2010-files on a mounted Server2008R2-share
pschulze59
pschulze59
Posted 2018-06-15 05:04
Since I've installed a new Leap Suse 15.0 and CXOffice 17.5 I can't save the changes in edited MS-Office2010-files on a mounted share from a MS Server 2008 R2.
The mount-options are the same as before and the native linux-to-smb-share-access works fine. There I can overwrite files on the mounted share, create new and delete files..  But if I use CXOffice and the MS Office 2010 I can not save the edited files - only if I use a new name.
I think the issue with the missing recent-folders can help, but it doesn't help.
Any other ideas?
Thanks!
Peter
Vincent Ouwehand
Vincent Ouwehand
Posted 2018-07-26 01:21
I have had the same issue for ages, it seems related to the 2008R2 server using SMB2 shares. For me the problem existed with an EMC Isilon share that at some point got switched to SMB2, from that point i couldn't save over the existing file anymore.

And this only happens with apps running in a crossover bottle (any bottle). So libreoffice can overwrite the file just fine.
Rostislav Stříbrný
Rostislav Stříbrný
Posted 2019-05-04 06:29
Hi,
I'm on Ubuntu 18.04.

=> Same problem here. For both Office 2010 and Office 365. I could same on network share on to new file (from office). Cannot override existing file, even if I just created it (with the previous save).

I've tried setting cifs with different combinations of following mount options (no success):
noperm
rwpidforward
nounix
noacl
file_mode=0644,dir_mode=0755
file_mode=0777,dir_mode=0777
uid=1000
gid=1000
forceuid
forcegid
cruid=1000
vers=2.1
vers=3.1.1

I tried to finding something else on some forums, with no success.
Villa Sara
Villa Sara
Posted 2019-10-28 18:15
I'm having a very similar problem.  Essentially, I get an error as described in this article when trying to save an Excel workbook using an Ubuntu 18.04 workstation running Crossover Office 18.5.0 connected to a Samba file server:

https://support.microsoft.com/en-us/help/813973/you-may-receive-a-your-changes-could-not-be-saved-error-message-when-y

However, I do have the correct modify and delete file permissions.  The error goes away when I force the SMB1 connection while mounting.  Clearly, there is a problem with Crossover or Wine and Ubuntu's implementation of SMB2, but I'm not sure what the issue is.
Jiri Halak
Jiri Halak
Posted 2019-12-08 10:00
I have the same problem. Tested with crossover 18.5 and 19.0 beta, multiple bottles, tested with Office 2013 and Office 2016. The same behavior. When the opened file is on Samba share >SMB1 the file cannot be saved. The only way is to save to the new file and then copy over. Any other SW can access the files just fine, LibreOffice can open edit and save the same file the same as any other text editor, the only problem is with the crossover. I have checked WINWORD.EXE process and it runs under correct user, even if the user is the same (not group match but exact user match) the process cannot save its own file. This really happens only on SMB >1, seems to work with SMB1 share.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTc4NTg3MzkzfQ==