CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Cannot install Crossover because of dependencies

Dear All

I am going back to Linux so I installed Kubuntu 20.04.2 LTS-64. Then Virtualbox 64 (VB64) bit from within Discover. Next I installed Lazarus (lazarus-project_2.2.4-0_i386.deb), but the 32 bit version. (with help from this forum). Virtuabox was uninstalled as part of the Lazarus’ installation. I did not notice. I have Virtualbox no more. When I try to reinstall VB64 from Discover I get this message.
This action will also remove the following packages:
binutils(2.38-4ubuntu2.1)
fpc-laz(3.2.2)
lazarus-project(2.2.4)
First Try - Undeterred, and while awaiting resolution from a Lazarus forum I pressed on with my journey back into Linux land. I decided to use Codeweavers again. While waiting for payday I downloaded the trial version. It has not gone smoothly. Not much has gone smoothly. I appear to be a a circle of unresolvable dependency problems. A bit like my personal life. See the output at the bottom. As you will see from the reproduced output marked First Try, where prompted I have tried to install a package mentioned. I have no idea what
"Try 'apt --fix-broken install' with no packages (or specify a solution)"
means, though I did try it.
Second Try – I keep installation notes and previous notes mentioned a dependency error and recommended I try to update apt and install python. This is inconclusive. See notes at the bottom marked Second Try

Any assistance welcomed

Stephanos
Output pasted here: https://pastebin.com/QAbXCHGE

Stephanos, in your output, you typed only "sudo apt --fix-broken", but the correct command is:

sudo apt --fix-broken install

the command "install" is missing in the line. "install" is the command and is mandatory, "--fix-broken" is only saying to "install" to try to fix things.

Hope this helps!

Thank you

Corrected, resolved/installed

Issue solved

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE4MDM3Nzg4LCJjc3JmX3Rva2VuIjoieDdQa3phYmNVd2F0TkVHcCIsImdkcHIiOjB9