CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

not found error in directory paths
Jim McNamara
Jim McNamara
Posted 2011-03-31 00:01
Hi-

wine-1.3.15
codeweavers installed a few days ago (standard)

\\windows\\system32" not found in /home/user100/.cxoffice/bottle name/dosdevices/c:/windows/system32

codeweavers is intalled in /opt/cxoffice

~/.cxoffice is where my windows program is and data (nested in there is my bottle)

If the directories themselves are not found, I don't know how to get this to work.

I managed to get almost ALL the not found errors eliminated (there were a ton) and then subsequently later found more settings where I could list locations like libraries and bin directories :

"Each of these values, if specified, will override the default value
;; computed via CX_ROOT."

I tried setting environment variables System, Path, WinDir, SystemDir and no matter what I try I still get the not found message above.

I'd like to know where this cx_root is located. It is referred to everywhere but I don't know its original location or default value.

I don't know whether to laugh or cry but I was copying from one directory to get rid of a not found message and putting it in another directory. It took FOREVER and I kept thinking if I could just reference the source directory like the fakedll directory or the dll directory and link them to my bottle systems system32 directory, I wouldnt be stuck copying fakedlls and dlls forever.

I had at one point System and Path set right from the manual (not now) and it just kept ignoring me and giving me a not found like above, so that is why the crazy setting you see now. I haven't set anything else except for environment variables in cxbottle.conf and a bottle path.

If I could just get the directories themselves to be found, it would be a HUGE step in getting things to work. Please assist. I have no other errors I can really fix when I debug on files not found except not found winewrapper.exe.

The only thing I think I needed from winetricks was vcrun6 so I could get a dll my program was asking for.

I am trying to get Paradox database to load. I found that with codeweaver the installer worked better than with just wine. It just needed a lot of compatibility dlls builtin manually added to my bottle because I am not good at referring to things in other locations yet. I couldnt believe how many built-ins were there instead of the native ones.

Thanks for any assistance!
mtdew3q

Jim McNamara
Jim McNamara
Posted 2011-03-31 22:47
Hi-

I thought I gained a little ground tonight and wanted to report back my findings.

I found a shell script and modified some settings. Here is a sample running a corel program and it seems to work kind of cool. I figure if I have the settings right in the shell script to launch this program ccwin10.exe then the Paradox database program has other things wrong with it and I don't know how to read the printouts with all the memory addresses.

I went about as far as I can go with trying to get paradox database to work.
I get an error that says "Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x0053d5a9) but I won't display the printout of the error because I don't know who can even read that type of printout. I use to read java stack traces but at least they werent memory addresses.

I might want to mention something I thought worth mentioning was if I launch wpwin10.exe from the same script below instead of the ccwin10.exe it stays waiting for termination in the shell with no errors but no screen image displays. It is interesting to note that on other launches of word perfect the screen did not display in the right dimensions at launch showing very little of the screen and needing to be resized. I think the program (word perfect) is running from the shell script and something is funky with the display at launch.

The print out below is from something that is working. I figured I'd leave it at some things work and others - well........

thanks to http://www.yolinux.com/TUTORIALS/LinuxTutorialRunMicrosoftExe.html for the cool tutorial.

#!/bin/bash
export LD_LIBRARY_PATH=/opt/cxoffice/lib:$LD_LIBRARY_PATH
export CX_ROOT=/opt/cxoffice
export CX_DEBUGMSG=-file
export CX_BOTTLE="/home/thirdshift/.cxoffice/paradox db"
export WINEPREFIX="/home/thirdshift/.cxoffice/paradox db"
export WINELOADER=/opt/cxoffice/bin/wineloader
export WINESERVER=/opt/cxoffice/bin/wineserver
export WINEDLLPATH=/opt/cxoffice/lib/wine
# Actual Linux file: /home/thirdshift/.cxoffice/bottle db/fake_windows/Program Files/Microsoft Office/Visio10/Visio.exe
/opt/cxoffice/bin/wine --workdir "/home/thirdshift/.cxoffice/paradox db/drive_c/users/crossover/My Documents/" \
"/home/thirdshift/.cxoffice/paradox db/dosdevices/c:/Program Files/Corel/WordPerfect Office 2002/Programs/CCWin10.exe"

***** Thu Mar 31 23:22:05 2011
Starting: '/opt/cxoffice/bin/wine' '--workdir' '/home/thirdshift/.cxoffice/paradox db/drive_c/users/crossover/My Documents/' '/home/thirdshift/.cxoffice/paradox db/dosdevices/c:/Program Files/Corel/WordPerfect Office 2002/Programs/CCWin10.exe'

CXConfig->read(/opt/cxoffice/etc/cxoffice.conf)
CXConfig->read(/home/thirdshift/.cxoffice/cxoffice.conf)
Product version=10.0.0
5192: Grabbing the '/tmp/.wine-1000/bottle-801-60160c.lock' lock
5192: Got the '/tmp/.wine-1000/bottle-801-60160c.lock' lock
CXConfig->read(/home/thirdshift/.cxoffice/paradox db/cxbottle.conf)
Mode = 'private'
Environment:
 CX_ROOT = "/opt/cxoffice"
 CX_BOTTLE = "/home/thirdshift/.cxoffice/paradox db"
 WINEPREFIX = "/home/thirdshift/.cxoffice/paradox db"
 CX_WINDOWS_VERSION = <undefined>
 PATH = "/opt/cxoffice/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
 LD_LIBRARY_PATH = "/opt/cxoffice/lib:"
 WINEDLLPATH = "/opt/cxoffice/lib/wine"
 WINEDLLOVERRIDES = <undefined>
 LD_PRELOAD = ""
 LD_ASSUME_KERNEL = <undefined>
 WINELOADER = "/opt/cxoffice/bin/wineloader"
 WINESERVER = "/opt/cxoffice/bin/wineserver"
 WINEDEBUG = "-file"
 CX_LOG = "-"
 CX_DEBUGMSG = "-file"
 CX_WINE_USAGE_LOGFILE = "/home/thirdshift/.cxoffice/usage.log"
 DISPLAY = ":0"
5192: Releasing the '/tmp/.wine-1000/bottle-801-60160c.lock' lock
Running `"/opt/cxoffice/bin/cxavscan" "/home/thirdshift/.cxoffice/paradox db/dosdevices/c:/Program Files/Corel/WordPerfect Office 2002/Programs/CCWin10.exe"`

***** Thu Mar 31 23:22:05 2011
Starting: '/opt/cxoffice/bin/cxavscan' '/home/thirdshift/.cxoffice/paradox db/dosdevices/c:/Program Files/Corel/WordPerfect Office 2002/Programs/CCWin10.exe'

CXConfig->read(/opt/cxoffice/etc/cxoffice.conf)
CXConfig->read(/home/thirdshift/.cxoffice/cxoffice.conf)
Running `"/usr/bin/clamscan" --no-summary -- "/home/thirdshift/.cxoffice/paradox db/dosdevices/c:/Program Files/Corel/WordPerfect Office 2002/Programs/CCWin10.exe"`
LibClamAV Warning: ***********************************************************
LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ***********************************************************
LibClamAV Warning: ***********************************************************
LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ***********************************************************
Exec-ing '/opt/cxoffice/bin/cxwait' '--no-focus' 'Scanning for viruses'
locale path '/opt/cxoffice/share/locale'
-> rc=0  (took 7.70993399620056 seconds)
output=[/home/thirdshift/.cxoffice/paradox db/dosdevices/c:/Program Files/Corel/WordPerfect Office 2002/Programs/CCWin10.exe: OK
]
-> rc=0  (took 7.77086019515991 seconds)
output=[]
Command:
/opt/cxoffice/bin/wineloader winewrapper.exe --workdir /home/thirdshift/.cxoffice/paradox db/drive_c/users/crossover/My Documents/ --run -- /home/thirdshift/.cxoffice/paradox db/dosdevices/c:/Program Files/Corel/WordPerfect Office 2002/Programs/CCWin10.exe

** Thu Mar 31 23:22:13 2011
Starting '/opt/cxoffice/bin/wineloader' 'winewrapper.exe' '--workdir' '/home/thirdshift/.cxoffice/paradox db/drive_c/users/crossover/My Documents/' '--run' '--'
'/home/thirdshift/.cxoffice/paradox db/dosdevices/c:/Program Files/Corel/WordPerfect Office 2002/Programs/CCWin10.exe'

thirdshift@mypc ~ $ (thanks -- the end)

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTc4NTg3MzkzfQ==