CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

How and What to Install Debian Wheezy 64 Bit

How do I install cxoffice on Debian Wheezy 64 bit with MultiArch enabled.
Do i use ver 12 32 bit or 64 bit. With ver 11 cxoffice hung synaptic up till I read how to remove all
the dependency's so it could clean it self up.

Dave

I've always assumed that there is no Cx 64bit, or that it's not a go-er.

so, you would have to install Cx 12 - as a 32 bit file into your 64 bit O/S.

  • which should accept it.
    but, there may be other issues, that go with that way of things. . .

I am thinking the package has to multiarch aware as to only load in the 32 bit library's as needed ,
since their no longer all loaded in at once. I would go back to the old way but there are some programs I need
that are done the new way .

Dave

I am in the same boat, looking for the cleanest way of running crossover (i.e. without ia32 libs)

Are there plans to release a multiarch aware package for Debian?

EDIT:

Looked a bit further and I think the problem may be a dependency on perl which cannot be
"multiarched" for the time being (see http://article.gmane.org/gmane.linux.debian.devel.perl/10655)

Which means we may have to use the ia32 approach until that is resolved.

You Know I just thought I would give it an other Try.

dpkg -i ia32-crossover_12.1.2-1_amd64.deb
(Reading database ... 344926 files and directories currently installed.)
Unpacking ia32-crossover (from ia32-crossover_12.1.2-1_amd64.deb) ...
dpkg: dependency problems prevent configuration of ia32-crossover:
ia32-crossover depends on libc6-i386; however:
Package libc6-i386 is not installed.
ia32-crossover depends on ia32-libs; however:
Package ia32-libs is not installed.
ia32-crossover depends on lib32gcc1; however:
Package lib32gcc1 is not installed.
ia32-crossover depends on lib32nss-mdns; however:
Package lib32nss-mdns is not installed.
ia32-crossover depends on lib32z1; however:
Package lib32z1 is not installed.
ia32-crossover depends on lib32asound2; however:
Package lib32asound2 is not installed.

dpkg: error processing ia32-crossover (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
ia32-crossover

Confirmed - crossover is still using the outdated ia32-libs.
Greetings,
Chris

This one don't work either ..

[code]dpkg -i ia32-crossover_12.2.0-1_amd64.deb
Selecting previously unselected package ia32-crossover.
(Reading database ... 345524 files and directories currently installed.)
Unpacking ia32-crossover (from ia32-crossover_12.2.0-1_amd64.deb) ...
dpkg: dependency problems prevent configuration of ia32-crossover:
ia32-crossover depends on libc6-i386; however:
Package libc6-i386 is not installed.
ia32-crossover depends on ia32-libs; however:
Package ia32-libs is not installed.
ia32-crossover depends on lib32gcc1; however:
Package lib32gcc1 is not installed.
ia32-crossover depends on lib32nss-mdns; however:
Package lib32nss-mdns is not installed.
ia32-crossover depends on lib32z1; however:
Package lib32z1 is not installed.
ia32-crossover depends on lib32asound2; however:
Package lib32asound2 is not installed.

dpkg: error processing ia32-crossover (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
ia32-crossover

In order to use a 32-bit application in 64-bit Wheezy, you need to enable multiarch support. Information on this can be found @ http://wiki.debian.org/Multiarch. For those who want a shortened version,

sudo dpkg --add-architecture i386

Chris Rogers wrote:

In order to use a 32-bit application in 64-bit Wheezy, you need to
enable multiarch support. Information on this can be found @
http://wiki.debian.org/Multiarch. For those who want a shortened
version,

sudo dpkg --add-architecture i386

I couldn't have said it better myself. And now, it is in our FAQ pages:

http://www.codeweavers.com/support/wiki//linux/faq/debian_wheezy_64bit

Thank you!

Thank You

But that is already done as I had to do it for Wine which works I all so have a few other programs installed .

I would like to know why this won't install with multiarch enabled ?

dpkg --print-foreign-architectures
i386

I thought I would try the 32bit ver it don't install either.

/Downloads# dpkg -i crossover_12.2.0-1_i386.deb
Selecting previously unselected package crossover.
(Reading database ... 345528 files and directories currently installed.)
Unpacking crossover (from crossover_12.2.0-1_i386.deb) ...
dpkg: dependency problems prevent configuration of crossover:
crossover depends on perl5-base.
crossover depends on perl-modules.
crossover depends on python (>= 2.4).
crossover depends on python-gtk2.
crossover depends on python-glade2.
crossover depends on desktop-file-utils.

dpkg: error processing crossover (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
crossover

sudo apt-get -f install?

How do you get apt-get to work with out having crossover in the sources list ?

Dave

this is how I remember on installing wine.

dpkg --add-architecture i386
apt-get update
apt-get install wine-bin:i386

now I know crossover is not in a repository or is it, might make it easier to install !

Installing Crossover on Debian wheezy still doesn't work for me.
I've added multiarch-support as recommended, but gdebi fails to install ia32-crossover_12.5.0-1_amd64.deb because of a broken dependency for ia32-libs-i386

sudo gdebi ia32-crossover_12.5.0-1_amd64.deb
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Building data structures... Done 
Dieses Paket kann nicht installiert werden
Cannot install 'ia32-libs'
sudo apt-get install ia32-libs
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 ia32-libs : Hängt ab von: ia32-libs-i386
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
udo apt-get install ia32-libs-i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 ia32-libs-i386:i386 : Hängt ab von: libnspr4-0d:i386 (>= 4.8.6-1) soll aber nicht installiert werden
                       Hängt ab von: libnss3-1d:i386 (>= 3.12.8-1+squeeze4) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

The problem is, you cannot install the 32-bit-Package of crossover, too!

sudo gdebi crossover_12.5.0-1_i386.deb
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Building data structures... Done 
Erfordert das ENTFERNEN folgender Pakete: 
cb-meta-printer-support  desktop-file-utils  gvfs  gvfs-backends  gvfs-bin  gvfs-common  gvfs-daemons  gvfs-fuse  gvfs-libs  libbonoboui2-0  libgnome2-0  libgnomeui-0  nautilus  python-gnome2  system-config-printer  thunar  thunar-archive-plugin  thunar-dropbox-plugin  thunar-media-tags-plugin  thunar-volman 
Erfordert die Installation folgender Pakete: 
desktop-file-utils:i386 
Run Windows applications like MS Office
 CrossOver Linux makes it possible to run Windows productivity applications
 such as Microsoft Office, and Quicken, and also lets you play Windows games
 like Skyrim and World of Warcraft.
Wollen Sie das Software-Paket installieren? [j/N]:n

He wants to remove essential packages like gvfs and such, most possibly because they seem uncompatible with desktop-file-utils:i386.

Whatever it is: this is not really good programming, folks! You can even manage to install $kype's and GoogleEarth's 32bit-Binaries. Not cool. Definitely not cool.

ia32-libs are getting obsolete on Debian, as we move over to multi-arch support. Fitting betas for Debian will be tested at the moment, and the next release will come with multi-arch Debian packages for Crossover. Stay tuned!
Greetings,
Chris

1 to 15 of 15

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoibkJneVdFbldZM2taTHBUYyIsImdkcHIiOjB9