CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

No Path in Wine Konfiguration

Hello,

while all other Apps show devices in > Bottlemanager > Wine-Configuration > Devices Assignment but one does not.
Error message (translation from German): Error while connecting with mountmanager. The devicesconfiguration can not be edited.
How and where can I fix this?

Regards

Bernd

CO Linux 12.5.0

I'm not very much sure how to fix this, so might I sugget a support ticket? You're the only one I know of with this specific problem, so the community might not have the answer you're looking for.

In any case, if I understand you correctly, you need to modify the drives in Winecfg (hence mountmanager) to access them in the bottle. You can do this manually by putting symbolic links to whatever you need in the "dosdevices" folder inside a bottle. For instance if you need "/home/someuser/important" then, in a terminal, in the dosdevice folder:

ln -s /home/someuser/important/ d:"

The support wiki also has this page to read. That will at least get you access to what you need until a solution is found for Winecfg.

You could also try to rename the old "dosdevices" folder in the offending bottle. Supposing this is a rights issue (not that I know why that would happen), that could clear the problem. The dosdevices folder will simply be recreated on use of said bottle with a minimum set of drives - and that might "reset" things - to which you can add back your extra drives later. To be honest I have no idea if this will help "fix" the problem, I just know it won't do worse.

Thanks for your reply but no success so far.

Regards

Bernd

Well, if you can't manually add drives with symbolic links, your bottle is well beyond anything I could manage. I now strongly suggest a support ticket as the staff would know better than me.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoiaEFoQUZzQVFyYWVXNk5mSCIsImdkcHIiOjB9