CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Trouble Installing WoW from copied game files
danielgrosvenor
danielgrosvenor
Posted 2010-12-28 12:47
Hi guys

I've just downloaded the trial version of CrossOver Games, and if I can get WoW up and running successfully will certainly be buying the full copy as I think this is a great project and a brilliant way to support WINE.  For reference, I'm running a Dell Inspiron laptop with latest Ubuntu x64.

I'm having some trouble installing World of Warcraft, however.  I downloaded the game to my Windows PC and so have no installation disks, and I have a 512 connection so re-downloading 20+ gig is out of the question.  So I did the only logical thing I could think of and copied my entire World of Warcraft directory to an external HDD, and pasted it into /home/dan/.wine/dosdevices/c:/Program Files

Now I'm able to get the game to run by opening Terminal and entering:
wine "C:\\Program Files\\World of Warcraft\\WoW.exe"


but I'd ideally like to have my laptop see WoW as being "installed", so I just need to click on a shortcut rather than having to dive into Terminal every time I want to open the game up.  I tried manually adding a shortcut in the Games folder to /home/dan/.wine/dosdevices/c:/Program Files/World of Warcraft/Wow.exe but I got a 'failed to execute child process' message.

It was at this point that I installed CrossOver Games.  When I try to install it from the Install Windows Software menu, it prompts me to install an Installer File or an Installer Folder.  I chose Folder and pointed it to .wine/drive_c/Program Files/World of Warcraft but this doesn't work.  The install starts to do something, then says:
[b]
An error occurred while running the 'AIEInsertMedia(World of Warcraft)' task[/b]

This disk contains two sections, one for Mac and one for Windows.  In order for CrossOver to use this disk it must be mounted so that the Windows portion is visible.

To make this change, remount as root with this command:
mount -t udf -o users,ro,unhide,uid=1000 /dev/cdrom "/home/dan/.wine/drive_c/Program Files/World of Warcraft"


I tried adding 'sudo' and typing this command into Terminal, but nothing seems to happen.

erm... help?!  😥
Artist Formally Known as Dot
Artist Formally Known as Dot Advocate
Posted 2010-12-28 16:56
Hi,

  See the following C4 page...;

http://www.codeweavers.com/compatibility/browse/name/?app_id=1185

Read the Tips&Tricks section on that page, and look in the forum
there. Likewise, if you run into problems, you can post questions
to that forum (not all WoW users read these general forums).

Hope this helps...

Cheers!
Andrew Schott
Andrew Schott Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2011-01-01 02:51
What you are doing is pretty much what I did to reinstall so I could check out Cataclysm.

The spot that we differ on, is the mounting issues.  I had no issues copying from the cds (I had the cd sets for WoW & BC, not WotLK or Cata), nor remounting my ext hd (formatted ext4).  This seems to be a Ubuntu issue methinks.  I am on Fedora 14 x64.

For starters, unless you are on a really old Ubuntu revision, the automount of cds/dvds should be all you need.  I can't recall when it worked perferct, but I think that 6.06 was where things got really nice, maybe prior.  As I recall the way Ubuntu handles things, is thru the groups.  So check your user in the Users & Groups control panel thingie and make sure you have yourself given the capability to use cds/dvds and ext hd and thumbsticks.  I am not sure offhand (no Ubuntu system handy) how its delineated on your system, especially since things got a complete overhaul in 10.04.  But that would be where I would check first.

Next if that fails, google how to mount cds and ext hds so all users can mount them.  I don't know if Ubuntu modified how the mount command works (doubt it heavily) but the following command should work for your cds and hd (make sure to change the mount paths accordingly, as well as the media type):

sudo mount -t udf -o users,ro,unhide,uid=1000 /dev/cdromslocation /wheretomountthis

Similar to the command that you mentioned in your post.  To switch cds use

sudo umount /dev/cdromslocation

Stick in your next disc, and remount.  Same command will work fine.  Rinse wash repeat until all the cds are copied over.
Again, I am not sure why you should even need to dork around like this, all recent distros handle this out of the box.  Plus the downloads of patches may actually make it that close to an actual re download of the whole thing.  On one linux machine, I used this method and I had 9GB to pull in between cata and the patches.  On my digital download I did, it needed about 13GB total.  With a little bit sucked down while gaming for the first day or so.  The nice thing with CXG, you can export this bottle when you bore with wow, and not need to do a reinstall, just reimport the bottle.

HTH,
Andrew.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTc4NTg3MzkzfQ==