CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Segmentation fault on Gentoo (updated to recent) KDE & QT 4.7 on Install of 10.0.0 Pro

I get the following line when trying to install crossover 10.0.0 professional:

./install-crossover-pro-10.0.0.bin: line 129: 20313 Segmentation fault "$installer" "$@"

I've also tried installing the games version.

./install-crossover-games-demo-10.0.0.bin: line 129: 20850 Segmentation fault "$installer" "$@"

Both are installed to user-writable directories, such as my home folder and an /opt/ folder I made specifically for it.
Happened regardless of whether the .bin file was executable or not.

Attempts to run any binaries that are created in the installs result in segmentation faults.
Reinstalling over my previous crossover games installation didn't manage to break the app install selection menu...

Reverting back to crossover pro/games 9.2.0 version allowed me to continue using it.
I also notice that the new installers are in .bin format, as opposed to the earlier .sh format.

My machine is a Thinkpad T60, 32-bit and Radeon X1400 with opensource ati drivers.

I'd file this under a bug, but that's been closed.
I'd also file this under a support ticket, but that's for a specific application, not crossover itself.

Does crossover 10 depend on libraries that should be on my system that I can check?

Same problem here, already wrote a ticket.

strace ./cxsetup:

Same problem here.
cxsetup crashes, but installed applications still work.

Gabriele Martino wrote:

Same problem here.
cxsetup crashes, but installed applications still work.

I have the same problem too. Here is my system information:

emerge --info

Portage (default/linux/amd64/10.0/desktop/kde, gcc-4.4.5, glibc-2.12.2-r0, 2.6.37 x86_64)
System uname: Linux-2.6.37-x86_64-Intel-R-_Core-TM-2_Quad_CPUQ9550@_2.83GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 30 Jan 2011 12:15:03 +0000
ccache version 3.1.4 [disabled]
app-shells/bash: 4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python: 2.7.1, 3.1.3
dev-util/ccache: 3.1.4
dev-util/cmake: 2.8.3-r1
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc: 0.7.0
sys-apps/sandbox: 2.4
sys-devel/autoconf: 2.13, 2.68
sys-devel/automake: 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils: 2.21
sys-devel/gcc: 4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82
virtual/os-headers: (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=core2 -mtune=core2 -mcx16 -msahf -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mtune=core2 -mcx16 -msahf -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages multilib-strict news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-march=core2 -mtune=core2 -mcx16 -msahf -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--sort-common"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/sunrise /usr/local/portage"
USE="X a52 aac acpi alsa amd64 berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fontconfig fortran gdbm gdu gif gpm iconv ipv6 java jpeg kde lcms ldap libnotify lzma mad mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support qt4 readline sdl session spell sse sse2 ssl ssse3 startup-notification svg sysfs tcpd theora tiff truetype udev unicode usb vdpau vorbis x264 xcb xcomposite xml xorg xulrunner xv xvid xvmc zlib zsh-completion" ALSA_CARDS="snd-ctxfi" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="
" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

By the way, is anyone using an ebuild to install version 10, or are you guys installing it into your user accounts too?

By the way, is anyone using an ebuild to install version 10, or are you guys installing it into your user accounts too?

There is no new ebuild for 10.0.0 and there was never a ebuild for crossover-games. Because of that, i installed it with the installer as root. It worked perfectly for every user. (with 9.x)

Not sure why, but i can start the 10.x tools as root atm without a Segfault.

strace as root:

strace as user (with Segfault):

But it's not permission problem, tried it with /opt/cxfoo user owned. But could be a problem with a env variable...


Not speaking to the crash here, but just just 2cents worth ; if you're the only person who regularly uses your computer, you should use the .bin (.sh before it) and be installing in $HOME. Unixly, the only time to use a deb/rpm package, is when there's regularly more than one user using the computer system, and you don't want 'single user mode' installs in every user's $HOMEDIR --- it says this in the docs too, but everyone seems to (erroneously) jump for distro packages, which is disappointing ;-/


It seems to fail importing python module "bottlecollection".

$ python -m pdb /opt/cxoffice-standard/bin/cxsetup 
> /opt/cxoffice-standard/bin/cxsetup(4)<module>()
-> import os
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(7)<module>()
-> def which(path, app):
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(30)<module>()
-> import sys
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(31)<module>()
-> def locate_cx_root():
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(80)<module>()
-> locate_cx_root()
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(81)<module>()
-> import cxutils
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(82)<module>()
-> cxutils.CX_ROOT = CX_ROOT
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(85)<module>()
-> import subprocess
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(86)<module>()
-> import traceback
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(88)<module>()
-> import checkgtk
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(89)<module>()
-> checkgtk.check_gtk()
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(91)<module>()
-> import gobject
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(92)<module>()
-> import gtk
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(93)<module>()
-> import
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(94)<module>()
-> gtk.gdk.threads_init()
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(96)<module>()
-> import crossover
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(97)<module>()
-> import cxlog
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(98)<module>()
-> import distversion
(Pdb) n
> /opt/cxoffice-standard/bin/cxsetup(99)<module>()
-> import bottlecollection
(Pdb) n
Segmentation fault

Going further with stepping, i found:

> /opt/cxoffice-standard/lib/python/<module>()
-> class NotFoundError(Exception):
(Pdb) s
> /opt/cxoffice-standard/lib/python/
-> class NotFoundError(Exception):
(Pdb) s
> /opt/cxoffice-standard/lib/python/
-> class NotFoundError(Exception):
(Pdb) s
> /opt/cxoffice-standard/lib/python/
-> pass
> /opt/cxoffice-standard/lib/python/
-> def _init_kde():
(Pdb) s
> /opt/cxoffice-standard/lib/python/
-> if _HAS_KDE is None:
(Pdb) s
> /opt/cxoffice-standard/lib/python/
-> try:
(Pdb) return
Segmentation fault

Hope it helps

Switching to python 2.7 and running python-updater solved for me.

Thanks for the info, works fine after the emerge of Python 2.7 and python-update 😊

emerge =dev-lang/python-2.7

python-update (~110 emerges on my system....)

Not 100% sure what fixed the segfault. The Python version or the recompiling of all python-packages?

Ah. Yes, my python version is :2.6 series.
Thank you for finding a fix!

1 to 10 of 10

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...