CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Anynotes

Hi all,
Kind of obscure app, Anynotes www.anynotes.com is the very last app I need to move the wife over to Linux, and I just cannot figure it out. It installs fine but throws a "the programs has encountered a serious problem" error and crashes at launch. Unfortunately, this app is the deal-killer and I wonder if anyone has any ideas before I decided to just revert her back to Win 7. This setup has been tried on 3 different computers, 3 different video cards (ATI, Nvidia, Intel), and all have the same result:

Crossover Linux Standard 10.1.0
Linux Mint 11, tried with both gnome and kde 4.6
Win98 bottle w/ IE6, Windows Installer 2.0

Debug:
fixme:exec:SHELL_execute flags ignored: 0x00000100
wine: Unhandled page fault on read access to 0xc0001001 at address 0x18125cc (thread 001b), starting debugger...
Unhandled exception: page fault on read access to 0xc0001001 in 32-bit code (0x018125cc).
Register dump:
CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
EIP:018125cc ESP:0033fd10 EBP:0033fe4c EFLAGS:00210202( R- -- I - - - )
EAX:00000001 EBX:00000000 ECX:c0001001 EDX:00000007
ESI:c0001000 EDI:018163f4
Stack dump:
0x0033fd10: 01817e48 0033fe00 00000003 018203fc
0x0033fd20: 01822064 01813ec7 0033ff10 01814274
0x0033fd30: 0033fe4c 00000003 003d0000 0181445c
0x0033fd40: 00000000 00000000 00000000 00000000
0x0033fd50: 00000000 00000000 00000000 00000000
0x0033fd60: 00000000 00000000 00000000 00000000
Backtrace:
=>0 0x018125cc (0x0033fe4c)
1 0x018129fc (0x0033fe68)
2 0x00000000 (0x00786497)
0x018125cc: movb 0x0(%ecx),%cl
Modules:
Module Address Debug info Name (104 modules)
PE 400000- 79f000 Deferred anynotes
PE 10000000-1000b000 Deferred anrapidesk
PE 21300000-21312000 Deferred rapi
PE 22b00000-22b0b000 Deferred ceutil
PE 5e380000-5e3a5000 Deferred msoss
PE 65340000-653d2000 Deferred oleaut32
PE 65f00000-65fc2000 Deferred ole32
ELF 68000000-6801e000 Deferred ld-linux.so.2
ELF 6801e000-6815e000 Deferred libwine.so.1
ELF 6815e000-68177000 Deferred libpthread.so.0
ELF 68177000-6817b000 Deferred libdl.so.2
ELF 6817b000-681a1000 Deferred libm.so.6
ELF 681a1000-681a9000 Deferred libnss_compat.so.2
ELF 681a9000-681c0000 Deferred libnsl.so.1
ELF 681c0000-681cc000 Deferred libnss_files.so.2
ELF 681cc000-6825b000 Deferred gdi32<elf>
-PE 681e0000-6825b000 \ gdi32
ELF 6825b000-68273000 Deferred version<elf>
-PE 68260000-68273000 \ version
ELF 68273000-68311000 Deferred krnl386.exe16.so
PE 68280000-68311000 Deferred krnl386.exe16
ELF 68311000-68325000 Deferred system.drv16.so
PE 68320000-68325000 Deferred system.drv16
ELF 68325000-68338000 Deferred comm.drv16.so
PE 68330000-68338000 Deferred comm.drv16
ELF 68338000-6835b000 Deferred mpr<elf>
-PE 68340000-6835b000 \ mpr
ELF 6835b000-6844b000 Deferred comctl32<elf>
-PE 68360000-6844b000 \ comctl32
ELF 6844b000-68482000 Deferred winspool<elf>
-PE 68450000-68482000 \ winspool
ELF 68482000-684e5000 Deferred shlwapi<elf>
-PE 68490000-684e5000 \ shlwapi
ELF 684e5000-684ff000 Deferred wsock32<elf>
-PE 684f0000-684ff000 \ wsock32
ELF 684ff000-6852e000 Deferred ws2_32<elf>
-PE 68510000-6852e000 \ ws2_32
ELF 68531000-68665000 Deferred user32<elf>
-PE 68540000-68665000 \ user32
ELF 68665000-68854000 Deferred shell32<elf>
-PE 68670000-68854000 \ shell32
ELF 68854000-68915000 Deferred comdlg32<elf>
-PE 68860000-68915000 \ comdlg32
ELF 68915000-68935000 Deferred iphlpapi<elf>
-PE 68920000-68935000 \ iphlpapi
ELF 68935000-6894a000 Deferred libresolv.so.2
ELF 6894a000-689b5000 Deferred libcxfreetype.so
ELF 689b5000-689ca000 Deferred libz.so.1
ELF 689ca000-68a75000 Deferred winex11<elf>
-PE 689e0000-68a75000 \ winex11
ELF 68a75000-68a7d000 Deferred libsm.so.6
ELF 68a7d000-68a95000 Deferred libice.so.6
ELF 68a95000-68bb0000 Deferred libx11.so.6
ELF 68bb0000-68bb5000 Deferred libuuid.so.1
ELF 68bb5000-68bce000 Deferred libxcb.so.1
ELF 68bce000-68bd2000 Deferred libxau.so.6
ELF 68bd2000-68bd8000 Deferred libxdmcp.so.6
ELF 68bd8000-68bf8000 Deferred imm32<elf>
-PE 68be0000-68bf8000 \ imm32
ELF 68bf8000-68bfe000 Deferred libxxf86vm.so.1
ELF 68bfe000-68c08000 Deferred libxrender.so.1
ELF 68c08000-68c10000 Deferred libxrandr.so.2
ELF 68c10000-68c14000 Deferred libxcomposite.so.1
ELF 68c14000-68c43000 Deferred libfontconfig.so.1
ELF 68c43000-68cc9000 Deferred libfreetype.so.6
ELF 68cc9000-68cf3000 Deferred libexpat.so.1
ELF 68cf3000-68cf9000 Deferred libxfixes.so.3
ELF 68cf9000-68d6f000 Deferred wineps<elf>
-PE 68d20000-68d6f000 \ wineps
ELF 68d6f000-68db9000 Deferred libcups.so.2
ELF 68db9000-68de9000 Deferred libgssapi_krb5.so.2
ELF 68de9000-68e0d000 Deferred libk5crypto.so.3
ELF 68e0d000-68ea3000 Deferred libgnutls.so.26
ELF 68ea3000-68f17000 Deferred libgcrypt.so.11
ELF 68f17000-68f23000 Deferred libavahi-common.so.3
ELF 68f23000-68f33000 Deferred libavahi-client.so.3
ELF 68f33000-68f3b000 Deferred libkrb5support.so.0
ELF 68f3b000-68f3f000 Deferred libkeyutils.so.1
ELF 68f3f000-68f50000 Deferred libtasn1.so.3
ELF 68f50000-68f8d000 Deferred libdbus-1.so.3
ELF 68f8d000-68f96000 Deferred librt.so.1
ELF 68f96000-68fb6000 Deferred localspl<elf>
-PE 68fa0000-68fb6000 \ localspl
ELF 68fb6000-68fd0000 Deferred spoolss<elf>
-PE 68fc0000-68fd0000 \ spoolss
ELF 69e2f000-69e33000 Deferred libcom_err.so.2
ELF 6ab94000-6ab99000 Deferred libgpg-error.so.0
ELF 6e397000-6e4f8000 Deferred libc.so.6
ELF 6f102000-6f15c000 Deferred advapi32<elf>
-PE 6f110000-6f15c000 \ advapi32
PE 70100000-70153000 Deferred rpcrt4
PE 70200000-70295000 Deferred wininet
ELF 70775000-70779000 Deferred libxinerama.so.1
PE 71450000-714ae000 Deferred crypt32
ELF 74c20000-74c2b000 Deferred libnss_nis.so.2
ELF 76df9000-76ea7000 Deferred libkrb5.so.3
PE 78000000-78040000 Deferred msvcrt
ELF 78fd5000-78fe4000 Deferred libxext.so.6
ELF 7a8f2000-7a8fc000 Deferred libxcursor.so.1
ELF 7b800000-7b980000 Deferred kernel32<elf>
-PE 7b810000-7b980000 \ kernel32
ELF 7bc00000-7bcbb000 Deferred ntdll<elf>
-PE 7bc10000-7bcbb000 \ ntdll
ELF 7bf00000-7bf03000 Deferred <wine-loader>
Threads:
process tid prio (all id:s are in hex)
0000000c services.exe
00000014 0
00000013 0
00000012 0
0000000e 0
0000000d 0
0000000f winedevice.exe
00000015 0
00000011 0
00000010 0
00000016 cxmanip.exe
00000017 0
00000018 winewrapper.exe
00000019 0
0000001a (D) C:\Program Files\AnyNotes 5.0\anynotes.exe
0000001b 0 <==
0000001e explorer.exe
0000001f 0
Backtrace:
=>0 0x018125cc (0x0033fe4c)
1 0x018129fc (0x0033fe68)
2 0x00000000 (0x00786497)

Hi,

I did get it to work somewhat without crashing - spawns a number
of ole errors instead, but, they don't seem to affect program behavior
too much. After looking at what it was after, I had two semi-working
scenarios... winxp bottle/IE7/.NET 2.0 ..or.. win2000 bottle/IE6 ; I
think the latter was preferable is it stopped it crashing on exit.

It was able to open the sample 'cooking-eng.abs' included for download
from the site, create new...etc etc...but like with all these sorts of
programs, it really depends on what the end-user wants to do with it.
The ole errors popping up will probably drive someone nuts in short time
though I guess...but something like this is what you need ; like many
win32 apps, it's dependent on parts of IE to work...

Cheers!

Don,
Thanks so much for taking a look at the app. I'll see if I can use your findings to get this thing working.

I really appreciate the help!

OK, I now have it running according to Don's configuration.

"The ole errors popping up will probably drive someone nuts in short time
though I guess."

I wonder, is there a way to squelch the OLE errors? It does appear usable otherwise (it's used for taking TONS of notes and clipboard snippets in a helpdesk scenario). But the OLE errors are very disruptive, rendering it pretty much useless.

Hi again....

I just had a look at this in wine-devel, and my wineprefix is
populated with roughly the same components as in CXO, and it kept
throwing OLE errors as well. I was able to dismiss these by
installing riched20 & riched30 via winetricks -- I could navigate
around anynotes, open that cooking database, click on stuff and
never saw an OLE error ... that said, the app crashes like a brick
into glass upon exit, which I doubt would be an issue in actual
usage...ie; save all work first before exiting ... but it was far
more usable without the error pop-ups...

..unfortunately, we don't have a C4 page/crosstie/install target
in crossover that's equivalent to these winetricks targets, but
ostensibly it's only a couple of .dll files + library overrides...


#----------------------------------------------------------------

load_riched20() {
    # http://support.microsoft.com/?kbid=249973
    download . http://download.microsoft.com/download/winntsp/Patch/RTF/NT4/EN-US/Q249973i.EXE f0b7663f15dbd31410435483ba832318c7a70470
    try_cabextract --directory="$WINETRICKS_TMP" "$WINETRICKS_CACHE"/Q249973i.EXE
    try cp -f "$WINETRICKS_TMP"/riched??.dll "$WINDIR"/system32
    override_dlls native,builtin riched20 riched32

    rm -rf "$WINETRICKS_TMP"/*
}

#----------------------------------------------------------------

load_riched30() {
    # http://www.novell.com/documentation/nm1/readmeen_web/readmeen_web.html#Akx3j64
    # claims that Groupwise Messenger's View / Text Size command
    # only works with riched30, and recommends getting it by installing
    # msi 2, which just happens to come with riched30 version of riched20
    # (though not with a corresponding riched32, which might be a problem)
    # http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=CEBBACD8-C094-4255-B702-DE3BB768148F
    download . http://download.microsoft.com/download/WindowsInstaller/Install/2.0/W9XMe/EN-US/InstMsiA.exe e739c40d747e7c27aacdb07b50925b1635ee7366
    try_cabextract --directory="$WINETRICKS_TMP" "$WINETRICKS_CACHE"/InstMsiA.exe
    try cp -f "$WINETRICKS_TMP"/riched20.dll "$WINDIR"/system32
    override_dlls native,builtin riched20

    rm -rf "$WINETRICKS_TMP"/*
}

...so... you'd need do it manually or use winetricks for this...ie;

WINEPREFIX="~/path/to/bottledir" winetricks riched20 riched30

...ergo...on my setup that would be...

WINEPREFIX="~/.cxoffice/anynotes" winetricks riched20 riched30

Cheers!

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzIxMzI3MzE0LCJjc3JmX3Rva2VuIjoiOU16N3BudnM1SFR6R0x2YiIsImdkcHIiOjB9