CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Steam Installed, but TF2 won't download

Hi all, I'm having a problem getting TF2 to install on my Ubuntu 11.10 system under Crossover. I selected TF2 to install via crosstie. The installation ran smoothly and Steam was installed as a prerequisite. The installer then said TF2 would download from Steam. Steam launches and functions perfectly, but TF2 is always sitting at "Download starting..." This has been going on for several hours. How can I get the game to actually download?

Hi....

....what happens if you start Steam, go to your Library
page...is TF2 in the list? If it is, can your right-click
on it's entry and select install game? If so, what happens then?...

Cheers!

I did that originally and it prepared the files for installation like it normally would. But ever since then it has just said Download starting... in the progress bar in the games library. Restarting Steam did not resolve the problem.

Hi again...

...I have seen that in Steam before (rarely), and typically
it's some sort of network connectivity issue. Umm..could
you try this instead?...

*Install Steam from the 'Supported Applications' target in
cxinstaller...let it do it's thing, and login to your account
-once- , then exit Steam....

*Restart Steam, and try to download/install TF2 from your
library page as you usually would...

...let me know if the behavior persists...

Cheers!

Unfortunately, the problem has persisted after trying your suggestion. I clicked install game about 2 hours ago, it still just says Download Starting...

...hmm...well I just checked it here, and it does start to
download as expected ; I just wanted you to try the manual
approach just incase the crosstie was not working...

...I take it you have a steam account and already have bought
something from Steam? (I'm not sure if that applied to TF2 in
the F2P form, but in the past when I've tried to send gifts
to someone who hasn't got a steam account, they had to join
Steam and buy something before they could access/install gifts)..

I have had a Steam account for awhile, but I haven't actually bought anything on this laptop under Crossover. Could that be the problem? Also, could I install it from a disk if I find one?

this may be a shot in the dark, but yesterday I had all kinds of problems getting my Steam Games to launch properly, connect to servers, etc. I ended up checking the "beta participation" option inside Settings>Account and re-started, and everything started working properly.

Also, perhaps you need to adjust your download region inside Settings>Download + Cloud?

..it's curious, I know... as for Jack's comment, this is true
(I saw it echoed to the Steam client counter as a few marked
dives in client count ...maybe they had an outage of some kind)...

..one of the reasons I asked if you have an account, is to get
you to see if you can install any of the games you already own?

Cheers!

Just checked my settings. The download region is fine, and no beta participation is listed. I was able to get Modern Warfare 2 to begin downloading. I did not wait to see if it would finish the process though, since I don't actually want to install that game on this system.

..that's fine, if it started downloading then obviously
the Steam installation is working...

...so we're back to speculating it's some sort of issue
with Steam and/or their servers ; what locale are you in?

East Coast, US. New York region for the purposes of Steam downloads.

...well, you certainly have me stumped ; I'm in .AU and
it's working here (downloading/installing) ; Jack is in
US central zone (MN) ... I can only guess the download
server for your locale isn't working (?)...but then, that
would infer TF2 is on a different server than MW2 and I'm
not sure if that is the case...

...at this stage, I would keep retrying just in case the
server feeding you is overloaded ...not much help, I know,
but it's all I can think of that fits the problem description..

Cheers!

Have you tried dumping your 'steamapps' folder? It could be that you've just got a bad cache stuck somewhere, somehow... a corrupted file maybe?

The "steamapps" folder will be located in your "Steam" bottle:

<bottlename>/drive_c/Program Files/Steam/steamapps

I would just move that folder aside and try again.

Yesterday Steam (Valve) was having a ton of network trouble and we had several reports that people could not connect (not to mention the Windows users who were reporting the problem on the Steam forums). It could potentially be related to that, I'm not certain.

If this does not work for you I would suggest opening a Support Ticket so that we can look further into the issue.

...their network traffic graph looks much more like
I'm used to seeing, observing it this morning - there's
a remark on their outage page about them discovering &
replacing a faulty switch in a server rack yesterday,
and I know from experience those kinds of problems are
diabolically hard to pin down ; such a failure is very
much aligned with the symptoms reported here...

Cheers!

1 to 15 of 15

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzIxMzI3MzE0LCJjc3JmX3Rva2VuIjoidFlxd1R5Tmhjd053eDk4YyIsImdkcHIiOjB9