CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Internal error - invalid parameters received

When I run Civilization IV (patched 1.74 or unpatched) witn Wine 1.4 the game runs but hang when loading any game. After the "finished" loading stage the background goes black and I have to reboot my computer to get wine to work again.

So I tried CrossOver, however the game doesn't even start. I just get "Internal error - invalid parameters received"

I can start the game using wine after this error, but cannot load.

I have wine 1.4 and the latest version of crossover installed.


It appears that steam hadn't installed Civ 4 at all. Trying to run setup.exe and the patch in the bottle created to see if this helps.

I ran setp.exe and the patch install sucessfully but Civilization4.exe fails with the same error.

There seems to be an issue with the 3.2 64bit kernel and ptrace. I'm being bit by this bug too trying to run Microsoft Outlook under Ubuntu 12.04 64bit. The "workaround" doesn work for me but it might help you. Before starting Wine type this at the command line:

echo 0|sudo tee /proc/sys/kernel/yama/ptrace_scope

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE4MDM3Nzg4LCJjc3JmX3Rva2VuIjoiOFFxdUxQZ253dUFiTnpWRSIsImdkcHIiOjB9