CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

"Python's Gtk and/or Glade libraries are missing."

If you're installing Crossover via the rpm package and you're hitting the error in the title, i.e.

[root@computer tmp]# rpm -Uvh crossover-standard-demo-9.2.0-1.i386.rpm
Preparing... ########################################### [100%]
It looks like Python's Gtk and/or Glade libraries are missing.

If this is the case, you may be able to resolve this issue
by running one of the following commands as root:
Fedora: yum install pygtk2 pygtk2-libglade
Mandriva: urpmi pygtk2.0 pygtk2.0-libglade
SUSE: yast -i python-gtk
error: %pre(crossover-standard-demo-9.2.0-1.i386) scriptlet failed, exit status 1
error: install: %pre scriptlet failed (2), skipping crossover-standard-demo-9.2.0-1

or a similar failure error in yum, please try

(a) logging into an actual root session from gdm/kdm and then install crossover

(b) giving Xauth to all users:

$ xauth +
$ su -

export DISPLAY=:0.0

and then trying the install, again

and in either case

(c) please write to info@codeweavers.com! This problem appears to arise from Crossover 9.2's installer incorrectly invoking X, and many systems don't extend Xauth to su. If you're having this problem, please tell us, and kindly inform if either (a) or (b) worked for you.

Thanks!

I'm changing to SimplyMEPIS 8.5.03 from 8.0 (Debian-based distribution) and ran into a problem installing crossover games. The installer ran, but failed to install. Terminal output is below:

[rtn@hawk downloads]$ sh install-crossover-games-demo-9.2.1.sh
Verifying archive integrity...OK
Uncompressing CrossOver Games
........................ bla bla bla .......
upgrade
Traceback (most recent call last):
  File "./bin/cxmessage", line 85, in <module>
    import gtk
ImportError: No module named gtk
/usr/share/themes/QtCurve/gtk-2.0/gtkrc:1: error: unexpected identifier `gtk-menu-images', expected keyword - e.g. `style'
[rtn@hawk downloads]$

After poking around in the trouble tickets, I saw one idea that I could try: install python-gtk2 and python-glade2. I used synaptic for the install and then retried the crossover installer. It worked but still complained:

[rtn@hawk downloads]$ sh install-crossover-games-demo-9.2.1.sh
Verifying archive integrity...OK
Uncompressing CrossOver Games
.................. bla bla bla ....
upgrade
Traceback (most recent call last):
  File "./bin/cxmessage", line 85, in <module>
    import gtk
ImportError: No module named gtk
/usr/share/themes/QtCurve/gtk-2.0/gtkrc:1: error: unexpected identifier `gtk-menu-images', expected keyword - e.g. `style'
[rtn@hawk downloads]$

Maybe this will help somebody.

Rob

Robert T Neece wrote:

snip>


[rtn@hawk downloads]$ sh install-crossover-games-demo-9.2.1.sh
Verifying archive integrity...OK
Uncompressing CrossOver Games
.................. bla bla bla ....
upgrade
Traceback (most recent call last):
File "./bin/cxmessage", line 85, in <module>
import gtk
ImportError: No module named gtk
/usr/share/themes/QtCurve/gtk-2.0/gtkrc:1: error: unexpected identifier `gtk-menu-images', expected keyword - e.g. `style'
[rtn@hawk downloads]$


> Maybe this will help somebody.

> Rob

Hi,

      That looks like python can't find it's gtk bindings -?- I've  
seen this before with another distro (Sidux), and then more succinctly,  
specifically related to the distro upgrade process...ie; in a clean install  
of the distro release version he was upgrading to, everything worked fine.  
We never did get to the bottom of it...umm...where is that thread..ahh..;

 http://www.codeweavers.com/support/forums/general/?t=26;forumcurPos=50;msg=87494

In the ensuing emails (where I told him not to send the disc, I was joking ;)  
Bernd ran a few more checks for me, and I believe the inclusion of the python2.6  
working tree was at the crux of it, and that somewhere, an rc file was directing   
python to look in the wrong place for the gtk module. In the end, I think we   
concluded if the upgrade path was busted -here-, there could be other stuff  
not quite right in the dist-upgrade process, and Bernd elected to run with a  
fresh install of Hypnos and just migrated his old stuff into the new installset.  
Everything then worked as expected...

Like I say, we never did find the actual culprit, and your situation is slightly  
different...but it sure looks like a similar sort of problem.

Hope this helps...

Cheers!

Thanks for the hints guys. Once I realized that the problem was a python problem and it was not finding the 'gtk' nor the 'gtk.glade' modules, I did the following:

Using the adept package manager, I installed first the python gtk module ("python-gtk2") then the python glade module ("python-glade2"). I looked at the adept manager install details and found that the modules were installed in "/usr/lib/pyshared/python2.6".

Then I set my PYTHONPATH environment value. I use 'tcsh' so my command to set the environment variable is:

setenv PYTHONPATH "/usr/lib/pyshared/python2.6:/usr/lib/python2.6:."

I then reran the install and the crossover window came up ok.

Jim Anderson

I just installed Crossover on Mepis 8.0 and had similar problems with missing libraries for python, GTk and/or glade. I see no way to capture the error message here but wanted to suggest that the distro list is a bit dated in not including Debian or any of its derivatives. I tried installing similar things to those suggested for Fedora et al.


Installed the following packages:
glade (3.4.5-3)
libgladeui-1-7 (3.4.5-3)
python-glade2 (2.12.1-6)

and got Crossover to install with these error messages:


hayden@GX260_2:/media/disk$ sh install-crossover-standard-10.0.3.bin
reinstall
/bin/sh: line 145: 15349 Terminated              "$CX_ROOT/bin/cxwait" --no-focus "Finishing insta                   llation"

(cxinstaller:15271): libglade-WARNING **: unknown property `orientation' for class `GtkVBox'

(That last line was actually repeated over and over.) Nonetheless, Office 2000 installed and I opened about half a dozen documents non-Linux users had sent me and they were rendered far better than they were by Open Office. So I am basically pleased but deepndencies could be handled a bit better. The exact names of the packages I installed may be of use to users of Mepis or other Debian 5 derivatives.

Hi,

...I think perhaps the reality here, is that the .bin installer in
no way deals with any dependencies, missing or otherwise. It will
install crossover, 'if it can' (you have enough system supports for
that much to happen) -- beyond that, is user-land. For the record,
crossover is actually built on Debian, and tested against the current
'popular' derivatives of that distro was well, and in that regard,
the various .deb packaged versions of crossover are available, which
should (in a perfect world) take care of installing any required system
dependencies ... in theory anyhow...

... not that I'm a big fan of that solution, either -- it invites a
system wide installation of crossover in /opt whereas for a typical,
average, single user machine, you should be using the .bin installer,
not the .deb package, for an isolated installation in your $HOMEDIR ...

..anyhow, having already helped a Mepis user with this briar patch,
I can see where the wheels are falling off -- the issue is an artifact
of the 'rolling release' linux distribution model -- they prove to be
more mobile than mainstream linux distros ; and the other factor here,
is that with derivative distros are in no way obligated to structure
their layout (or base installation targets) as aligned with the 'parent'
distribution on which they are based. That is more than likely the case
here, wherein you have to install dependencies not already part of the
base system makeup...

... then, this spools off into a rock and a tight place sketch, wherein
is seems the only apparent solution would be to have the .bin installer
be able to detect a missing dependency, and alert the user that they will
have to install such'n'such first, and then rerun the installer (which
might in itself prove difficult depending on which dependency is missing =)...

..there is one thing you could do ... (..umm...where has this gone?)..ah!,

http://www.codeweavers.com/support/wiki/linux/faq

...see the top-most entries there vis howto get things going on this'n'that
linux distro? An entry for Mepis is noticeably missing ... you can send an
email to info@codeweavers.com asking if they might include an entry there
for Mepis 8.0 , and you can include in that a draft of 'what you think it
should look like' (or else just ask for them to draw upon the data here),
and I'd be 'reasonably confident' such would be accepted into the FAQ there..

...I think that's far and away the best way to deal with this right now, as
exampled by the existence of the other 'distrocentric' entries in the FAQ. In
that way, it's about as easy as it gets for specific linux distro users, and
the information is prominently available (as opposed to having the solution
nested in the general forums somewhere)...

Cheers!

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoiUzRzcEdzdUV4RzJDeXlQaCIsImdkcHIiOjB9