CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Steam Source games not launching

Hey all,

I have been running fine for a couple of years, but this last weekend, I reloaded my OS from OpenSUSE to Ubuntu (Mint) and tried to reinstall Steam.

It installed just fine, but when I try to launch Source games, the game spash comes up, but then just dissappears. Non source games like the original Counter Strike and Day of Defeat work just fine.

Not sure how to troubleshoot as I have never had to 😀. Please let me know what you need to help fix the issue.

Computer is an Asus G71 Laptop with Intel Core 2 Duo (64bit CPU and OS)
6 Gigs ram
Mint 10 fully patched
Crossover Games version ia32-crossover-games-demo_9.2.0-1_amd64

Thanks!

Joe

Hi,

My guess is you're missing the 32bit nvidia video drivers...

Cheers!

Artist Formally Known as Dot wrote:

Hi,

My guess is you're missing the 32bit nvidia video drivers...

Cheers!

No, this guy is having the same problem as I and the other person is with TF2/Gmod. There was an update this past weekend that stopped the recently updated games from working. Ie. TF2, GMOD, CSS, DOD:S, etc. Anything that ran on Source.

We really need to find a work around for this. :/

Thanks.

Jeremy.

Jessica Reid wrote:

Artist Formally Known as Dot wrote:

Hi,

My guess is you're missing the 32bit nvidia video drivers...

Cheers!

No, this guy is having the same problem as I and the other person is
with TF2/Gmod. There was an update this past weekend that stopped
the recently updated games from working. Ie. TF2, GMOD, CSS, DOD:S,
etc. Anything that ran on Source.

We really need to find a work around for this. :/

Thanks.

Jeremy.

Can confirm it, CS Source and Beta doesn't start anymore. But for example L4D2 runs pretty well, but its the same source... Well thanks Valve that I can't play anymore, I love you...

Jessica Reid wrote:

No, this guy is having the same problem as I and the other person is
with TF2/Gmod. There was an update this past weekend that stopped
the recently updated games from working. Ie. TF2, GMOD, CSS, DOD:S,
etc. Anything that ran on Source.

We really need to find a work around for this. :/

Thanks.

Jeremy.

You dp realize it still all works fine on OSX?....hence my speculation.

It seems that Valve's update caused issues with the in-game community overlay, again.

EDIT: Don reports that the below doesn't work for him. It may still be worth trying, but don't get your hopes up.

Please try disabling it. It's not necessarily enough to disable it via Steam's settings. The most reliable way to disable it is via the Wine Configuration (winecfg) tool:

Go to Manage Bottles -> select bottle with Steam -> Control Panel. Launch winecfg. On winecfg's Applications tab, click Add Application. Select the executable of the Steam game that's having the problem (or just type its filename, like foobar.exe) and click Open. Select the Libraries tab of winecfg. Type GameOverlayRenderer in the "New override for library" edit field, click the Add button, click the Edit button, select Disable, click OK, and click OK. That prevents the in-game community overlay from even being loaded for that game.

If you don't use the in-game community, you might find it simpler to just disable it for the whole bottle. To do that, just skip the above steps involving the Applications tab of winecfg. Just leave it with Default Settings selected, which is how it starts, and go straight to the Libraries tab and proceed from there.

Further to what Ken mentions above, if it doesn't work for you then...

Ken linked me to a patch from one of the dev's (Henri) - I've rolled
that into the CXG-9.2 source tree and compiled a user32.dll.so library
that seems to get things working again. If you want to grab it and give
it a try, you can find it here - there's some instructions in the archive.

Please report back if it works for you....

Cheers!

Artist Formally Known as Dot wrote:

Further to what Ken mentions above, if it doesn't work for you
then...

Ken linked me to a patch from one of the dev's (Henri) - I've rolled

that into the CXG-9.2 source tree and compiled a user32.dll.so
library
that seems to get things working again. If you want to grab it and
give
it a try, you can find it
here

  • there's some instructions in the archive.

Please report back if it works for you....

Cheers!

works for me. thanks.

Artist Formally Known as Dot wrote:

Further to what Ken mentions above, if it doesn't work for you
then...

Ken linked me to a patch from one of the dev's (Henri) - I've rolled

that into the CXG-9.2 source tree and compiled a user32.dll.so
library
that seems to get things working again. If you want to grab it and
give
it a try, you can find it
here

  • there's some instructions in the archive.

Please report back if it works for you....

Cheers!

Could you please upload this to uppit.com aswell? Rapidshare says I have reached my download limit and I need to pay to download, which I don't want to do. I haven't downloaded from rapidshare in a while, so I have no idea why it is saying that.

Jessica Reid wrote:

Could you please upload this to uppit.com aswell? Rapidshare says I
have reached my download limit and I need to pay to download, which
I don't want to do. I haven't downloaded from rapidshare in a while,
so I have no idea why it is saying that.

Hi,

Done!

http://uppit.com/r0vy4bh1wppm/linux-cxg92-user32dllso.tar.gz

Cheers!

Artist Formally Known as Dot wrote:

Jessica Reid wrote:

Could you please upload this to uppit.com aswell? Rapidshare says
I
have reached my download limit and I need to pay to download,
which
I don't want to do. I haven't downloaded from rapidshare in a
while,
so I have no idea why it is saying that.

Hi,

Done!

http://uppit.com/r0vy4bh1wppm/linux-cxg92-user32dllso.tar.gz

Cheers!

Thank you so much! :D

This fix works perfectly, thank you so much for acting so quickly! :D

Support Library Article created for this issue:

http://www.codeweavers.com/support/wiki/CXGamesApp_SteamSourceGames

We are working on a more permanent fix!

Fix works here as well...

Thanks!

Joe

Fix works too, on CSS installed on Ubuntu 64
Thanks a lot!

not working for me. steam comes up but no games play.

Hi,

Which linux distro? Do other non Steam (non-Source based) games work?
If neither of the workarounds fix things and/or the 9.2.1 release doesn't
help, you're going to need provide some more details.

Cheers!

Hello Don,

since this issue seems to persist with CX Games 9.2.1 would it be possible to make an updated version of the user32.dll.so that works again with 9.2.1?

Regards,

Matteo

Hi,

The dll library I compiled for Crossover Games 9.2, should work (or not)
in 9.2.1 -- I say '(or not)' as subsequent to this problem appearing, we
have found that not all linux distros are behaving the same here. I would
have you try the 'other' fix first (disable gameoverlayrenderer)...see;

http://www.codeweavers.com/support/wiki/CXGamesApp_SteamSourceGames

I know there is no significant difference in the crossover/wine code portion
affected here between 9.2 & 9.2.1 and as such the dll library available
from the above link ~should~ work. If it doesn't (and the other fix doesn't
work either), then we need to know which platform/OS{distro} version you
are using...please let us know how you go with the above fixes and what
distro/version you are using. Afaik, this issue is still being investigated
and is not completely understood...yet...

Cheers!

Hello Don,

I already tried the said user32.dll.so on the day of the release of CXG 9.2.1 and it was not compatible. I am running on Ubuntu 10.10 32-bit. The fix, by disabling the whole Gameoverlay was working all the time for me, by just disabling it via the switch inside Steam. Anyways as I'm using the Overlay regularly I was 'forced' to switch back to 9.2.0 because this + the fixed dll was still working fine. I also reported the whole issue to Codeweavers support, but didn't really get a lot of attention, being only referred to fix this by disabling the Overlay.
Anyways, I hope you can work around this soon and deliver a final fix, maybe in 9.2.2?! I was just hoping that in between that time there would be a new build of the dll specifically for 9.2.1, so I could do the update and still keep the Overlay working.

Best regards,
Matteo

Hey, I've got the steam version of Bioshock 2 installed and when I go to run all runs and activates except crashes and says to open it through the Bioshock 2 Launcher exe direct, I do so but receive this error:

http://img683.imageshack.us/i/screenshotbioshock2.png/

Any ideas what I can do to get Crossover to be seen as at least an XP system? Thanks!

I've been playing TF2 with Crossover Games for over a year with little or no problems. The 11/29/2011 Team Fortress 2 update broke the game on my system.

I'm running a Toshiba Satellite P505-S8010, with Mandriva Linux 2010.2. I upgraded my Crossover Games last night to version 10.2, but this did not fix my issue. I also tried installing DirectX9 in the bottle in which I'm running Steam, but that also had no effect. I normally run the game windowed, at a resolution of 1440x900. I've tried full screen, but have the same problem.

Steam loads without issues. TF2 loads to the main menu screen, however that screen is now mostly black, and the menu items which do show up are dark, as though you put a very dark filter over the screen. I can see just well enough to pick out a server and press "connect". The game goes through the motions of loading for awhile, and then exits with one of the two following errors:

Failed to lock index buffer in CMeshDX8::LockIndexbuffer
Failed to lock vertex buffer in CMeshDX8::LockVertexBuffer

Any help or suggestions will be appreciated.

On a side note, I purchased Portal2 about 9 months ago and have never been able to play it, even natively in Windows. The best I could do was play for 5 or 10 minutes, and the game would crash. Last night, unable to play TF2, I tried Portal2 in Linux, with Crossover. It worked!! I played for about 3 hours with no crash.

You guys do great work. I sure hope I can get my TF2 back soon.

Thanks.

Hi,,,

... please learn to search for your app in this database, and
check it's forum first before posting here ; seriously, you will
save yourself -so- much time =)...

http://www.codeweavers.com/compatibility/browse/name/?app_id=3379;forum=1;mhl=114382

...my guess is you're seeing the same issue ; try the fix... B)

Cheers!

ps: and if it doesn't work for you, post back to that forum, not here ..<grin>..

Same here, again, with the last update for Day Of Defeat Source - Counter Strike Source works fine, but I will try the TF 2 fix that is mentioned in the other thread.

Looks simple enough to implement.

Joe

Hi...

...yes, I think that was another title affected by the update.

http://store.steampowered.com/news/?feed=steam_updates&appids=440

..the Nov. 30/Dec 1st updates...

Cheers!

1 to 25 of 25

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzIxMzI3MzE0LCJjc3JmX3Rva2VuIjoiUGU1bkJYZHFSN2RTTTY2biIsImdkcHIiOjB9