CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Missing libgnutls 32bit library

Hi, I am getting this message everytime I try to install a software, I tried to re-install it but it wont. When I want to un-install it, it wants to remove a lot of other stuff, is there a way to remove it, without removing everything? Then I could install it again and probably fix my problem.Thx for the help.

What linux distro are you using?

Im using hardy, it should use libgnutls13 and it is installed, but I know that it should be upgraded to libgnutls13 2.0.4-1ubuntu2.6 and when I try to upgrade it here is what I get :


sudo apt-get install libgnutls13 2.0.4-1ubuntu2.6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgnutls13 is already the newest version.
E: Couldn't find package 2.0.4-1ubuntu2.6

I also tried to uninstall it and it wants to remove pretty much everything lol, so this doesnt look good. Thx for the help.

Your error there is that you've told it to install two packages - libgnutls13 and 2.0.4-1ubuntu2.6. That's why you're getting told libgnutls is the newest version, and it can't find the package '2.0.4...'.

The newest package in Hardy is libgnutls13_2.0.4-1ubuntu2.6 but it looks like you already have that as it's saying you have the newest version.

Intrepid, Jaunty, and the soon-to-be-released Karmic all have newer versions, but it would appear they haven't been backported.

Nope I dont when I looked in synaptic it says I have the 2.0.5 version installed not 2.0.6 but ill try that without the libgnutls13
Thx
This is what I got when i tried to install the new package :


 sudo apt-get install 2.0.4-1ubuntu2.6
[sudo] password for terak: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Couldn't find package 2.0.4-1ubuntu2.6

That's to be expected. There's no package in the repo simply called '2.0.4-1ubuntu2.6' - therefore it's not found. The package name is 'libgnutls13_2.0.4-1ubuntu2.6' - note there's no spaces in it.

You may need to enable the security repo in order to get the update, as it's just a security patch.

it is still not finding that package libgnutls13_2.0.4-1ubuntu2.6 and I do have enabled the security repo. What is going on?
Thanks for the help it is greatly appreciated, I hope I am not going to have to reinstall my OS. I think it may be compromised it hasnt done any update for so long I think something is wrong.

You could always try downloading it manually from http://packages.ubuntu.com/hardy/libgnutls13 - the download links are at the bottom. If you don't know which one you want, you want the i386 one. Double click it to install, and let us know any messages the installer comes back with.

(Thinking about it, did Hardy have a proper updater? You may want to run 'sudo apt-get update' just to make sure you're working with the newest repo lists, and try again)

Thanks it seems to have unblocked the update manager now i have many updates available and the new package has install successfully, now in synaptic i see 2 more libgnutls package that werent there before and I can finally install the sxx package which wouldnt before, I have the dev and dbg package that werent listed before, I am installing them now...it installed fine now i am trying crossover again and see if I get the same message....nope same thing it says :

Missing 32bit libgnutls.so.26 library

Will update what is now in update manager and see if this solves the problem, do you think i should restart crossover or reboot for changes to take effect?
I will need to reboot the comp for changes to take effect and I have to go out to do some important things will be back and give you an update in about 4hours or less, cheers and thanks a million, much appreciated.

libgnutls26 didn't get introduced until Intrepid, as far as I'm aware, so if you need it in Hardy you'll need to get it manually - and it may not want to install easily.

<EDIT> - http://packages.debian.org/lenny/i386/libgnutls26 - The Debian package looks more likely to work, as it shouldn't require you to go on a mad upgrade spree. Please note, though, if it doesn't just install easily you may want to reconsider. Debian packages are usually compatible with Ubuntu, as they are closely related, but do bear in mind it's an unsupported method. </EDIT>

If you're up for giving it a go, you can download it for either Intrepid, Jaunty or Karmic (I would try Intrepid's, if you're set on trying) from http://ns2.canonical.com/search?keywords=libgnutls26 - but be warned that it may break your system as it's not meant for Hardy.

If Crossover is really dependant on libgnutls26 it would appear they may need to change their requirements page.

I think my best alternative would be to down grade to crossoverpro 7, I didnt need that then, and I am not ready to upgrade to Intredip just yet, will need to have more time to put on this to get it all done, pretty busy these days, well thanks for all your help you have been so kind, I thank you very very much Carl, you been a great help.
I sure dont want to break my system, but will give a go for upgrade once I get a full day to spend on it, cheers.

TC

Roger

No problem, if you need more help on it just reply to this thread and I'll get an email notice.

Ok solved I upgraded to the 8.10 release and all is well now, it doesnt cry for the libgnutls26 anymore, yep they should mention that version 8 requires minimum 8.10 to work with encryption, cause that is what the message was saying : certain windows app will not be able to use encryption without it, and for me it is a must that uTorrent can use it, most important I might add, lol.
Cheers. Hope this can help someone else if they have the same problem.

1 to 13 of 13

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE4NzMyNzMzLCJjc3JmX3Rva2VuIjoiR1duQmR1WkJzcmZHZDd5MyIsImdkcHIiOjB9