CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Incompatibility associated with the AMD 64 X2 processor ...QuickBooks

I think I have found an incompatibility or bug associated with the AMD 64 X2 processor. It appears to be either Ubuntu or Codeweavers Cross Over product, or in Wine, or it might be something to do with QuickBooks. But there are so many variables I need more data. What I do know is that there is something that is preventing QuickBooks from running. Here is what I have found:

Intel PC: P4 3Ghz, 2GB RAM, Ubuntu 8.04, Codeweavers 6.2, Wine 1.0
QuickBooks 4.0 runs great under Codeweavers.
Quicken 2005 runs great under Codeweavers.
eSword, Spider Solitaire runs great under Wine.

AMD PC: AMD 64 X2 6000+, 4GB RAM, Ubuntu 8.04, Codeweavers 6.2, Wine 1.0.
QuickBooks 4.0 will not run.
Quicken 2005 runs great
eSword, Spider Solitaire runs great under Wine.

On the AMD PC, I have tried both Codeweavers 6.2 and 7.2.
On the AMD PC, I have tried to get QuickBooks to run by:

  • installing both Ubuntu 8.04 and 8.10
  • installing both versions of Codeweavers
  • I cloned the hard drive from the Intel PC and it booted and ran on the AMD PC but QuickBooks would not run

When I say QuickBooks will not run, I mean that it presents a small window with a yellow "!" caution icon and an OK button. After clicking the OK button 9 times, this message appears: QuickBooks requires 2.5 Megabytes (2560K) of free RAM. Close other applications in order to free up memory.

So, what do you think? Is is a quirk with the AMD 64? A quirk with Ubuntu as it runs on the AMD 64? A Codeweavers quirk? Could it be some esoteric feature in Quick Books that ties it to something with Intel processors?




We'll suppose quick books runs fine on AMD 64 x2 rigs running the OS
it was designed for, so it's possibly not the program itself.

I'm not a codeweavers dev, so I can't comment on whether or not
crossover handles the two processor types differently....

It does occur to me however, that the IOMMU code in recent linux
kernels has been a bit buggy running on AMD 64 CPUs, so ypu might
try booting with that turned off and see if it resolves anything.

I tried both IOMMU=soft and IOMMU=off in the Kernel boot string in the Grub Menu -- still no joy getting Quick Books to work.

There is something quirky that has to do with the AMD 64 or the code in the OS or QuickBooks.

Has anyone at Codeweavers gotten Quick Books to run on AMD 64 X2 processors?


'if you don't know where something is, first find where it is not'...

So, not iommu apparently...further thoughts and ideas ;

I would have removed 2gb of ram from the AMD rig, just to make the
two machine specs as close as possible (I know it shouldn't matter
and isn't a pleasant workaround, but I would do it to better define
the two environments, and if something changed, we would be wiser ;)

If, as you infer, quickbooks was seeing a difference in the CPU being
used at the time, and thus changed the way it loaded or ran, I think
that's going to be hard to define - we are talking closed source
proprietary software after all, and this will limit dissection...

Crossover, on the other hand, is pretty easy to look at objectively
here -- for instance, the next thing I would try, would be installing
the latest WINE and trying quickbooks in that. I don't know if it runs
in current WINE or not, but, it'd be an interesting comparative test.
-If- it installed and ran fine like this, or else did exactly the same
thing, else did something completely different've learnt
something. Depending on what happened, would determine what happens next.
Somehow, you have to narrow the possibilites...

The other great contender for mine, is the linux kernel itself. The fact
that you transposed the intel instance (that worked on intel hardware with
cx/quickbooks) to the AMD rig and it booted, ran and worked but still didn't
do the cx/quickbooks thing, makes me wonder just what kernel got loaded. (I
don't personally know how ubuntu arrange things here)..but it probably was
the generic_x86_64 kernel build (unless ubuntu keeps amd64 kernel images
handy incase someone changes machine under you... ;), and so if this were
the case, then I'd definitely ensure that I tried another kernel build. I
know, you already tried the AMD specific release...but what kernel was that?
It could easily have been the generic build as well....

This is one of those quirky, obscure and curious happenings that one is
-lucky- to ever come across...I have seen it before. Too many times, I'm
quite insane now. However, you asked for comments and this is a discussion
forum, and if you find anything out for sure then that will lead to a truly
useful support ticket for the cx devs to look at...who knows, perhaps they
are already aware of this problem?....

<cue, stage left, enter cx dev with answer>

Is it possible that Quickbooks is just tying its installed version to a specific machine?(copy protection) Some of them do this by looking at Mac ADDr, Disk serial number, or even cpu serial number if its enabled. The fact that your second machine is AMD might be a red herring - do you know if your cloned system will run it properly on a different intel box?

Some more data regarding this AMD X2 6000+ CPU:

I tried to install QuickBooks using CodeWeavers 6.2 and also 7.1 on:
1- on a fresh install of Ubuntu 8.04 on the AMD PC
2- on a fresh install of Ubuntu 8.10 on the AMD PC
3- using the hard drive image for an Intel CPU on the AMD PC

I've spent a lot of time trying to figure this one out.

BTW, Quicken 2005 ran ok on all instances.


Andrew Chandler wrote:

Is it possible that Quickbooks is just tying its installed version
to a specific machine?(copy protection) Some of them do this by
looking at Mac ADDr, Disk serial number, or even cpu serial number
if its enabled. The fact that your second machine is AMD might be
a red herring - do you know if your cloned system will run it
properly on a different intel box?

Yeah, like I said in my original reply on this one, we are supposing the app runs
fine on this AMD hardware using the native OS it was designed for - unless that very
supposition can be tested & verified, we (or rather Carl ;) might be flogging a
dead; perhaps the app doesn't run on AMD x2 even with a 'real' Windows
installation? It would be nice to know for sure...(especially if the software
itself was created/released before the amd x2 was)...

Also, it's a bit speculative citing the AMD x2 as the possible problem - what about
the same kit with an AMD LE sempron fitted, or an x3, or a phenom - there's a few
shades of gray here, is it the AMD core or just this version of same? The AMD &
intel cores are intrinsically different, as remarked by they respective cpu_flags.
If the app is looking for a specific capabilities flag the AMD core doesn't have,
then this might be a bug in the -app- and not in cx or the AMD cpu at all. There's
so many things one could check and try to eliminate here, if you know what I mean.

What you entertain here regarding 'coded to a specific hardware key' is indeed
possible...we'd like to hope it's improbable, but, as you indicate, there is only
one way to know for; does it run on a different intel rig? There are so
many cross-checks one can do here to help isolate the exact cause, and really, the
surface has been barely scratched here....

Carl - in your response you indicate you tried installing quickbooks so that may eliminate one possibility - I was getting at the fact that when you installed it on your intel rig and put in your cd key it may have locked that installation to the hardware it was installed on - cloning the whole thing over to another system wouldn't work because quickbooks would detect that it had been duplicated. However a re-install should have gone through the process of taking a cd key and registering that system with intuit. Assuming quickbooks uses the whole cd-key registration thing. Sorry I can't think of anything else short of trying to get your hands on another intel based linux system to try the install or clone process on.

OK, I think I found some more information as to why Quick Books will not run.

I originally had 4GB RAM in my PC and Quick Books would not start up.

When I backed off the RAM to 2GB, Quick Books started up and worked as it should.
When I increased RAM to 3GB, Quick Books failed just like it did when I had 4GB installed.

So, there is something about the amount of memory that is bothering either Codeweavers or the Quick Books application. If you are having problems getting Quick Books to work with Linux, having "too much RAM" might be the issue.


Glad to hear you've made some headway -- when I suggested you drop the AMD powered
rig from 4gb ram back to 2gb, that inkling was drawn from the past 8years doing
stuff on my son's XP box (with AMD cpu) and encountering the same thing ; many of
his games simply would not run with more than 2gb ram installed. (iirc his sblive
card also had trouble with more than 2gb ram).

An interesting check, would be stacking your intel rig with 4gb ram and seeing if
it behaved the same - at least this would narrow things down, for the purposes of
a tips&tricks entry for this app.

Has anyone come up with a solution to this? Quickbooks 2001 does not run with AMD 64x2 with 4G ram, it does run if I remove 2G of ram. The other Windows apps I have tried seem to work ok with 4G ram so it seems to be a Qbooks issue.


1 to 11 of 11

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...