CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Weird installation problem between WINE and Crossover

I have yet to get a good answer from the WINE forums, so I'm submitting it here. I'm trying to install some programming software for my ham radio; this software is considered "unsupported" by Crossover, but it's not anything fancy.

I tried installing it under WINE 1.0, 1.1.3, and 1.1.16, but every time the install hangs with, "Please insert disk containing "data3.cab"--except there isn't any file by that name on the disk (I even grepped for it). I then tried Crossover Linux and it installed and ran without a hitch (just needed to add the link so I could access the serial dongle). Finally, a couple of suggestions and some searching later, I found a program called "unshield", which broke it down without any problems, though I have no idea how to tell WINE to install the mess of directories left by unshield.

At first, I thought this might be DRM, but unshield working proves it isn't (I think). Then I noticed something: in a directory that looks like it has a corrupted name lies the executable along with 2 files that appear to provide localization, one saying "eng" and the other "jap". This program is made by a Japanese company, so I'm thinking that the "corrupted" directory name may actually be Japanese in Unicode or some other system, though I have no idea how to check.

So that brings me to the question I haven't had answered yet: if this is indeed what it is, could Crossover have some foreign-language-handling ability that somehow never got integrated back into WINE?

I have no problem paying for Crossover since the work goes back into FOSS WINE so I consider it almost a sort of "donation", along with the fact I'm a sometimes-gamer (mainly VALVe/Steam stuff), but I really would like to nail this problem down so I can make a bug report or whatever.

Thanks, Mike


This issue has been forwarded to the Official CodeWeaver's Ticket System. If you have observed this issue and would like to report it as well, please open a support ticket or send an email to info@codeweavers.com with a description of what you are seeing and a link to this post.

Thank you!
The CodeWeavers Team


Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE4NzMyNzMzLCJjc3JmX3Rva2VuIjoiYk5MRkFDS0UzQVpNeHdyNiIsImdkcHIiOjB9