CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

CrossOver Linux 18.5.0 fails to install on Ubuntu 20.04

Hi friends,
I have purchased CrossOver Linux 18.5.0 and previous version , but now after upgrading to Ubuntu 20.04 CrossOver Linux 18.5.0 does not work any more . I have attempted to reinstall I get :
CrossOver needs your permission to install missing packages.
This operation must be run as root:

sh -c "apt-get update; apt-get install python-dbus python-gtk2"

after i get it root password I get:
E: Unable to locate package python-gtk2
Finished. Press Return to continue.

Is installer going to get fixed?
Latest version installs without problem, but I cannot afford it at the moment.
Kind Regards

Hi

It seems that ubuntu has removed python gtk2, go to this site https://pkgs.org/download/python-gtk2 , this package is missing for ubuntu 20, however you can try to install this package from previous version of ubuntu (try 19.10 then 18.04 and as last hope 16.04), it should be compatible but it's not a sure thing. If you manage to solve this dependecy issue run this command to install other dependecies,are secondary packages but they can improve your experience, just run this command,once cross over is installed /opt/cxoffice/bin/cxfix --auto . To allow dxvk to work run sudo apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386 libvulkan1 libvulkan1:i386 vulkan-utils .

Ps download and install first the amd64 version of the package (for 64 bit Os), to do so click on the package name into the archive a new page will show up go down till you reach the download section copy the link of the binary package and paste it into google bar to search it, once you pressed enter the download will begin. Hope it helps.

Actually...

I installed it on 20 by searching for the python-gtk2 amd64 deb on google. Installed that, then ran cxsetup and installed more stuff. Then ran apt-get install python dh-python python-gnome2, cxsetup again. Install the .deb and the python-gnome2 dh-python python python-cairo python-gobject-2, then cxsetup.

Works for me! Now, the list of apps is dated so I do Unlisted in Win 10 bottle.

I came across a similar type of problem with the latest out-of-distro version of "youtube-dl" on Linux Mint 20/Ubuntu 20.04. (This was before I got around to testing Crossover Linux on Mint 20):

problem:
Out-of-distro "youtube-dl" has "python-*" dependencies, but they don't exist on Mint 20.

solution:
sudo apt install python
This installs "python-is-python2" package on Mint 20. Then the "python2-" packages which do exist on Mint 20 (Ubuntu 20.04) are used by the older applications that are just looking for "python-".

I haven't verified with Crossover, but it just sounds like it could be the same issue.

I just had this problem, where crossover wouldnt work after running the installer on ubuntu 20.04.
here is a thread I made on askubuntu https://askubuntu.com/questions/1327626/dependency-not-found/1327629?noredirect=1#comment2262514_1327629

my issue was having had a previous version of crossover installed. The deb installer I guess doesnt check for previous versions having been installed. I then got the dependency issue about python-gtk2. Subsequently, python-gtk2 is depreciated, and I couldn't find a functional replacement, so I purged my old installation of crossover. sudo apt-get purge crossover

then ran the generic shell installer. It installed again, without error, and without having messages about needing to install the python-gtk2 package.

maybe a check for previously installed versions can be added to the deb file installer. (no idea if this issue effects other package manager installer types)

For the .deb installer to detect older .bin installers would require searching every user's home directory on install. I don't think we want to do that.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzAwMTUwMjM1LCJjc3JmX3Rva2VuIjoiVUw0YVlHbjdiN0hiblg0ZyIsImdkcHIiOjB9