CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

DMR CPS under CrossOver for Linux Not Recognizing Com Ports

This is probably a little bit of an esoteric issue, but I am throwing it out in hopes someone will have some insight for me. I have a DMR (Digital Mobil Radio) that requires programming with a CPS (Customer Programming Software) program that is Windows only provided by the vendor of the radio. This was one of my main reasons (but not the only reason) for getting CrossOver for Linux. I am running Ubuntu 16.04 LTS under Crouton on an Asus Flip c302 Chromebook, all my Linux software runs great. I hit a snag with the CPS however because it needs to recognize an FTDI programming cable and the program must recognize the com ports. So far I have followed the recommendations to edit the bottle's registry (CPS_Bottle, a Windows 7 bottle). Everything looks good when I look in ~/.cxoffice/CPS_Bottle/dosdevices, com1, com2, com3 and com4 are there. I also ran the comparison of the /dev directory with the FTDI cable disconnected and connected, and the new device is /dev/ttyACM0. So I tried making symbolic links also, but of course the response was "File already exists." Finally, I ran the vendor's USB cable driver for Windows 7 under CrossOver, which reported the installation succeeded. The CPS itself installed fine under CrossOver. But when I go to the "Set Com Port" menu item, the window is blank - on my antique Windows 7 machine, on which I only ran the vendor's USB cable driver, it always shows me com4, which works with the CPS. I would really rather manage my DMR radio under CrossOver for Linux rather than the old Windows laptop, but I need to figure this out, TIA for any thoughts or advice!

Pat Anderson
KD7OAC

I am having the same issue. From what I understand so far, Wine (the code underneath Crossover) does not currently support USB devices. I've tracked a few threads that are talking about how to try to get access to a specific USB device, but so far have not found a work around. It's a bummer, I'd love to be able to access the CPS without booting a full Windows VM.

Hi,

A bit late to party... Health issues have kept me away.
Not wishing to teach you how to suck eggs...
I'm also looking at this...

You have added yourself to the Dialout Group..??
Needed to access serial/tty stuff...

sudo usermod -aG dialout your-username

Then restart/re-boot

73 Dave G8LIY

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoiWUFiVmRZbnlQNlNTYUFjayIsImdkcHIiOjB9