CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

New to Crossover and Office 2016
Jan G
Jan G
Posted 2017-12-16 14:37
Hello there,

I'm new to crossover and fairly new to Linux and I'm having trouble setting up CO with Office 2016 on my Mint 18.3. Specifically, running the installer doesn't seem to finish properly and the last debug line reads:
"err:module:load_builtin_dll failed to load .so lib for builtin L"winebus.sys": libudev.so.1: cannot open shared object file: No such file or directory
err:winedevice:async_create_driver failed to create driver L"WineBus": c0000142
-> rc=0  (took 0.714734077453613 seconds)
'/home/pao/.cxoffice/New_Bottle/cxnsplugin.conf' not modified -> no need to save
:cxlogfilter:exit"

I'm not quite sure what to do now. Can anyone offer a hint or two? That'd be greatly appreciated!

Jan
-----
This issue has been forwarded to the Official CodeWeavers Ticket System.  If you have observed this issue and would like to report it as well, please open a support ticket or send an email to info@codeweavers.com with a description of what you are seeing and a link to this post.

Thank you!
The CodeWeavers Team
Ian Dunn
Ian Dunn
Posted 2017-12-21 05:40
Yes I would like a guide to using crossover 7 and installing Office 2016 as repetitively failed to install either the 32 or 64 bit versions of office, would like to know where I am going wrong. Got quite excited seeing that crossover 7 was office 2016 compt.
Michael Anderson
Michael Anderson
Posted 2017-12-21 09:01
Greetings!

 I'm running  Mint 18.2 nad I have been successful at getting Office 2016 to install.  The online-installer never worked for me.  It would always crash.  However, if you download the ISO, that install seems to work and the Office will authenticate w/ Microsoft afterwards.  However, even after the install, there will be glitches.  In particular, I'm running the proprietary Nvidia driver so Office detects the DirectX during installation.  But, the interface between DirectX and OpenGL seems wonky.  Powerpoint will seem to freeze sometimes while rendering the charts on load.  Then I'll get artifacts on the screen that can be made to go away if you resize the application (or that can also make it worse).  So, far all of the applications sem to work at some level.  However, there is an anomaly where if I close the application with the "X" button, the app doesn't actually die but sits in background as a non-visible that starts burning CPU until I kill -9 it and the wineserver.  I use gkrellm to monitor my machine all the time.  So, I see the CPU meters jump up and the fans will come on and that let's me know that the application did die correctly.  I'm still working on the sequence that cause this to report it.

FWIW, my machine is a Dell Precision 5510 laptop with 32GBs RAM, 2.5 TB of SSD, a Xeon E3-1505, and Nvidia Quadro M1000 GPU.  I'm running Minr 18.2 with a 4.12.5 kernel.

HTH,

Mike
Ian Dunn
Ian Dunn
Posted 2018-01-01 13:16
I have managed to get a log file of office 2016 attempting to run .. i seem to be missing some dependencies but no idea how to resolve them..

cxdiag output:
[MissingLibOpencl]
"Level"="Suggest"
"Title"="Missing 32bit libOpenCL.so.1 library"
"Description"="Provides GPU computation support to Windows applications."

[MissingLibOsmesa8]
"Level"="Suggest"
"Title"="Missing 32bit libOSMesa.so.8 library"
"Description"="This is needed by some games and CAD-like applications to perform off-screen rendering."

[Properties]
"opengl.glsl_version"="1.20"

[OpenglNoGLSL130]
"Level"="Suggest"
"Title"="OpenGL shading language version is older than 1.30"
"Description"="This is needed for limited DirectX 10 support."
-----
This issue has been forwarded to the Official CodeWeavers Ticket System.  If you have observed this issue and would like to report it as well, please open a support ticket or send an email to info@codeweavers.com with a description of what you are seeing and a link to this post.

Thank you!
The CodeWeavers Team
Mike
Mike Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 3
Posted 2018-01-01 19:19
Office 2016 has a crosstie for easy install. on the right on this page click on the install now button for the crosstie. https://www.codeweavers.com/compatibility/crossover/microsoft-office-2016
Frederic BOTTARO
Frederic BOTTARO
Posted 2018-01-07 23:48
Hi,

Running Linux Mint 18.3 on a Dual Xeon MoBo with 64GB of RAM.
All updates are made.
The computer is running a Radeon X460 GPU with no proprietary drivers, only the free drivers for AMD GPU's.

Trying to install Office 2016 from an original .iso file.
The file is detected.
But after a while, it says : "The installer encountered a serious problem".

I tried to use the crosstie file even though I have no diea how to use it.
It's said on your site to select to start it using CorssOver Crosstie Launcher...
Guess what : I do not have that option on my CrossOver 17 for Linux...

So I guess the replacement to my VM to run Office on Linux has not arisen yet 😢
I placed high hopes in CrossOver 17. So far, it's been a disappointment.

Regards.
Tyler Gale
Tyler Gale Chief Senior Advocate
Posted 2018-01-10 02:49
The error indicates that you do not have 32 bit mesa libraries installed, which is usual for a 64 bit system.  You will need to install the 32 bit libraries, which via Ubuntu is done via "sudo apt install lib32-mesa".  Alternatively, if you fancy a bit of Linux gaming, the libraries required are installed if you install Steam!
Frederic BOTTARO
Frederic BOTTARO
Posted 2018-02-03 08:01
Hi Tyler Gale,

Thanks for your will to help.
Unfortunately, that isn't working 😢

Your command returns a "package not found" even though I of course enabled MultiArch to allow apt to search 32-bit packages.

I also alternativelty installed Steam which launches on the computer, but I still get that nasty : "Installer encountered a serious problem" error 😢

It seems there's A LOT of work to do to get Office 2016 to run and that the promises of CodeWeavers are FAR to be kept.

Regards.
Hana Pagel
Hana Pagel  Staff Member
Posted 2018-02-06 12:45
We have just released CrossOver 17.1 for macOS and Linux, which includes critical bug fixes for Office 2016 installation. If you have experienced problems installing Office 2016, please upgrade to 17.1 here (https://www.codeweavers.com/CX171) or contact our support team for more information.

Thank you for your patience as we have worked to resolve this issue.

Thanks,

Hana
CodeWeavers
Gary Thornton
Gary Thornton
Posted 2018-02-09 05:32
Hi all

First the good news:

I did all the updates then I fought through all of the hurdles to get Office 2016 installed.  For me these were logging into my Office.com account from my browser, telling my browser to use a IE9 user agent, downloading the installer .exe to disk, then going through the normal Crossover process to install Office 2016 into a new bottle.  This seemed to work well and I was able to fire up Word, Excel etc to register them online./

Now the BAD news:
1) When I load a spreadsheet Excel is SOOOOOO slow to respond to any input (5 seconds to recognise a character has been typed into a cell)
2) Word is slightly better at maybe 2-3 seconds to recognise any typing
3) When I run TOP I see that any Office program immediately takes 100% of the CPU

I am running Crossover 17.10 on Ubuntu 16.04LTS (the Ubuntu upgrade to 17.10 killed my other machine so I am hanging on to 16.04 for now), Thinkpad X220 with 4GB RAM and 500GB disk.  Crossover continues to work absolutely fine with my old Office 2007 bottle.

I don't know where else to go now to resolve these issues.
-----
This issue has been forwarded to the Official CodeWeavers Ticket System.  If you have observed this issue and would like to report it as well, please open a support ticket or send an email to info@codeweavers.com with a description of what you are seeing and a link to this post.

Thank you!
The CodeWeavers Team
Andrew Craig
Andrew Craig
Posted 2018-02-23 05:38
Hi,

Has any of this been resolved yet. I am attempting to install Office 2016 and having no luck.

Has anyone actually got this working yet on Debian stable?

What should I try next. I really want to purchase CrossOver but have not had a good experience so far. Please help.

I get error Unhandled exception: assertion failed in 32-bit code (0xf7f2adc9).



Gary Thornton
Gary Thornton
Posted 2018-02-23 05:50
Andrew

It still hasn't been resolved.  To be fair, Brian from CodeWeavers responded to me and suggested I try installing again into a new bottle.  I have subsequently done that on two different machines, one running Ubuntu 16.04 (with X11) and one running Ubuntu 17.10 (with Wayland) and got exactly same result, it works but is so slow as to be unusable.

I've emailed Brian back and updated him.

Meantime, if I need to use Office 2016 it is back to running up a virtual machine.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTg2NDQyNzI0fQ==