CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Reply to Thread Back to Threads

Linux mint 19.0 + crossover 17.5 + office 2013 = black screen/window
Posted for info, it has been raised as a bug:



Mint 18.3 + crossover 17.5 + office 2013 runs fine (at least excel and word do). Main laptop is a Thinkpad T430 running LM18.3, testing LM19.0 on another T430.

Copied over /home to testing T430, installed LM19.0 in new root partition, installed crossover 17.5 (from same deb as main T430). Crossover found all my installed win apps (it should since they are all sat in home/andy/.cxoffice). Photoshop 7.0 runs fine but both word and excel start up with a black window. They are running because you can click top right to close the app, just can't see anything.

Deleted the office 2013 bottle, exported it from the main T430 and imported into the testing T430 = no change.

I will try a fresh install of office 2013 (have run out of licensed copies :() and see if it makes any difference and post further if it does.
Solved, after a fashion!

Deleted the existing office 2013 bottle (the one giving me the black screens) and did a fresh install of office 2013 from DVD. Think this used up the last of my licensed copies for office 2013. I did notice that crossover installed a number of additional packages into LM, didn't make a note, it's on my other laptop.

Fired up both word and excel, both worked, no black windows.

Deleted the office 2013 bottle I'd just created and imported the office 2013 bottle from my main laptop. It all works, no black screens.

While this works, it is a workaround, when I have to do this for 'real' on my daily driver, it's not going to activate online because I've hit the 3 copy limit. This is a PITA.

So... this is not a problem with LM19+crossover+office2013, more a problem with copying/importing an office 2013 bottle. A crossover problem, not a LM19 problem.
The what runs db says Office 2013 has limited functionality did you try installing office using the crosstie from here. https://www.codeweavers.com/compatibility/crossover/microsoft-office-2013
that's interesting, in that the bug appears in CX17x and not in the operating system LM19 series,
as that is what I'd wish to do - - import an saved copy of MS Office, so as to not have to re-use an licence key.

but, in having to re-install Office 2013, then that does defeat the whole purpose of exporting an bottle, doesn't it ?.
and I've proven the same issue, as well, but don't wish to have to re-install again, like you did.
so, on the machine, that I've got CX16 & Office 2013 working okay, then I'll leave it well alone, for the moment.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjAzMTM4NzM0LCJjc3JmX3Rva2VuIjoiblRkdnZNVnB2Z2hnSFRQZyIsImdkcHIiOjB9