CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Scrivener Registration Failure

I have successfully installed Scrivener 1.9.16 at least three (3) times under Crossover but each time have been unsuccessful in registering it.

The initial times I used the file downloaded from L&L's Web Site. Later I discovered it is listed as an Available Application, and used it. Regrettably, the failure was the same each time.

I believe I have selected the bottle as both Win 7 and Win 7 64-Bit, neither working and both complaining that it required Net 4.5 - though Crossover showed it had downloaded and installed Net 4.6.2. A representative of Codeweavers suggested I possibly try a Win 10 bottle. I would prefer some guidance, as to whether a Win 10 bottle might work, before following that suggestion.

Does anyone have any suggestions of a remedy for this problem?

[I have four (4) PNG files that display the error messages, but apparently am unable to include them herein. i can provide them offline as e-mail attachments if anyone has any ideas and would like to see them.]

This is in supplement of my earlier posting, regarding problems w/ registration of Scrivener 1.9.16 on my Linux Debian platform.

In order to save space in Root, and as they weren't helping me anyway, I decided to uninstall Wine, PlayOn Linux, and Winetricks, and to try Crossover. After installing Crossover I was able to successfully install and open Scrivener using both the 1.9.16 version downloaded from the L&L site and the Crosstalk Available Applications version (which also was 1.9.16) Both of them presented the same problem, viz, on attempted registration using my e-mail address and my Serial Number, I received error messages complaining about the absence of Net 4.5.

The Crossover installation window showed it downloaded both Net 4.0 and 4.6.2, and installed the Net 4.0 Framework. Whether it installed 4.6.2, I don't know. I looked at the Log file and extracted the relevant lines to a new text file. They are meaningless to me. If it did not install also 4.6.2, perhaps this is why Paddle complains about Net 4.5. (Though I know that Net Framework 4.0 was installed by Crossover, I don't know enough about Net to determine which 4.0 files that were installed, as indicated by the log file, constitute the 4.6.2 upgrade.)

One of the technicians at Code Weavers suggested I try to intall it in a Win 10 Bottle. I suppose that if would install all of 4.0, and maybe even 4.7 or 4.8, would solve the problem, since it would seem that a version of Net later than 4.6 would install all of the earlier components. However, a person responding to one of my posts indicated this was unlikely; I don't know. (I successively used both a Win 7 Bottle and a Win 7 64-Bit Bottle for Scrivener installation, w/ neither having any different effect.)

Apparently there has been a persistent problem w/ Paddle. The <paddle.exe> version is dated 09/12/19, and the Configuration file is dated 07/25/19. I wonder if these the latest of each?

I also note the following line from the configuration file:
<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5" />
Since it is complaining about not seeing Net 4.5, could this be the problem?

Would editing the line in the Paddle Configuration file be an option to resolve the problem?

Finally, I wonder if it is possible to use the Wine Configuration or Tools utility in Crossover to install
<NDP462-KB3151800-x86-x64-AllOS-ENU> in the Scrivener Bottle? (This of course is the EXE file for installing the complete Net 4.0 Framework up to and including 4.6.2.)

If only the Net 4.0 Framework, but not the upgrade to 4.5 or 4.6.2, installed perhaps this would solve the problem. (Perhaps then the Paddle utility w/ Scrivener (the registration process) will be able to find 4.5.)

Any thoughts on any of the above?

You must install a minimum of .Net 4.6.2. You should be able to install that in your existing bottle. You can do that after you've installed Scrivener or during the installation of Scrivener. It's available under Advanced Options in the last screen before the install actually starts. The latest supported version 1.9.16 will register with Paddle; you don't need to change anything in any config files to do it.

I also run the Scrivener Beta -- for which there's no shim yet. I add .Net 4.7.2 during the install by adding it to the package.

Thank you very much for your suggestion. I was wholly unaware of the Advanced Options significance.

Unfortunately the effort - actually consisting of five (5) different methods - still failed. I tried:

  • both Net 4.6.2 and Net 4.7.2,
  • selecting both "Reboot Now" and "Reboot Later" after the Net installations, +
  • selecting, as well as a Windows 7 Bottle, a Windows 7 64-Bit Bottle (despite CrossOver complaining about the latter).

Each time CrossOver said "An error occurred while installing Microsoft .NET Framework 4.6.2" (or 4.7.2 when I selected it instead), and gave the reason that a certain file in ~/.cxoffice/installers/ - a name too long to type here but set forth in a PNG file which I unfortunately can't attach - "could not be scanned."

I thought perhaps that there were some dependencies that were required but absent, but this seems like a different problem.

I went ahead and completed the Scrivener installation even though I was forced to skip the step of installing 4.6.2. However, you say that I "should be able to install that in [my] existing bottle .... after [I]'ve installed Scrivener ...". What menu option do I use to do install Net 4.6.2 after installation?


This is in supplementation of my preceding message.

I was going to try to upload the PNG file to one of my Websites so that I then had a URL for it. However, since I would have to boot to a different platform, I decided to go to the ~/installers directory. I looked through it and decided I could copy and then modify the name of the existing file for this message.

While the error message said that
could not be scanned,
the only file there that had a similar name was

The absence of the file seems like a good reason it couldn't be scanned ... Any ideas?

In further supplementation.

After the earlier message I did a search for the full first name, located and downloaded

Now what would happen if I added the preceding letters and numbers to this file name, moved it to the ~/installers directory, and then tried to

  1. install 4.6.2 to the existing installation, or
  2. uninstall and delete the current bottle, and start afresh?

To install additional software into the bottle, go through the Install Windows Software process manually. I have a bottle called Scrivener_1.9.16. So, I go to the Install WIndows Software pane. Browse Available Applications. I choose .Net 4.6.2 or 4.7.2. Proceed to the point it asks me what bottle you want to use. I then select my Scrivener_1.9.16 bottle, and then continue with the install.

Alternatively, I can right-click on the Scrivener_1.9.16 bottle in the main pane and select Install Software into Bottle. The process is the same, but the bottle is preselected.

If I were rebuilding a Scrivener 1.9.16 install, I would use the pre-built shim for Scrivener and add .Net 4.6.2 during the install process, while letting the shim build the rest of it, i.e. letting it choose which type of bottle to create and the other SW it might add. I've not had a problem since the release of 1.9.16 with activating my license with Paddle.

That said, I mostly use the Scrivener Beta (now at aka RC5). I install it as an Unlisted Application in Win10 bottle with .Net 4.7.2 added with Advanced Options. It works seamlessly. The activation feature isn't used at this point since it's a beta product.

My system is:
Linux Mint 19.3 Cinnamon 4.4.8, kernel: 5.3.0-46 x64
HP ENVY x360 Convertible 15m-dr1012dx
Intel Core i7-10510U @ 1.80 Ghz (Quadcore) 12 GB RAM
Intel NVME 500GB
CrossOver Version 19.0.1
Scrivener Version: & Version: Beta 64-bit
Your mileage may vary.

I thank your for all the time you have expended in trying to assist me. Unfortunately, for some unknown reason, the registration problem persists.

I used your suggested method, after installing Scrivener, to install to its bottle not only 4.6.2 but 4.5.1 and 4.7.2 - for good measure, to "cover the waterfront". The result is the same

I thus, to avoid further expenditure of vain effort, have decided to simply await what I am advised is a new version of Scrivener later this year that will avoid the Paddle problem. I still have it working fine under Windows 7 and thus will use it while I am waiting.

The information on my system, for what it might reveal is:

Computer : ThinkPad T540p
Processor : 2x Intel(R) Core(TM) i5-4300M CPU @ 2.60GHz
Memory : 7843MB (1461MB used)
OS Version : LMDE 3 Cindy
Kernel : Linux 4.9.0-12-amd64 (x86_64)
Scrivener : 1.9.16
Crossover : 19.0.1

Again, thanks much.

I'm super late to this, and I'm sorry if it goes against any forum rules.

I had this problem on the Chrome OS version. What you (or any other person looking for this answer) needs to do is this:

Install Scrivener
Click on Scrivener Icon
Click on "Manage Scrivener"
Click on the cog on the next screen
Install Internet Explorer 8 from there
Say yes to any popups
Launch Scrivener proper
Enter the serial code and your user name
You are good to write now!

It's not intuitive, but IE needs to be installed within Scrivener, not outside of it.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...