CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Slovak accounting software POHODA


I'm trying to install this accounting software but unfortunately without any success.
Tried different bottle setups (Windows versions) but it did not help. The installer simply hangs after
a few seconds (after installing some 3rd party components like VCRedist or MS ACCESS DATABASE ENGINE required by the software).
Please check the screenshot here:

If I may, I link the installer here:
It is possible to download without registration if you click the "STIAHNUT HNED" on the left side.

Any help would be greatly appreciated, this is the only thing that keeps me on Windows. :)

Thanks for the replies!

P.S.: I'm using CrossOver Linux 19.0.1 and Manjaro 20



Try to install these components yourself:visual c++ 2008,2010 and 2015, they are the most used; then install microsoft jet component (install the latest version) and mdac latest version. Let's see if something changes or not. Hope it helps.

Hi Simone!

Thank you! :) Unfortunately, it did not help... tried to install all those components but the installer - or more precisely, the WinZIP self-extractor - hangs like before.


I suggest you to post the cxlog file it should help debugging. Open crossover right click on the icon of your program and select run with option, a pop up will appear flag the option create a cxlog file and then run the application. Then post here the content of the txt file you created. If in the log file there are errors complaining about wine unhandled exception there's not much we can do it means that wine can't handle one or more functions that the software requires, else maybe we can sort something out. Cold you post a direct link to allow me to download the program, maybe I can fix it in my spare time.


Sorry for the delay, here is the link for the log:
and for the application itself:

Thanks for your help and support!


I played a little with the software you sent me. I managed to find a workaround to the setup process issue. Apparently the real setup file is a msi file inside the main exe. Wine can't handle this msi so the extraction process stops for a reason unknown. Installing msitools and giving the command msiextract with the name of the msi file (extracted from the main exe) inside a linux terminal, allowed me to mimic the setup process and I had access to the exe files and dll needed for the software to work. But once I tried to start the program (there is a Pohoda exe file inside the program files folder extracted from the msi) a winedvm error occurred, wine says that this is a Dos program and I need to run it inside dosbox. As far as I understand this program is a 16 bit one. I Installed dosbox and dosshell to facilitate the process of running this software into an msdos enviroment, but I had no success the program crashes at start in dosbox the log complains about a msvcrt error that I can't fix... I tried to use winedvm (it's a tool that allows to use 16 bit softwares inside wine without using dosbox) but even with this approach the loader crash at start complaining about an unhandled exception, and I bet it's a thing related to visual c++,I had the same issue with skype for business an error related to visual c++ and the getenviroment variables function etc. Long story short The program files can be accessed bypassing the setup but I couldn't get the app to work... I'm running out of ideas... A caveat, if this program's purpouse is to interact with hardware it may not work at all in wine (at least for now they are working on it) just devices that use com ports or usb over serial protocols could work in wine not usb devices.

Hi Simone! I'm really grateful to have you! The situation is indeed very interesting or strange, because it is supposed to be a 32bit software and does not feature any hardlock,
activates by license key. I'll try to extract/install with your method, too. Thank you very much!


I found the source of the problem, the issue is related to some access runtime 2007 components that do not work correclty under wine this prevents the setup process to finish. I manually installed , access runtime 2007 and access database engine and the setup progressed a bit but failed installing some other access 2007 component... You could try to install pohoda in the same bottle where office 2007 is installed (I suggest you to install office 2007 via cross tie) and see if something happens. Install these other components too visual c++ 2017 mdac 2.8 , microsoft jet 4 richedit 4 msxml 6 sp1 and visual basic runtime 6.

Hi Simone!

Sorry for the delay! I've tried to install Office 2007 and other components you mentioned but unfortunately, Pohoda still failed to install. There is some progress though. I cheated - copied the installed Pohoda from Win10 to the CX bottle and tried to run it. With the initial splash screen it showed an error - missing Office Access Runtime and Data Connectivity Components 2007 SP3. I installed the vanilla Office 2007 without SP3. It is possible to download "accessRDC2007sp3-kb2526310-fullfile-en-us.exe" from their site (Pohoda) but when I run it shows something like "There is no installed component to update" so I reinstalled the Office 2007 but now with SP3 bundle. After this procedure the Pohoda still failed to install but the copied - already installed on Win10 version runs well. There is just one section (but unfortunately a crucial one) where it crashes - the "stock" section.
I'm using x86 Win7 bottle.

Here is the crash log:

... and two screenshots (the second shows the "stock" option - before clicking on it):

Thanks for helping me! I've never been so close to get this software running on Linux. :)


HI Ladislav,

The error related to Entry point mfc140 could be related to visual c++ 2015, is it installed in your bottle? Let me know if that helped.

Best regards

1 to 10 of 10

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...