CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Ubuntu 20.04 - Multiarch Support not possible, so Crossover 18 fails to install

Apparently Ubuntu has dropped 32bit support https://pcper.com/2019/06/ubuntu-19-10-20-04-lts-support-selected-32-bit/

When I try to install I get a pre-dependency error.

sudo gdebi crossover_18.1.0-1.deb 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done
This package is uninstallable
[b]Dependency is not satisfiable: multiarch-support[/b]

sudo dpkg --add-architecture i386
has no effect.

I can't see anything in the FAQ or install guides. How do I proceed?

Try this guide it's for 18.04 but it works for 20.04. https://linuxhint.com/run_32_bit_windows_64_bit_unbuntu/

We have made changes to CrossOver 19.x so that it works better with the recent versions of Ubuntu. Are you using CrossOver 18.1 because of a regression?

I would suggest trying the .bin installer for 18.1 - it is possible that will work where the .deb failed.

Thanks,
Anna

Latest Crossover (19.0.2) on Ubuntu 19.10 / 20.04 refuses to install:

Selecting previously unselected package crossover:i386.
(Se citește baza de date ... 363711 fișiere și directoare actualmente instalate.)
Preparing to unpack crossover.deb ...
Unpacking crossover:i386 (19.0.2-1) ...
dpkg: dependency problems prevent configuration of crossover:i386:
 crossover:i386 depinde de libx11-6 | xlibs.
 crossover:i386 depinde de libxext6 | xlibs.
 crossover:i386 depinde de libxi6.
 crossover:i386 depinde de libfreetype6.
 crossover:i386 depinde de libpng12-0 | libpng16-16.
 crossover:i386 depinde de libz1.
 crossover:i386 depinde de libnss-mdns | lib32nss-mdns:amd64; dar:
  Pachetul lib32nss-mdns nu este instalat.
 crossover:i386 depinde de libcups2; dar:
 crossover:i386 depinde de liblcms2-2; dar:
 crossover:i386 depinde de libglu1-mesa; dar:
 crossover:i386 depinde de libxcursor1; dar:
 crossover:i386 depinde de libxrandr2; dar:

dpkg: error processing package crossover:i386 (--install):
 probleme de dependențe - se lasă neconfigurat
Erori întâlnite în timpul prelucrării:
 crossover:i386

If i do "sudo apt install -f" like un previous versions, dpkg wants to completely remove crossover.
Also, trying to install "libnss-mdns" (64bit or 32bit leads to even more errors).

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzIwODgyNTk1LCJjc3JmX3Rva2VuIjoiSFByUVV1UllOYks2ZUwzUCIsImdkcHIiOjB9