CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Application works on CrossOver using VM but not on real hardware

Hi everyone,

I have an application here with a curious behavior.
Using the trial version, we setup a virtual machine (VMware Player) with Fedora 32 and Ubuntu 20.04.
Then we installed the application successfully: Simufact Welding.
It works great, responsiveness is awesome and we thought of moving forward and doing a bigger deploy.
The next phase was to get the same machine (Lenovo W510) that was running the VM and swap the operating system.
It did not work, the application crashes during launch. No interface is brought up, nothing.
Installed Fedora 32, Ubuntu 20.04, Ubuntu 18, Linux Mint 19, openSuSUE Tumbleweed, etc.
Thought that was the nvidia driver, the nouveau driver, X11, Wayland. No combination worked.
Tried it in a more recent hardware (Lenovo P50), no luck again.
The VM however works every time in all hardware we tested: no need to add i386 arch, no need to cxfix --auto, it just works.

Has anyone experienced this before? Any clues?

Appreciate your time and response!

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...