CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Install Crossover 14.0.3-1 on Fedora 21 (Intel GPU)
Striker Leggette
Striker Leggette
Posted 2015-03-09 16:49
Below are the steps I took:

1.  Install Crossover:

 # sudo yum localinstall http://media.codeweavers.com/pub/crossover/cxlinux/demo/crossover-14.0.3-1.rpm

2.  Install all needed dependencies:

 # sudo yum install fontconfig.i686 fontconfig.x86_64 lcms2.x86_64 libXcomposite.i686 libXcomposite.x86_64 libXinerama.i686 libXinerama.x86_64 libgphoto2.i686 libgphoto2.x86_64 libxml2.i686 libxml2.x86_64 libxslt.i686 libxslt.x86_64 openal-soft.i686 openal-soft.x86_64 openldap.i686 openldap.x86_64 sane-backends-libs.i686 sane-backends-libs.x86_64 mesa-dri-drivers.i686 libtxc_dxtn.i686 isdn4k-utils-devel.i686 gsm-devel.i686 gstreamer-plugins-base-devel.i686 lcms2.i686 mesa-libOSMesa-devel.i686 libtiff-devel.i686 gnutls-devel.i686

3.  Further needed actions:

 # sudo ln -s /usr/lib/libOSMesa.so /usr/lib/libOSMesa.so.6
 # sudo ln -s /usr/lib/libtiff.so.5.2.0 /usr/lib/libtiff.so.4

Current install issues:

#############
[MissingLibMpg123]
"Level"="Suggest"
"Title"="Missing 32bit libmpg123.so.0 library"
"Description"="Needed by some Windows applications to play MP3 files."
#############

$ sudo yum install libmpg123-devel.i686
Loaded plugins: langpacks
Resolving Dependencies
--> Running transaction check
---> Package libmpg123-devel.i686 0:1.19.0-2.fc21 will be installed
--> Processing Dependency: libmpg123(x86-32) = 1.19.0-2.fc21 for package: libmpg123-devel-1.19.0-2.fc21.i686
--> Processing Dependency: libmpg123.so.0 for package: libmpg123-devel-1.19.0-2.fc21.i686
--> Finished Dependency Resolution
Error: Package: libmpg123-devel-1.19.0-2.fc21.i686 (rpmfusion-free)
          Requires: libmpg123(x86-32) = 1.19.0-2.fc21
Error: Package: libmpg123-devel-1.19.0-2.fc21.i686 (rpmfusion-free)
          Requires: libmpg123.so.0
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

#############
[MissingLibHal]
"Level"="Suggest"
"Title"="Missing 32bit libhal.so.1 library"
#############

$ sudo yum provides /usr/lib/libhal.so
Loaded plugins: langpacks
No matches found
Striker Leggette
Striker Leggette
Posted 2015-03-09 17:18
###  /usr/lib/libhal.so.1  ###

In recent versions of Fedora, this library is provided by hal-devel.i686, which can be found most recently in this location.  It has since been outdated by udisks, upower and libudev.  More information can be found at this link.
Striker Leggette
Striker Leggette
Posted 2015-03-09 17:19
###  /usr/lib/libmpg123.so.0  ###

Possibly need libmpg123-devel.i686
The above package depends upon libmpg123.i686 which does not currently exist in RPMFusion repos.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTM4NzY3MzM4fQ==