CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Avogadro version 1.2.0n
Mohd Farid  Ismail
Mohd Farid Ismail
Posted 2017-06-15 21:55
Hi, has anyone got the program Avogadro to work on Linux?  I know there's a Linux version of the program, but there's so many problem compiling the Linux version, I was hoping crossover can run the Windows version.  I tried to install the program, and the installation works OK.  But opening the program results in program error.

EDIT: Ooops, sorry wrong forum.  Can an admin please move the post to the appropriate forum.
Roger Barnes
Roger Barnes
Posted 2017-06-16 02:25
What are your OS details please?
Mohd Farid  Ismail
Mohd Farid Ismail
Posted 2017-06-16 03:25
CentOS 6.5 (kernel 2.6.32-431.11.2.el6.x86_64, gnome 2.28.2, gcc 4.4.7)
I'm using crossover ver 16.2.0

Frede Hundewadt
Frede Hundewadt Dragon Turbo Chief Senior Advocate
Posted 2017-06-16 04:33
Mohd Farid  Ismail Posted:
Hi, has anyone got the program Avogadro to work on Linux?  I know there's a Linux version of the program, but there's so many problem compiling the Linux version, I was hoping crossover can run the Windows version.  I tried to install the program, and the installation works OK.  But opening the program results in program error.


No problem on Manjaro Linux (Arch Linux derivative).
Roger Barnes
Roger Barnes
Posted 2017-06-16 07:21
There is a package for version 1.2.0-1 in the Debian repos. This version number may be unique to the Debian package, I didn't check that.

I don't know if it will meet your requirements, but you may have success converting it to RPM with Alien (see link below, it should be in Red Hat repos though). I realise that it doesn't address the Crossover issue but it may be at least a temporary solution while you are getting a more current version to work (if one exists).

I tried compiling the source on Debian stable and it was well outside my limited scope, with listed dependancies met to the best of my ability. Not saying I did it correctly either.

I list the links below in case they are of any use to you, but please do some research before you try anything.
https://packages.debian.org/stretch/avogadro
https://joeyh.name/code/alien/
Mike
Mike Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 3
Posted 2017-06-16 22:43
Version 1.2.0-1 .debs for Ubuntu are here  https://pkgs.org/download/avogadro
Mohd Farid  Ismail
Mohd Farid Ismail
Posted 2017-07-03 01:03
Thank you for all the replies. I tried all the suggestions, with a few others I could think off, but unfortunately it won't install on CentOS 6.5, with all the typical dependencies problem.
Frede Hundewadt
Frede Hundewadt Dragon Turbo Chief Senior Advocate
Posted 2017-07-03 04:22
I you really need that app I can suggest this:

Install VirtualBox on your centos box
Download a Manjaro release from manjaro.org (pick the xfce edition)
Install Manjaro in VirtualBox
Start the VM with Manjaro
Inside launch the Add/Remove Software App
Goto Settings in the Software App
Select the Tab marked AUR
Enable installation from AUR
Close the Settings window
Type in avogadro and select the version you want to install
When the task is finished you can launch Avogadro within the VM
Andrew Schott
Andrew Schott Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2017-07-03 12:05
Mohd Farid  Ismail Posted:
Thank you for all the replies. I tried all the suggestions, with a few others I could think off, but unfortunately it won't install on CentOS 6.5, with all the typical dependencies problem.


Ill see if I can get a package for EL6/7 made up.  This week is going to be a bit hectic, but I will post what I can get done when I have the time.

** EDIT **
Rebuilding the Fedora SRPM did not work.  Looks like I will have to spend the time to edit the SPEC.  Doesn't look terrible, but I thought that about Mumble, and ... well I am using Nux's packages for that :D
Mohd Farid  Ismail
Mohd Farid Ismail
Posted 2017-07-04 23:36
Thank you for your suggestions.  I have used this method (using Win 7), but lately VBox is acting weird, thus I'm looking for alternatives.  Besides, having VBox taking resources is something I want to avoid.  I actually purchased COLinux to have MS Office 2010.  It's OK if avogadro wouldn't run with COLinux, but it's a bonus if it would.  

Frede Hundewadt Posted:
I you really need that app I can suggest this:

Install VirtualBox on your centos box
Download a Manjaro release from manjaro.org (pick the xfce edition)
Install Manjaro in VirtualBox
Start the VM with Manjaro
Inside launch the Add/Remove Software App
Goto Settings in the Software App
Select the Tab marked AUR
Enable installation from AUR
Close the Settings window
Type in avogadro and select the version you want to install
When the task is finished you can launch Avogadro within the VM

Mohd Farid  Ismail
Mohd Farid Ismail
Posted 2017-07-04 23:39
Thank you thank you thank you.

Andrew Schott Posted:
Mohd Farid  Ismail Posted:
Thank you for all the replies. I tried all the suggestions, with a few others I could think off, but unfortunately it won't install on CentOS 6.5, with all the typical dependencies problem.


Ill see if I can get a package for EL6/7 made up.  This week is going to be a bit hectic, but I will post what I can get done when I have the time.

** EDIT **
Rebuilding the Fedora SRPM did not work.  Looks like I will have to spend the time to edit the SPEC.  Doesn't look terrible, but I thought that about Mumble, and ... well I am using Nux's packages for that :D

Andrew Schott
Andrew Schott Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2017-07-12 19:18
Mohd Farid  Ismail Posted:
Thank you thank you thank you.

Andrew Schott Posted:
Mohd Farid  Ismail Posted:
Thank you for all the replies. I tried all the suggestions, with a few others I could think off, but unfortunately it won't install on CentOS 6.5, with all the typical dependencies problem.


Ill see if I can get a package for EL6/7 made up.  This week is going to be a bit hectic, but I will post what I can get done when I have the time.

** EDIT **
Rebuilding the Fedora SRPM did not work.  Looks like I will have to spend the time to edit the SPEC.  Doesn't look terrible, but I thought that about Mumble, and ... well I am using Nux's packages for that :D



Haven't forgot, just having a less than pleasant time with some of these missing dependencies.  I see why you were having alot of issues compiling.  A bit surprised that the deps are this insane.  I run RHEL7 on most of my machines (do have a few RHEL6 installs on 32bit hardware), and have yet to have this big a nightmare dealing with packing/compiling/running anything.
Mohd Farid  Ismail
Mohd Farid Ismail
Posted 2017-07-13 23:27
Ah well.  I understand if you stop trying.  I believe from looking at mailing lists, many others also tried to compile on RHEL-based systems but eventually gave up.  I think the developers use Debian-based distros and thus the crazy looking deps from rpm-based distros side.  Thank you for trying though.  

Andrew Schott Posted:
Mohd Farid  Ismail Posted:
Thank you thank you thank you.

Andrew Schott Posted:
Mohd Farid  Ismail Posted:
Thank you for all the replies. I tried all the suggestions, with a few others I could think off, but unfortunately it won't install on CentOS 6.5, with all the typical dependencies problem.


Ill see if I can get a package for EL6/7 made up.  This week is going to be a bit hectic, but I will post what I can get done when I have the time.

** EDIT **
Rebuilding the Fedora SRPM did not work.  Looks like I will have to spend the time to edit the SPEC.  Doesn't look terrible, but I thought that about Mumble, and ... well I am using Nux's packages for that :D



Haven't forgot, just having a less than pleasant time with some of these missing dependencies.  I see why you were having alot of issues compiling.  A bit surprised that the deps are this insane.  I run RHEL7 on most of my machines (do have a few RHEL6 installs on 32bit hardware), and have yet to have this big a nightmare dealing with packing/compiling/running anything.

Andrew Schott
Andrew Schott Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2017-08-01 16:53
OK, putting a pause on the inane amount of packages needed.  Instead I am taking this as a learning opportunity for flatpak.  This will work on EL7 if I can make this work out ok.  Was going to go AppImage, but that looks like it would need native libs anyhow at build, which is the crux of the problem here.  I am hoping that I can figure out flatpak well enough that this works out.  I see there are qt5 runtimes now.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTg2NDQyNzI0fQ==