CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Fedora 23 GA - Beta Installation instructions
Striker Leggette
Striker Leggette
Posted 2015-11-06 11:13
!BETA! - This article outlines installation instructions for Fedora 23's GA release using RPMFusion packages still listed in Development and to outline issues that arise from the testing of this process.  At the time of this writing, RPMFusion has not yet released a [Final] Fedora 23 repository.  These instructions are meant to be informative only.

[1] Run system updates and reboot if needed:
sudo dnf update
sudo reboot


[2] Install the RPMFusion repository for Fedora 23 (RPMFusion F23 in development at the time of this writing):
sudo dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-23.noarch.rpm


[3] Install CrossOver (version 14.1.11-1 at the time of this writing):
sudo dnf install http://crossover.codeweavers.com/redirect/crossover.rpm


[4] [Optional] Install packages CrossOver may complain about:
sudo dnf install dbus-python pygtk2 libv4l.i686 fontconfig.i686 libXcomposite.i686 libXinerama.i686 libgphoto2.i686 libxml2.i686 libxslt.i686 openal-soft.i686 openldap.i686 sane-backends-libs.i686 mesa-dri-drivers.i686 libtxc_dxtn.i686 isdn4k-utils.i686 gsm.i686 gstreamer-plugins-base.i686 lcms2.i686 mesa-libOSMesa.i686 libtiff.i686 gnutls.i686 libmpg123.i686 nss-mdns.i686


[5] Symlink the two libraries CrossOver cannot find:
sudo ln -s /usr/lib/libOSMesa.so /usr/lib/libOSMesa.so.6 
sudo ln -s /usr/lib/libtiff.so.5.2.0 /usr/lib/libtiff.so.4


[6] Launch CrossOver.
Striker Leggette
Striker Leggette
Posted 2015-11-06 16:47
Remember to check for sound compatibility afterwards:
https://www.codeweavers.com/support/wiki/Diag/MissingLibAsound
Striker Leggette
Striker Leggette
Posted 2015-11-13 12:21
-Redacted-
Matthew Gilbert
Matthew Gilbert
Posted 2015-12-14 12:55
I'm having trouble on Fedora 23, even after following these directions. Even though I have pygtk2 and dbus-python installed:

Package dbus-python-1.2.0-12.fc23.x86_64 is already installed, skipping.
Package dbus-python-1.2.0-12.fc23.i686 is already installed, skipping.
Package pygtk2-2.24.0-12.fc23.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

I'm asked to install them every time I launch crossover. Any suggestions?

Thanks!
Matthew Gilbert
Matthew Gilbert
Posted 2015-12-14 14:57
Nevermind! Sorry, for the noise, I had the Anaconda Python version in my path ahead of /usr/bin/python.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==