CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Reply to Thread Back to Threads

install failed on ubuntu 17.04 gnome
I followed the instruction on the site and this is what I get

sudo gdebi crossover.deb
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done
Requires the installation of the following packages: libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libcomerr2:i386 libcups2:i386 libdbus-1-3:i386 libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libelf1:i386 libexpat1:i386 libffi6:i386 libfreetype6:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libglu1-mesa:i386 libgmp10:i386 libgnutls30 libgnutls30:i386 libgssapi-krb5-2 libgssapi-krb5-2:i386 libhogweed4:i386 libidn11:i386 libk5crypto3 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3 libkrb5-3:i386 libkrb5support0 libkrb5support0:i386 liblcms2-2:i386 libllvm4.0:i386 libnettle6:i386 libp11-kit0:i386 libpciaccess0:i386 libpng16-16:i386 libsensors4:i386 libstdc++6:i386 libsystemd0:i386 libtasn1-6:i386 libtinfo5:i386 libtxc-dxtn-s2tc:i386 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386 libxcb1:i386 libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxrandr2:i386 libxrender1:i386 libxshmfence1:i386 libxxf86vm1:i386

Run Windows applications like MS Office
On 64-bit flavors of Debian and some Ubuntu variants, first open a terminal and
run 'sudo dpkg --add-architecture i386 ; sudo apt-get update'.
.
CrossOver Linux makes it possible to run Windows productivity applications
such as Microsoft Office, and Quicken, and also lets you play Windows games
like Skyrim and World of Warcraft.
Do you want to install the software package? [y/N]:y
Fetched 0 B in 0s (0 B/s)                                                      
Extracting templates from packages: 100%
Extracting templates from packages: 100%
dpkg: error processing package gcc-6-base:i386 (--configure):
package is in a very bad inconsistent state; you should
reinstall it before attempting configuration
dpkg: dependency problems prevent configuration of libgcc1:i386:
libgcc1:i386 depends on gcc-6-base (= 6.3.0-12ubuntu2); however:
 Package gcc-6-base:i386 is not configured yet.

dpkg: error processing package libgcc1:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6:i386:
libc6:i386 depends on libgcc1; however:
 Package libgcc1:i386 is not configured yet.

No apport report written because the error message indicates its a followup error from a previous failure.
                         No apport report written because the error message indicates its a followup error from a previous failure.
                                                   dpkg: error processing package libc6:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgpg-error0:i386:
libgpg-error0:i386 depends on libc6 (>= 2.15); however:
 Package libc6:i386 is not configured yet.

dpkg: error processing package libgpg-error0:i386 (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                             dpkg: dependency problems prevent configuration of libgcrypt20:i386:
libgcrypt20:i386 depends on libc6 (>= 2.15); however:
 Package libc6:i386 is not configured yet.
libgcrypt20:i386 depends on libgpg-error0 (>= 1.14); however:
 Package libgpg-error0:i386 is not configured yet.

dpkg: error processing package libgcrypt20:i386 (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                             dpkg: dependency problems prevent configuration of liblz4-1:i386:
liblz4-1:i386 depends on libc6 (>= 2.4); however:
 Package libc6:i386 is not configured yet.

dpkg: error processing package liblz4-1:i386 (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                             dpkg: dependency problems prevent configuration of liblzma5:i386:
liblzma5:i386 depends on libc6 (>= 2.17); however:
 Package libc6:i386 is not configured yet.

dpkg: error processing package liblzma5:i386 (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                             dpkg: dependency problems prevent configuration of libpcre3:i386:
libpcre3:i386 depends on libc6 (>= 2.4); however:
 Package libc6:i386 is not configured yet.

dpkg: error processing package libpcre3:i386 (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                             dpkg: dependency problems prevent configuration of libselinux1:i386:
libselinux1:i386 depends on libc6 (>= 2.8); however:
 Package libc6:i386 is not configured yet.
libselinux1:i386 depends on libpcre3; however:
 Package libpcre3:i386 is not configured yet.

dpkg: error processing package libselinux1:i386 (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                             Errors were encountered while processing:
gcc-6-base:i386
libgcc1:i386
libc6:i386
libgpg-error0:i386
libgcrypt20:i386
liblz4-1:i386
liblzma5:i386
libpcre3:i386
libselinux1:i386
E:Sub-process /usr/bin/dpkg returned an error code (1)
Error during install: 'installArchives() failed
I got it to install after reinstalling gcc-6-base, now every windows program hangs on installing, and with pdf xchange viewer it gives me a warning due to not finding com.codeweavers.c4.cxhtml
After reading a few posts, I have decided there seems to be a lot of issues with ubuntu 17.04, I've download unbuntu gnome 16.04 lts and have no issues.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjAzMTM4NzM0LCJjc3JmX3Rva2VuIjoiemd3ZGVxVUJuRVVxU3FNQyIsImdkcHIiOjB9