CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Office 2010 doesn't run after upgrade to crossover 18

After upgrading to crossover 18 Office 2010 complains about licences.

After upgrading to crossover 18, when I try to run Excel, for example, it fist states it needs to configure files, etc, then finishes saying that it cannot verify the necessary licence.

If I revert the installation to crossover 17.5.0 everything gets back to normal.

Additional data:
Linux Fedora 27, Kernel 4.16.18


I also see this issue.

Running with crossover 17.5.1, MS Office 2010 apps (excel, powerpoint, word, and outlook) work fine. With crossover 18.0.0, they crash before getting fully started up.

Some of the apps attempt to perform an initial install, but they still don't run.

Hi Geoffrey,

What happens when the apps "attempt to perform an initial install"? Does it ask you for a product key or say that Office is "configuring" things?


I have the same issue and actually just submitted an expert support ticket. Each time when starting an office application it tries to reconfigure things and then asks to revalidate the office copy. This works for me and it does eventually start the application (though with a more than 1-minute startup delay). Most of the times, closing the application will result in a wineserver crash. The next time starting any office application it just goes through the same reconfiguration process. Reverting to 17.5.1 and reinstalling the bottle from an archive was the only workaround for me.

Exactly the same problem for me. Other applications (e.g. Enterprise Architect) still work without a problem.

Please, report back here if you find a solution!


Same issue here ....
Tried installing in a Win7 bottle, but the install would not finish.

Now trying the sugested 17.5 solution.

Same problem here. Still waiting for a solution.


Office asks for a product key during the "initial install" step.
This occurs with all of the Crossover 18.* releases, including 18.5.0.

Be well,

Hi Geoffrey,

What you are describing sounds like correct Office behavior. When you install Office 2010, it will ask for a product key during the initial installation process. The incorrect behavior was asking to reactivate an existing bottle - we hope that some changes we made in 18.5 have fixed this problem for customers with bottles created on CrossOver 17.x and earlier, but we have gotten a wide array of different descriptions of what customers are seeing, so unfortunately cannot guarantee that the fixes will work for every customer.

This issue has caused our team a great deal of frustration, in part because we are seeing the correct behavior now internally - if any customer is seeing an issue with this on 18.5, I would encourage you to send in a support ticket so that we can gather more information.


I think I have the same problem, but it seems to work alright on crossover 18.1.0
In 18.1.0 it does tries to validate the registration with a pop-up on whether you want to do this by phone or internet., which seems to work most of the time if you pick internet

in 18.5.0 it just crashes.

This issue has been forwarded to the Official CodeWeavers Ticket System. If you have observed this issue and would like to report it as well, please open a support ticket or send an email to with a description of what you are seeing and a link to this post.

Thank you!
The CodeWeavers Team


To be clear, this is with an existing bottle, with Office 2010 already installed.

Running an app should just bring up the app (this works with Crossover 17.5.1), but with 18.* it tries doing an "initial install". It shouldn't need to do an initial install-- the app is already installed.

Best wishes to the dev team in tracking this down!

Be well,

I have a bottle with an activated Office 2010, too, which ran a long time without any issues from 17.5.0 onwards. I got the activation screen with 18.5.0. Downgrading to 18.1.0 helped; no more activation screen.

I see same problem with Office 2016. With cx-18.1, I was working well, never questions about activation. Upgrading to cx-18.5, causes a request for activation. When I try that, with my username that the university provides, I get a "white screen of death" symptom, where the activation process stops dead.

Downgrading to cx-18.1 seems to help, however it does some "magic" on the MS Office bottle and Word says "Product Activated: Restart any open office applications to apply the changes". After that, however, closing Winword and restarting seems to work OK.

Strange... just for tests I upgraded from 18.1 to 18.5 once again, and after killing the wineserver still running from 18.1 everything works now with 18.5 without asking for activation again.
So, I'm running my Office 2010 with 18.5 now without any problems! :)

1 to 14 of 14

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...