CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

iBus and office 2007, anyone got this to work?
trizt
trizt
Posted 2015-01-11 07:40
I have been trying to get Chinese input trough iBus to work with office 2007.
I can use iBus input both in gtk and qt applications without any issues, but when using CX the iBus input will not be activated.

Anyone here who has succeeded with this and want to share how they did it?

Thanks in advance for your reply.
John Niendorf
John Niendorf
Posted 2015-01-11 08:00
I had exactly the same problem with Japanese input.  I set the language of the bottle to Japanese and after that have been able to type in Japanese in Word.
rik-shaw
rik-shaw
Posted 2015-02-11 09:58
John, thanks for the comment on setting the bottle language to Japanese.  I do not see where to make this setting change, however.

In my situation, ibus is used with minority language keyboards.  I would hope I could just set en_US.utf-8 as the language.

Regards,

Rik
John Niendorf
John Niendorf
Posted 2015-02-11 10:16
You can change the locale by following the instructions here http://www.codeweavers.com/support/wiki/mac/faq/cxoffice62_choosedifferentlanguage

I don't know why this is in their Mac FAQ.  I am running Linux and this worked for me.
rik-shaw
rik-shaw
Posted 2015-02-16 06:04
John, thanks for the quick reply but alas no luck.  When using ibus-kmfl (or ibus-m17n keyboards), nothing appears when attempting to type.  In one keyboard instance (kmfl-keyboard-sil-ethiopic), if I have existing characters in a Word doc, when I type after I hit 3 keys one of the existing characters disappears!  I can keep "going backward like this" (deleting existing characters) for every 3 keyboard hits.

So, it seems that there is some communication going on between keyboard and Word doc, but that in most cases the keystrokes are getting "swallowed", and in the case of the Ethiopic keyboard, it is more than swallowed it is also eating pre-existing characters!
John Niendorf
John Niendorf
Posted 2015-02-16 06:17
hmmmmm I don't suppose there is a Microsoft IME that could be installed in the bottle is there?
(That is just a thought.)

Another solution could be what I did to get EndNote working.

Crossover does not support the reference manager EndNote.  Well, you can run EndNote, but there is no way for the reference manager to communicate with Word so the most important feature of EndNote doesn't work.  This was such an issue for me, I am in the middle of writing my thesis now, that I set up a virtual machine with Windows 7.

I was able to find an OEM version of Windows 7 at Amazon.  You can probably pick one up in many places, but I trust Amazon to not sell pirated software.  The list price was around $100.00 USD, but with my Amazon points I got the OS for $45.00 USD.

Is setting up a virtual machine overkill?  Well, ideally things wouldn't come to that.  In my case I REALLY wanted to use EndNote - the full version, not just EndNote online.  So, for me it was worth it.  I guess it depends on how important it is to you to write in that language in Word.
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2015-02-16 06:28
John Niendorf Posted:
hmmmmm I don't suppose there is a Microsoft IME that could be installed in the bottle is there?
(That is just a thought.)


Probably not:

Bug 8093 - running windows IME modules under wine
rik-shaw
rik-shaw
Posted 2015-09-23 07:45
I was able to get ibus keyboard input to work in Office 2007 by changing the winver to "Windows 7" (or "Vista").  But no other tricks (env XMODIFIERS='', setting language, etc.) would work.  Many of those suggestions simply turn off ibus, but then of course I can't use the advanced characters of my ibus keyboard in Office!  Anyway, after changing to Windows 7 then ibus input works GREAT in Office 2007.  However, then when you attempt to save a file an error is thrown: https://bugs.winehq.org/show_bug.cgi?id=29788

So, you can save documents (using Windows XP version) or you can key in ibus (using Windows 7 version) but right now I don't think you can do both 😢
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2015-09-30 01:31
Terribly ugly workaround suggestion: Install Word in two bottles, set one to Win7 and copypaste between them :-\ .
rik-shaw
rik-shaw
Posted 2015-10-03 09:43
I have created a bug report at winehq specifically for the ibus problem with Office 2007 when using a winver of XP: https://bugs.winehq.org/show_bug.cgi?id=39374

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==