I have a support ticket opened already on this, but putting this here in case anyone else has ideas:
Running Linux Mint 19.1 (based on ubuntu 18.04). Trying to run Crossover gives the following error:
CrossOver needs your permission to install missing packages.
This operation must be run as root:
sh -c "apt-get update; apt-get install python-dbus python-gtk2
and if you run the apt-get
python-dbus is already the newest version (1.2.6-1).
python-gtk2 is already the newest version (2.24.0-5.1ubuntu2)
the main error is this:
Could not install some Unix packages
Some errors may prevent CrossOver Linux from working correctly:
* Could not load the D-Bus Python modules.
* Could not load the GTK+ Python modules.
You may be able to fix some issues by running one of the following commands as root:
Arch Linux pacman -Syu pygtk python2-dbus
Debian 7 apt-get install python-dbus python-gtk2
Debian <= 6 apt-get install python-dbus python-gtk2
Fedora <= 13 yum install dbus-python pygtk2
Mandriva /usr/sbin/urpmi dbus-python pygtk2.0
openSUSE <= 11.2 zypper install dbus-1-python python-gtk
So following support instructions, we've run the following:
Hi Mark and David (and anyone else seeing this error),
We have been struggling to replicate this failure. I have a few questions regarding your setup to try to figure out what is happening. If there is anything unusual about your setup, please let me know in case I'm not asking the right questions.
1) Are you trying to install CrossOver on fresh installs of Mint 19.1 and Ubuntu 18.1 respectively, or are these older installations that you upgraded to the newest version?
2) What hardware are you using? Do you have a graphics card, and if so, which one?
3) Have you installed CrossOver before on the machine where you are currently seeing the failure to install?
I also have one experiment for you to try: if you have installed an older version of CrossOver on the machines where you are seeing the error, could you try installing the older version (can be found under My Downloads -> Archived Downloads) and see if you still get the error?
1) This is a fresh install of Mint 19.1 Moving over from Windows so trying to get the last few things to run that I need.
2) This is a machine built by Skytech Gaming - basically built using off the shelf parts, not a major manufacturer. ASUS Motherboard, AMD Processor, NVIDIA graphics. 16 gigs of RAM, 2TB of HD space.
3) This is my first time to try the installation.
Console output for both versions is below. TL;DR: 17.5.1 gave me the same error as 18.1
Posted 2019-02-25 12:54
· edited by Mark Crocker on 2019-02-25 12:55
Thanks for finding that, it does create a problem for people using Python virtual env or ASDF to manage python dev environments or even running python libs/apps that aren't compatible with system provided python :/
Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.
CrossOver Forums: the place to discuss running Windows applications on Mac and Linux
We're rebels. We're misfits. But mostly, we're software liberators. And we're very, very good at what we do. We have to be. Lots of developers work with open source, but only a tiny fraction of those are good enough to get software that was designed for one platform to work on another one. We invented CrossOver software - a unique approach to cross-platform compatibility that does not require dual-boot or another OS license. We launched PortJump to help app and game developers broaden their market beyond Windows® users. And we launched ExecMode to help organizations solve really ugly technical challenges.