CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Debian Update Removed Crossover ?
David Holmes
David Holmes
Posted 2014-04-05 23:42

Guys Wheezy just updated liblcms2-2 but also removed the I386 version and also removed crossover in the process.
this has happened to me before but I seen it happen this time. I locked crossover in with synaptic  but no help still got removed.
when I try to reinstall this is what i get.



pkg: dependency problems prevent configuration of crossover:                                                                      
crossover depends on liblcms2-2; however:                                                                                        
 Package liblcms2-2:i386 is not installed.                                                                                        
                                                                                                                                 

also this is 64bit multiarch aware.

Dave
David Holmes
David Holmes
Posted 2014-04-06 00:13
For those interested here how it happened.


Commit Log for Sat Apr  5 22:54:00 2014


Removed the following packages:
crossover:i386
liblcms2-2:i386

Upgraded the following packages:
liblcms2-2 (2.2+git20110628-2.2) to 2.2+git20110628-2.2+deb7u1
openssh-client (1:6.0p1-4) to 1:6.0p1-4+deb7u1
openssh-server (1:6.0p1-4) to 1:6.0p1-4+deb7u1
ssh (1:6.0p1-4) to 1:6.0p1-4+deb7u1

Dave
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-04-06 01:23
What happens when you try to apt-get install liblcms2-2:i386 ?
David Holmes
David Holmes
Posted 2014-04-06 10:51
Kind of Shy as a previous thread stated install will over write the 64bit libs with :i386.

Dave
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-04-06 11:19
Then it is a packaging bug and needs to be reported. They coexist just fine on Ubuntu 12.04 64bit.
David Holmes
David Holmes
Posted 2014-04-06 11:51
Got It Working.

But a bit of magic in between.
First Synaptic is an impressive program !

Now for what happend in between

added apt-get install package:architecture  "again"  just in case.
tryed apt-get install links:i386  which error d out missing 2 librarys.
did a apt-get   update.
ran Synaptic again fixed broken package,update,now this time it did not remove crossover but installed missing lib.

Commit Log for Sun Apr  6 11:10:10 2014


Installed the following packages:
liblcms2-2:i386 (2.2+git20110628-2.2+deb7u1)

running again  got to love Linux.

Dave

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==