CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

No sound on app loaded thru CrossOver which was working under plain WINE
Patrick Hertel
Patrick Hertel
Posted 2014-04-18 20:07
Hi,

  I'm using a trial version on Linux 12.04 LTS
The app plays guitar lessons which come in "DVD" versions and in "CD" versions.
Everything works in the DVD version a player comes up and there is sound.
The CD version brings up a player app which does nothing. The app itself when it first loads also is supposed to play a few notes but doesn't.

THE THING IS ... that I had the app working under WINE (although it was missing some icons and buttons) and the sound WORKED. I tried copying all libs etc to the CrossOver folders from WINE but no luck.
Any suggestions?

I ran the app under debug and  found :

"fixme:quartz:DSoundRender_QueryInterface No interface for {37d84f60-42cb-11ce-8135-00aa004bb851}!"

I also got some messages like :
"(wine:3443): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /usr/lib/gstreamer-0.10/libgstffmpeg.so: wrong ELF class: ELFCLASS64"
Which might mean I'm looking at a 32 bit library problem

BUT why would it work under plain jane WINE and not CrosssOver?
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-04-19 04:54
You probably have the 64bit version of wine installed and CrossOver's wine is 32bit... There's a wiki page that deals with this sort of stuff:

http://www.codeweavers.com/support/wiki/linux/faq/Ubuntu/PrecisePangolin

Look under "Installation". You have two apt-get commands that will install almost anything CX's wine can potentially need.

Since I don't know what you copied and where, you may need to un-install CX and re-install...

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==