CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Ubuntu 14.04 - Dependency is not satisfiable: ia32-libs
Carl Moser
Carl Moser Dragon Turbo Chief Senior Advocate
Posted 2014-04-20 06:38

Crossover installation error:  Dependency is not satisfiable: ia32-libs

Will not install on Ubuntu 14.04

Carl
Jason V
Jason V
Posted 2014-04-20 07:18
I'm having the exact same issue with Ubuntu 14.04LTS.  Looking for a resolution.
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-04-20 07:29
What version of CrossOver is that? I'm betting one of the older ones...

Anyway, you can try to get CX installed in two ways:

1) download the bin installer and then look at this page to get dependencies installed:

http://www.codeweavers.com/support/wiki/linux/faq/Ubuntu/PrecisePangolin

Scroll to "Installation" and check the two apt-get commands. Package names are the same for Ubuntu 14.04... there may be some that have no 32bit package, like libtiff4

2) download the newer deb file but bear in mind that you may have issues with CX if using the FOSS video drivers. More info here:

http://www.codeweavers.com/support/wiki/linux/faq/Ubuntu

Trusty is not yet "officially" supported.
Charles Talk
Charles Talk
Posted 2014-04-20 10:03
Hi All,

Ran into this previously on Saucy (13.10) when they went full on 64-bit. There are a number of ways to overcome this:

1) Add the i386 architecture to your instance of Trust:

user@host:~$ sudo dpkg --add-architecture i386

2) I rebuilt the last multiarch package for Saucy from Raring and deployed that as an alternative (grab that package and rebuild for yourself or you can use mine, though it worked for most, one person said it did not work for them):

http://chucktalk.com/2013/11/05/webex-multiarch-support-in-saucy/

Instructions are there, as with all such packages, YMMV and the first option may be better for you.

HTH, DWBH, HAND.

Chuck
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-04-20 10:22
Trusty is not saucy... the ia32-libs meta package is not even there any more. It's been deprecated for some releases now and looks they finally dropped it. No need to:

sudo dpkg --add-architecture i386 


either.

Actually, IIRC it wasn't available on Saucy either... Raring was the last to carry it.
Alexander Tornow
Alexander Tornow Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 2
Posted 2014-04-20 11:57
Silviu Cojocaru Posted:
Trusty is not saucy... the ia32-libs meta package is not even there any more. It's been deprecated for some releases now and looks they finally dropped it. No need to:

sudo dpkg --add-architecture i386 


either.

Actually, IIRC it wasn't available on Saucy either... Raring was the last to carry it.


Hello,

That's interesting.

That kind of information should be noted right here. Otherwise it can be a bit confusing. It would be nice if someone could add a line of information in that Ubuntu section, explaining what version of Ubuntu that command is meant for. Also, it would be nice to let the user know which version of the officially supported distributions are actively and "officially" supported. Adding and updating that information right here would be useful.

Cheers,
Alex
Charles Talk
Charles Talk
Posted 2014-04-20 14:11
True,

Trusty is not Saucy nor Raring. However, if you use some applications, they do require 32-bit libraries (Webex being one) in order to operate. Do I wish they would update their software? Yes, I do. However, they have not. Works for me, but YMMV.

Have a nice day.
Caron Wills
Caron Wills
Posted 2014-04-21 09:32
We are working to update CrossOver this morning for some known issues with Ubuntu 14.04.

Until then, we've got a bit of documentation that should help out:

 http://www.codeweavers.com/support/wiki/linux/faq/Ubuntu

The "ia32-libs" dependency not being satisfiable means you're using an older version of CrossOver. ia32-libs is "typically" not in use any more. Other messages about problems with dependencies should all be covered in the above link. If not, drop us a line and we'll update what we have.
Alexander Tornow
Alexander Tornow Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 2
Posted 2014-04-21 12:12
Caron Wills Posted:
We are working to update CrossOver this morning for some known issues with Ubuntu 14.04.


Sweet!

My Crossover license runs out next month. I'll be renewing my Crossover license the moment you guys update and offer the newest version of Crossover for Ubuntu 14.04 32- and 64-bit via USC. I hope everything needed works fully automated by then.

Cheers,
Alex

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==