CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Fedora x64 games fails
Oliver Leiteritz
Oliver Leiteritz
Posted 2014-04-22 02:19
Hello!

Ich have some troubles running games in crossover, wine or with playonlinux. I installed crossover normal and I'm also able to run applications e.g. Office 2010 without any issues. But know I tried to install the game "Thief", also with no problems, but if in try to play the game it always crashes.


This is the log file from crossover:
(its the same error for wine or playonlinux)

Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x00673dd4).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:00673dd4 ESP:0033f894 EBP:0033fa28 EFLAGS:00010206(  R- --  I   - -P- )
EAX:00000000 EBX:04f89570 ECX:00000028 EDX:0033f9d8
ESI:04f892b8 EDI:00000000
Stack dump:
0x0033f894:  0033f8a8 00000000 00000130 0077053c
0x0033f8a4:  04f89570 00000000 00000000 00000000
0x0033f8b4:  00000000 00000000 00000000 00000000
0x0033f8c4:  00000000 00000000 00000000 00000000
0x0033f8d4:  00000000 00000000 00000000 00000000
0x0033f8e4:  00000000 00000000 00000000 00000000
Backtrace:
=>0 0x00673dd4 in thief2_nd (+0x273dd4) (0x0033fa28)
0x00673dd4: movl 0x0(%eax),%edx
Modules:
Module Address Debug info Name (97 modules)
PE  400000-  c6e000 Export          thief2_nd
PE 10000000-101ff000 Deferred        d3dx9_43
PE 69580000-69fa8000 Deferred        lgvid
ELF 7b800000-7ba5e000 Deferred        kernel32<elf>
 \-PE 7b810000-7ba5e000 \               kernel32
ELF 7bc00000-7bce1000 Deferred        ntdll<elf>
 \-PE 7bc10000-7bce1000 \               ntdll
ELF 7bf00000-7bf03000 Deferred        <wine-loader>
ELF 7d47e000-7d4e5000 Deferred        dbghelp<elf>
 \-PE 7d490000-7d4e5000 \               dbghelp
ELF 7d4e5000-7d5d3000 Deferred        libasound.so.2
ELF 7d69f000-7d6ce000 Deferred        winealsa<elf>
 \-PE 7d6b0000-7d6ce000 \               winealsa
ELF 7d6ce000-7d805000 Deferred        oleaut32<elf>
 \-PE 7d6f0000-7d805000 \               oleaut32
ELF 7d805000-7d826000 Deferred        mmdevapi<elf>
 \-PE 7d810000-7d826000 \               mmdevapi
ELF 7d826000-7d86f000 Deferred        dsound<elf>
 \-PE 7d830000-7d86f000 \               dsound
ELF 7d86f000-7d978000 Deferred        opengl32<elf>
 \-PE 7d890000-7d978000 \               opengl32
ELF 7d978000-7dac3000 Deferred        wined3d<elf>
 \-PE 7d990000-7dac3000 \               wined3d
ELF 7dac3000-7db00000 Deferred        d3d9<elf>
 \-PE 7dad0000-7db00000 \               d3d9
ELF 7dc04000-7dc17000 Deferred        psapi<elf>
 \-PE 7dc10000-7dc17000 \               psapi
ELF 7dc17000-7dc4c000 Deferred        ws2_32<elf>
 \-PE 7dc20000-7dc4c000 \               ws2_32
ELF 7dc4c000-7dc77000 Deferred        msvfw32<elf>
 \-PE 7dc50000-7dc77000 \               msvfw32
ELF 7dc77000-7dcbd000 Deferred        avifil32<elf>
 \-PE 7dc80000-7dcbd000 \               avifil32
ELF 7dcbd000-7dcdb000 Deferred        libgcc_s.so.1
ELF 7dcdf000-7dd09000 Deferred        msacm32<elf>
 \-PE 7dcf0000-7dd09000 \               msacm32
ELF 7dd09000-7dd54000 Deferred        dinput<elf>
 \-PE 7dd10000-7dd54000 \               dinput
ELF 7dd54000-7dd78000 Deferred        imm32<elf>
 \-PE 7dd60000-7dd78000 \               imm32
ELF 7dd9a000-7dda0000 Deferred        libxfixes.so.3
ELF 7dda0000-7ddac000 Deferred        libxcursor.so.1
ELF 7ddac000-7ddbd000 Deferred        libxi.so.6
ELF 7ddbd000-7ddc1000 Deferred        libxcomposite.so.1
ELF 7ddc1000-7ddcc000 Deferred        libxrandr.so.2
ELF 7ddcc000-7ddd7000 Deferred        libxrender.so.1
ELF 7ddd7000-7dddd000 Deferred        libxxf86vm.so.1
ELF 7dddd000-7dde1000 Deferred        libxinerama.so.1
ELF 7dde1000-7dde5000 Deferred        libxau.so.6
ELF 7dde5000-7de07000 Deferred        libxcb.so.1
ELF 7de07000-7df43000 Deferred        libx11.so.6
ELF 7df43000-7df56000 Deferred        libxext.so.6
ELF 7df84000-7e018000 Deferred        winex11<elf>
 \-PE 7df90000-7e018000 \               winex11
ELF 7e045000-7e06e000 Deferred        libexpat.so.1
ELF 7e06e000-7e0ac000 Deferred        libfontconfig.so.1
ELF 7e0ac000-7e0e3000 Deferred        libpng16.so.16
ELF 7e0e3000-7e0f5000 Deferred        libbz2.so.1
ELF 7e0f5000-7e10c000 Deferred        libz.so.1
ELF 7e10c000-7e1b2000 Deferred        libfreetype.so.6
ELF 7e206000-7e23e000 Deferred        msvcr100<elf>
 \-PE 7e210000-7e23e000 \               msvcr100
ELF 7e23e000-7e26b000 Deferred        msvcr90<elf>
 \-PE 7e250000-7e26b000 \               msvcr90
ELF 7e26b000-7e318000 Deferred        msvcrt<elf>
 \-PE 7e280000-7e318000 \               msvcrt
ELF 7e318000-7e45d000 Deferred        msvcp90<elf>
 \-PE 7e360000-7e45d000 \               msvcp90
ELF 7e45d000-7e4e1000 Deferred        rpcrt4<elf>
 \-PE 7e470000-7e4e1000 \               rpcrt4
ELF 7e4e1000-7e61f000 Deferred        ole32<elf>
 \-PE 7e500000-7e61f000 \               ole32
ELF 7e61f000-7e723000 Deferred        comctl32<elf>
 \-PE 7e630000-7e723000 \               comctl32
ELF 7e723000-7e79d000 Deferred        shlwapi<elf>
 \-PE 7e730000-7e79d000 \               shlwapi
ELF 7e79d000-7e9d3000 Deferred        shell32<elf>
 \-PE 7e7b0000-7e9d3000 \               shell32
ELF 7e9d3000-7ea43000 Deferred        advapi32<elf>
 \-PE 7e9e0000-7ea43000 \               advapi32
ELF 7ea43000-7eb62000 Deferred        gdi32<elf>
 \-PE 7ea50000-7eb62000 \               gdi32
ELF 7eb62000-7ecbf000 Deferred        user32<elf>
 \-PE 7eb80000-7ecbf000 \               user32
ELF 7ecbf000-7ed77000 Deferred        winmm<elf>
 \-PE 7ecd0000-7ed77000 \               winmm
ELF 7ed77000-7ed85000 Deferred        libnss_files.so.2
ELF 7ef85000-7efd2000 Deferred        libm.so.6
ELF 7efe7000-7f000000 Deferred        version<elf>
 \-PE 7eff0000-7f000000 \               version
ELF f73a3000-f73a8000 Deferred        libdl.so.2
ELF f73a8000-f7580000 Deferred        libc.so.6
ELF f7580000-f759c000 Deferred        libpthread.so.0
ELF f75c0000-f75ca000 Deferred        librt.so.1
ELF f75ca000-f777f000 Dwarf           libwine.so.1
ELF f7780000-f77a6000 Deferred        ld-linux.so.2
ELF f77a8000-f77a9000 Deferred        [vdso].so
Threads:
process  tid      prio (all id:s are in hex)
00000008 winewrapper.exe
00000009    0
0000000c services.exe
00000023    0
00000022    0
0000001b    0
00000018    0
00000014    0
00000012    0
0000000e    0
0000000d    0
00000010 mscorsvw.exe
00000017    0
00000016    0
00000015    0
00000011    0
00000019 winedevice.exe
0000001f    0
0000001e    0
0000001d    0
0000001a    0
00000020 plugplay.exe
00000025    0
00000024    0
00000021    0
00000026 explorer.exe
00000028    0
00000027    0
00000029 (D) C:\GOG Games\Thief 2 - The Metal Age\Thief2_ND.exe
0000002d    0
0000002c    0
0000002a    0 <==
System information:
   Wine build: wine-1.7.4-7236-g69b3f64
   Platform: i386
   Host system: Linux
   Host version: 3.15.0-0.rc2.git0.1.fc21.x86_64


I installed directx in the bottle and use the install file from GOG, but nothing changed.
My Hardware:

Core i3-2348M CPU @ 2.30GHz with integrated GPU
8GB RAM

This is what I get from lspci:
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

I installed the Intel Xorg driver and also the mesa driver...(x64 and i686) maybe I forget something of the drivers?

Thanks for the help!
J-P Simard
J-P Simard Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 4
Posted 2014-04-23 06:33
Could you run cxdiag? You will find it in either /opt/cxoffice/bin or ~/cxoffice/bin.
Oliver Leiteritz
Oliver Leiteritz
Posted 2014-04-23 13:57
Here is what i got:


[MissingLibCapi20]
"Level"="Suggest"
"Title"="Missing 32bit libcapi20.so.3 library"
"Description"="Provides support for some ISDN cards. Very few applications need this."

[MissingLibHal]
"Level"="Suggest"
"Title"="Missing 32bit libhal.so.1 library"
"Description"="This may be needed for Windows applications to automatically detect CD-ROM and USB key insertion."

[MissingLibMpg123]
"Level"="Suggest"
"Title"="Missing 32bit libmpg123.so.0 library"
"Description"="Needed by some Windows applications to play MP3 files."

[MissingLibOsmesa]
"Level"="Suggest"
"Title"="Missing 32bit libOSMesa.so.6 library"
"Description"="This is needed by some games and CAD-like applications to perform off-screen rendering."

[MissingLibSane]
"Level"="Recommend"
"Title"="Missing 32bit libsane.so.1 library"
"Description"="Lets Windows applications access scanners."

[MissingLibTiff]
"Level"="Suggest"
"Title"="Missing 32bit libtiff.so.4 library"
"Description"="This is needed by some applications that need to manipulate TIFF images in their user interface."

[MissingLibV4l1]
"Level"="Suggest"
"Title"="Missing 32bit libv4l1.so.0 library"
"Description"="Lets Windows applications access video devices."

[Properties]
"display.depth"="24"

[Properties]
"opengl.vendor"="Intel Open Source Technology Center"

[Properties]
"opengl.version"="3.0 Mesa 10.1.1"

[Properties]
"opengl.renderer"="Mesa DRI Intel(R) Sandybridge Mobile "
Stefan Dösinger
Stefan Dösinger  Staff Member
Posted 2014-04-23 15:47
Does glxgears work?
Oliver Leiteritz
Oliver Leiteritz
Posted 2014-04-23 23:22
Yes thats no problem, I can play Doom3 with the linux installer also without any problems.
J-P Simard
J-P Simard Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 4
Posted 2014-04-24 09:58
Just to make sure, are we talking about thief or thief 2? I have the games up to 3, so I would try on my end.
Oliver Leiteritz
Oliver Leiteritz
Posted 2014-04-24 11:21
I also bought thief 1 -3 but all parts ends with the same error. Installation is no problem but it will not working... I only know it is not a supported app from codeweavers but there is a install tie for it and it should work...? But maybe there is a problem with fedora for that or something with my intel driver and wine... I don't know.
J-P Simard
J-P Simard Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 4
Posted 2014-04-24 11:23
Actually, I did use those a while back, but I can't remember which version of Crossover. There were glitches, but no outright crashes. So I would count this as a regression. I'll test things out tonight, and see how things are on my end.
Oliver Leiteritz
Oliver Leiteritz
Posted 2014-04-24 11:30
Thanks alot for the help!

It's not important but would be great if it's working. So no hurry ;)
But thanks again!
J-P Simard
J-P Simard Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 4
Posted 2014-04-24 18:40
I have the original boxed version, not the GOG version...

Well, I installed T2, and it crashed. I patched it to 1.18 and now it starts but it asks for the CD, which it doesn't see. That being said, at some point it crashed, now it asked for the CD. I had trouble installing it, so I'm not entirely surprised. The patch seems to have "helped", but since the GOG version is already 1.18, I don't really see how it helped.  It is some progress, and might actually launch at some point. I think there is some hope, but other duties are calling me for tonight.

Oliver Leiteritz
Oliver Leiteritz
Posted 2014-04-25 01:46
I tried the patch 1.19 (the fanpatch) but it's also the same error.
But I also have the next week other duties, so we will see;)

If I have time I will also try other things out...
Oliver Leiteritz
Oliver Leiteritz
Posted 2014-05-24 14:24
Hey!

i don't know what was happening the last weeks, but now everything works perfectly. I tested thief also with playonlinux and use the debuging for it. One result was, that my libgl (intel driver) didn't support some options. I used nm -d to find the right lib and changed it, without any result (only the error was changing).
So I moved everything back to the original and didn't changed anything. But now after a update of my system, everything is working, perfectly!

J-P Simard
J-P Simard Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 4
Posted 2014-05-25 06:48
I didn't have much time of late, so I didn't get around to do much testing. I'm glad the problems seems to have resolved.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==