CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Installing MDAC 2.8 hangs
Dirk Schnelle-Walka
Dirk Schnelle-Walka
Posted 2014-06-02 04:03
Hey there,

I am trying to install Enterprise Architect 11 into a fresh bottle. All goes fine until it tries to it comes to the point where it says: Installing MDAC 2.8

I waited apprx 30 minutes but nothing happened. After that I tried to cancel the install without much success, so I killed crossover on my Fedora 20. In the background there were still some processes that are running on consuming most of my processors. Some winewrapper process goes u to 100% CPU usage.

I cannot remove the bottle since it waits until it is able to determine which applications are installed in the bottle.

Any help is appreciated.

Dirk
Dirk Schnelle-Walka
Dirk Schnelle-Walka
Posted 2014-06-02 04:07
I just checked: The problem already appears, when I install only MDAC 2.8 SP1 in a new bottle.

Dirk

Output of top:
top - 14:23:59 up  1:14,  2 users,  load average: 2.40, 1.99, 1.88
Tasks: 205 total,   4 running, 201 sleeping,   0 stopped,   0 zombie
%Cpu(s): 15.8 us,  9.5 sy,  0.2 ni, 73.4 id,  0.2 wa,  0.7 hi,  0.2 si,  0.0 st
KiB Mem:   8080828 total,  4069516 used,  4011312 free,   132428 buffers
KiB Swap:  8142844 total,        0 used,  8142844 free,  1833168 cached

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
 7606 dirk      20   0 3832248   5376   4148 R 100.0  0.1   3:24.34 winewrappe+
 7604 dirk      20   0 3832312   5376   4152 R  96.9  0.1   3:24.28 winewrappe+
 2991 dirk      20   0  775432 196792  52532 S   6.5  2.4  21:09.37 skype
 6044 dirk      20   0  644796  19616  12948 S   6.5  0.2   0:01.75 gnome-term+
    1 root      20   0   50340   6680   3832 S   0.0  0.1   0:01.70 systemd
    2 root      20   0       0      0      0 S   0.0  0.0   0:00.01 kthreadd
    3 root      20   0       0      0      0 S   0.0  0.0   0:00.10 ksoftirqd/0
    5 root       0 -20       0      0      0 S   0.0  0.0   0:00.00 kworker/0:+


Current screenshot:



Edit: added top output and screenshot
Caron Wills
Caron Wills
Posted 2014-06-05 09:06
Dirk Schnelle-Walka Posted:
Hey there,

I am trying to install Enterprise Architect 11 into a fresh bottle. All goes fine until it tries to it comes to the point where it says: Installing MDAC 2.8

I waited apprx 30 minutes but nothing happened. After that I tried to cancel the install without much success, so I killed crossover on my Fedora 20. In the background there were still some processes that are running on consuming most of my processors. Some winewrapper process goes u to 100% CPU usage.

I cannot remove the bottle since it waits until it is able to determine which applications are installed in the bottle.

Any help is appreciated.

Dirk


I think you should open a Support Ticket and include the install log file. I also think you should include the output of:

/opt/cxoffice/bin/cxdiag


You might try installing mdac 2.8 into a fresh bottle and then installing Enterprise Architect 11.
Dirk Schnelle-Walka
Dirk Schnelle-Walka
Posted 2014-06-11 02:15
Thanks for the answer. I already opened a ticket http://www.codeweavers.com/support/tickets/browse/?ticket_id=993160 to solve this issue.

Dirk
Kevin Raulins
Kevin Raulins
Posted 2014-06-21 20:48
Hey Dirk,

Any chance you got that resolved?  I am having the same issue and have tried creating a new XP bottle and installing MDAC 2.8 and it hangs right out of the gate.  Just thought I'd ask since Google isn't being nice to me on this one.
Caron Wills
Caron Wills
Posted 2014-06-23 09:47
It's a kernel bug:

 https://lkml.org/lkml/2014/5/7/145

If you're on the 3.14.6 kernel, you should be able to open a terminal and run:

echo 1 > /proc/sys/abi/ldt16


It will re-enable the 16 bit code. This does come with some trouble. You should read more about it here:

 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1328965

or here:

 http://osdir.com/ml/ubuntu-bugs/2014-06/msg07982.html

Or other various sources.

Unfortunately, the broken behavior was back-ported to Ubuntu 14.04 and the fix has not yet been back-ported. Of course, MDAC 2.8 is affected by this issue. Our sincerest apologies.

We are working to improve the behavior within CrossOver and the commits are filtering to the various affected distros. If you would like to know when CrossOver has been updated with a fix, please write to ninjas@codeweavers.com and ask to be added to bug number 11938.
Kevin Raulins
Kevin Raulins
Posted 2014-06-27 05:05
Ahh, that makes sense.  I see a fix was committed in Trusty.  I'm still on Precise atm until the .1 version of Trusty comes out (sticking with the LTS upgrade schedule for stability).  I'll be upgrading as soon as the Trusty .1 release comes out though so no worries here.  Thanks for dropping the info in the forums for others to find as well.

FYI: I did attempt to email ninja@codeweavers.com to be added to the bug but received an error 550 unroutable address.  Not sure why I'm getting that but thought you should know.

Thanks!

-Kevin
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-06-27 05:28
Ugh, I think the proper email address was ninjas@codeweavers.com (notice the extra "s") but sending it to info@codeweavers.com should also work. Also, 12.04 suffers from the same problem currently since Canonical backported the security fix...
Kevin Raulins
Kevin Raulins
Posted 2014-06-27 10:42
Okay, that seems to have worked.  Thanks for the corrected email.

I figured that security fix would have been back-ported so I just thought I would upgrade to the latest LTS release once the .1 release is done.  Thanks again!

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==