CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Trial package install failed
glense78
glense78
Posted 2014-09-17 04:03
Hi,
I have successfully download the trial version 13.2.0.

Before install, i run : sudo dpkg --add-architecture i386 ; sudo apt-get update

But i have an error while installing the package :

Preparing to unpack /tmp/crossover_13.2.0-1.deb ...
This CrossOver Linux Debian package cannot be installed on top of a Loki or MojoSetup package.
dpkg: error processing archive /tmp/crossover_13.2.0-1.deb (--install):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/tmp/crossover_13.2.0-1.deb
red
My laptop is an ubuntu 14.04 LTS 64 bits (kernel 3.13.0-35).



Many thanks in advance for your assistance and help.

Regards.
William Harwin
William Harwin
Posted 2014-12-12 07:37
I get the same error on trying to update a previous install of crossover. The error returned via Ubuntu software centre is

This CrossOver Linux Debian package cannot be installed on top of a Loki or MojoSetup package.
dpkg: error processing archive /home/user/Downloads/crossover_14.0.3-1.deb (--install):
subprocess new pre-installation script returned error exit status 1

What is the resolution?
Łukasz Janowski
Łukasz Janowski Chief Senior Advocate
Posted 2014-12-12 08:16
I have came across the same issue last time when installing 14.03.
The workaround is to use the bin version instead of the Ubuntu package. However, I find it odd and I'd suggest to report the issue upstream.
I'd raise a ticket for it if I only knew hot to report bugs for crossover.
Caron Wills
Caron Wills
Posted 2014-12-17 11:45
William Harwin Posted:
I get the same error on trying to update a previous install of crossover. The error returned via Ubuntu software centre is

This CrossOver Linux Debian package cannot be installed on top of a Loki or MojoSetup package.
dpkg: error processing archive /home/user/Downloads/crossover_14.0.3-1.deb (--install):
subprocess new pre-installation script returned error exit status 1

What is the resolution?


Did you previously use the Ubuntu Software Center to install CrossOver? Did you previously use our bin (mojo) installer?

If you used the Ubuntu Software Center, you need to remove the old package:

    sudo apt-get remove crossover-trial-bin:i386

This information has now been added to our main page for Ubuntu:

    https://www.codeweavers.com/support/wiki/linux/faq/Ubuntu

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTg2NDQyNzI0fQ==