CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Trouble meeting libgphoto2 dependencies in Ubuntu 14.10 Utopic
Sandy Beggs
Sandy Beggs
Posted 2015-04-22 20:52
Trying to get trial version of  Crossover installed on Ubuntu 14.10 using dpkg. Following back through the dependencies for libgphoto2, I get to libvpx1:i386, and get the following error:

The following packages have unmet dependencies:
libvpx1 : Breaks: libvpx1:i386 (!= 1.3.0-3~trusty) but 1.3.0-2.1 is to be installed
libvpx1:i386 : Breaks: libvpx1 (!= 1.3.0-2.1) but 1.3.0-3~trusty is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Any advice on how to get past this? Is it caused by a PPA I have enabled?  I don't really care about libgphoto2, as I don't plan to have to access photo on a digital camera, but apparently Crossover will not install properly without it.  Obviously I'm not buying Crossover until I see if it works. TIA.
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2015-04-23 01:06
Why is there a package intended for Ubuntu 14.04 (trusty) on your 14.10 system? Did you use 14.04 and the upgraded to 14.10?  Were you using this ppa https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media ?
Sandy Beggs
Sandy Beggs
Posted 2015-04-23 17:39
Silviu Cojocaru Posted:
Why is there a package intended for Ubuntu 14.04 (trusty) on your 14.10 system? Did you use 14.04 and the upgraded to 14.10?  Were you using this ppa https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media ?


IDK, I allowed Ubuntu to upgrade itself. That ppa isn't in sources.list as of now. Maybe I could remove the trusty package and retry installing Crossover.
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2015-04-24 00:50
Yes, but it was probably there before the upgrade. I would go to the Ubuntu forums and IRC. I honestly never had to deal with this problem myself.
Sandy Beggs
Sandy Beggs
Posted 2015-04-24 22:42
I managed to get this to work by removing the current libvpx1 and reinstalling it. Must not have been updated when I upgraded Ubuntu. Now I have other problems with this, but this one is solved at least.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTg2NDQyNzI0fQ==