CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Can't get Crossover to work on Ubuntu 16.04

Hi, I have purchased a copy of Crossover for Linux and supposedly installed but can't get it running, if I download a .tie file and right click on it there is no option to open with Crossover.
Also I placed a game disk (original far cry 2) into the drive but can't access it, the drive errors and ejects the disk, the disk works in my old windows system.
Could someone please help?
I just double clicked on the file and opened with Crossover, seems to work but has now opened up Terminal to get missing packages, I'll enter password and see where that takes me.

Well I went through the install and it asked to install DX9 so I did and it locked up, nothing said about what to do, after 15mns I shut the computer down.
My Ubuntu system is stuffed!!! All the edges are white and an error symbol on the top bar says "An error occurred please run package manager" I ran the updates and after a reboot all seems well again.
I don't know what to do now, what has happened to the installed files I don't know, I dare not try installing Far Cry 2 until I get some advice.

When you let the downloaded deb file be opened with the Ubuntu Software app it will display this message:

"On 64-bit flavors of Debian and some Ubuntu variants, first open a terminal and run 'sudo dpkg --add-architecture i386 ; sudo apt-get update'."

Did you do this before installation?

sudo dpkg --add-architecture i386
sudo apt-get update

Hi, yes the 32 bit architecture has been set, I did that after installing Wine.
I had another go and got to the point of getting the icon on the desktop but clicking that for some reason started to get updates from Ubisoft.
I ended up going to my XP install and copying the files from there overwriting the new install files, I figured this would be better since it included the latest updates.
Now it fired up to the menu, saved some settings then quit back to the desktop but that caused the desktop screen size to change to the games screen size, that's a problem!!
Is there a fix? Maybe it can be run in a window but not sure how to do that.
In windows it is easy to edit the shortcut to add parameters so it would be "C:\Games\Far Cry 2\bin\FarCry2.exe" -GameProfile_SkipIntroMovies 1.
There are others also that can be added.
How do I add the parameters in Linux, the icon points to a lnk file that contains this:

exec "/opt/cxoffice/bin/wine" --bottle "Far_Cry_2" --check --wait-children --start "C:/users/Public/Desktop/Far Cry® 2.lnk" "$@" 


IF you manage to set the screen resolution inside the game once, probably this resizing will not happen again. I had this problem with Rocksmith 2014. What I did was to open Crossover, select the game bottle. In Control Panels, open "wine settings" or "wine config" (my Crossover is in Brazilian Portuguese, so I can't say the exact form). Choose the "Graphics" tab, select "Emulate Virtual Desktop" and choose a proper resolution. This will probably solve the resolution change problem.

The "C:/users/Public/Desktop/Far Cry® 2.lnk" is, in fact, the Windows link inside the Windows Bottle. If you edit this ".lnk" file, you can probably add the parameters you wish. You will need to use the icon to start the game, anyway. This ".lnk" file will be inside a path probably like "/home/YourUsername/.cxoffice/YourGame/drive_c/" unless you changed the default path.

Thanks, I managed to get the desktop resolution fixed (fixed itself), I will work on the parameters later, also when I start the game (using the desktop icon) it always starts to update from ubisoft, how can I stop that?

I don't know the behaviour of FarCry. Isn't updating before playing a normal behaviour, or even a requirement? If not, maybe there are some parameters in the "C:/users/Public/Desktop/Far Cry® 2.lnk" that are forcing an update? Or maybe it calls a different .exe file? Good luck!

No it's not normal, never happens on my old XP machine, something Codeweavers has thrown in.

What happens if you just let it update everything?

It updates every time I start it. The shortcut is weird!! I fail to see why Codeweavers made it to check for updates, it is already version 1.03.
Still can't get it running, and can't find where to put the parameters such as -GameProfile_SkipintroMovies 1 (normally placed after farcry2.exe)

Maybe it was not Codeweavers who made it check. It may be some weird side-effect of not running it from a real Windows S.O. ...

You can check it by running farcry2.exe with any parameters you like:

1) Open Crossover.
2) Go to Farcry bottle
3) In programs open the "Execute Command" icon.
4) Click on search, go through "Program Files" and find the farcry2.exe or whatever the executable file is named.
5) Add any parameters you like.
6) Press the "Execute" button.

If this works, you can repeat steps 1-5 and press "Create Launcher" button instead.

Good luck!

Yes that seems to have got it going, when you look at the shortcut properties and the link it is rather weird, neither the farcry2.exe or the parameters appear there but it works!!
When you stated "bottle" I didn't know what you were talking about, I searched the web and found the Crossover Linux User Guide pdf and printed it, I'll have to do some more reading!!

Good to hear that it worked! 😊

Probably the shortcut points to a .lnk file which contains the parameters you chose. That is why you don't see them directly.

This "bottle" concept is fantastic. It is like having many different Windows installations easily accessible. The main use is to make certain that one program does not interfere with another or because some programs need very specific types of installation to work that others may no work with. I really enjoy the "bottle" name... You know, wine... bottle... 😊

One query, where does the game save reside? it used to be in the: My Documents\My Games\Far Cry 2\ folder (windows)

I see 2 possibilities:

1) Go to your Farcry bottle folder. Inside it you will find drive_c/users/Public/Documents
2) Inside drive_c/users/crossover you will find a link pointing to your Linux user's Documents folder, that is, you may look directly in your Linux user's Documents folder!

1 to 14 of 14

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...