CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread and Guild Wars1

Hello, i am on ubuntu mate since 3 days and i downloaded gw and it was working fine until i tried to add some components to make work but now i can't play the game. The installation work fine until it has to reach something online and they put me a red message telling me i can't connect to arenanet.

For the installation work fine as well, i tried hearthstone for exemple but the picture when i launch it get distorted and with a terrible zoom and some cut that can't allow me to even click on anything.

As i said above i'm on linux ubuntu mate.
Sorry for my english, it isn't my native language and if you need more informations about my situation, i will gladly give them to you.

Thank you for your time

(ps, i wrote a message like this in the gw section but it isn't active so i wrote this one here but i didn't see the option to delete the message there)

You are best off doing GW and BNet in separate bottles. This way when messing with one of them, it will not break another.

Personally I would delete the bottle with both GW & BNet in it and create one for GW, and another for BNet. The software installer has a working setup for BNet for sure (Diablo and WoW are well tested by me), as I used it a few months back to rebuild my bottle (was time, lasted 8 years).


Thank you for your answer. I did seperate the bottles for the installations and the problem isn't with which is working fine. The bug with guild wars was from somewhere else and it is now fixe for reasons i don't know. When i finished installing and tried to launch hearthstone, there was tons of bugs that appeared on my screen like cuts, zooms, distortions etc. Hearthstone is also propose on the menu of app but it can't work for reasons i don't know because everything is installed.

I should maybe try to download diablo for exemple to be sure it is from hearthstone and not from but i don't think it's from there.

for Hearthstone try launching game with argument "-force-d3d9" (without quotes). You have to add it in Hearthstone game settings window in

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...