CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Installation broken on Debian Testing/Sid

Can you just please plain provide with native i386 and amd64 binary packages ?
The current packages are just plain annoying. I can't even install it on my box.

rrs@priyasi:/var/tmp$ sudo apt install ./crossover_16.2.5-1.deb 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'crossover:i386' instead of './crossover_16.2.5-1.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 crossover:i386 : Depends: libc6:i386 (>= 2.11) but it is not installable
                  Depends: libx11-6:i386 but it is not installable or
                           xlibs:i386 but it is not installable
                  Depends: libxext6:i386 but it is not installable or
                           xlibs:i386 but it is not installable
                  Depends: libxi6:i386 but it is not installable
                  Depends: libfreetype6:i386 but it is not installable
                  Depends: libpng12-0:i386 but it is not installable or
                           libpng16-16:i386 but it is not installable
                  Depends: libz1:i386 but it is not installable
                  Depends: libcups2:i386 but it is not installable
                  Depends: liblcms2-2:i386 but it is not installable
                  Depends: libglu1-mesa:i386 but it is not installable
                  Depends: libxcursor1:i386 but it is not installable
                  Depends: libxrandr2:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.
14:13 ♒♒♒    ☹  => 100  
rrs@priyasi:/var/tmp$ sudo ^C
14:13 ♒♒♒    ☹  => 130  
rrs@priyasi:/var/tmp$ apt policy libc6
libc6:

Have you tried

sudo apt-get -f install

?

Add 32 bit support if you've not done so then try to install.

dpkg --add-architecture i386 && apt-get update

Still won't install on Debian Sid

Dependencies can't be resolved

I have no problems on Debian Sid.

apt-cache policy crossover 
crossover:i386:
  Installiert:           16.2.5-1
  Installationskandidat: 16.2.5-1
apt-cache policy libc6:i386
libc6:i386:
  Installiert:           2.25-2
  Installationskandidat: 2.25-2
  Versionstabelle:
     2.26-0experimental1 1
          1 http://ftp.de.debian.org/debian experimental/main i386 Packages
 *** 2.25-2 500
        500 http://ftp.de.debian.org/debian unstable/main i386 Packages
        500 http://ftp.de.debian.org/debian testing/main i386 Packages
        100 /var/lib/dpkg/status

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoiWUprZVA1Z3RWTG1NTnY4cCIsImdkcHIiOjB9